Weitere Informationen und den Download findest du auf der offiziellen Anlaufstelle de.wordpress.org
Seite 1 von 4 123 ... LetzteLetzte
Ergebnis 1 bis 10 von 37
  1. #1
    PostRank: 0 Avatar von viehrig
    Registriert seit
    30.12.2012
    Beiträge
    19

    Artikel planen - Eingebette Videos verschwinden bei Veröffentlichung

    Vor einigen Wochen habe ich ein Upgrade meines Blogs von WP 3.2 auf 3.4 und nun auf 3.5 durchgeführt.
    Wie im Titel bereits erwähnt tritt seitdem ein Fehler im Zusammenhang mit der Planung eines Artikels auf. Der komplette Code zur Einbettung eines Videos ist im Moment der Veröffentlichung des geplanten Artikels verschwunden. Im Gegensatz dazu funktioniert er, wenn der Artikel

    1. sofort veröffentlicht wird
    2. im Dashbord in der Vorschau angezeigt wird
    3. nach geplanter Veröffentlichung der Video-Code nachträglich wieder eingefügt wird.

    Zur Fehlersuche bzw. Eingrenzung hatte ich bereits testweise sämtliche Plugins deaktiviert, ohne Veränderung, das heißt, der Fehler tritt trotzdem auf.

    Da ich Artikel ausschließlich in der HTML-Ansicht erstelle, nachfolgend ein Beispiel:

    HTML-Code:
     
    <center><iframe width="640" height="395" src="http://www.youtube-nocookie.com/embed/tvRjyLxcHSo?hd=1&amp;autohide=0&amp;rel=0&amp;showinfo=0" frameborder="0" allowfullscreen></iframe></center>
    <br />
    Daraus wird im Moment der geplanten Veröffentlichung des Artikels:
    HTML-Code:
    &nbsp;
    
    <br />
    Es sei angemerkt, daß der Fehler auch mit dem alten Embed-Code auftritt. Er tritt auch unabhängig vom Videohoster auf.

    Fragen:

    1. Woran kann das liegen?
    2. Wie kann ich das beheben?


  2. #2
    PostRank: 10
    Registriert seit
    17.05.2007
    Beiträge
    1.872
    und wenn du nur den Link zum Video postest, auf einer Zeile? Eigentlich geht das doch über oEmbed automatisch, also ohne iframe...

  3. #3
    PostRank: 0 Avatar von viehrig
    Registriert seit
    30.12.2012
    Beiträge
    19
    @Narcanti

    Zunächst einmal danke für die Reaktion.

    Um ehrlich zu sein, ich verstehe nicht genau, wie die Frage gemeint ist. Wenn ich lediglich den Link zum Video einfüge, dann erscheint in dem Artikel auch nur der Link zum Video, was ja auch der Sinn der HTML-Ansicht des Editors sein sollte.

    Im übrigen, wie oben bereits am Beispiel ersichtlich, möchte ich die Standard-Einbettung (beispielsweise von YouTube) in der Regel nicht verwenden und ändere sie in der Regel deshalb auch entsprechend ab. Das hat aber mit dem Fehler nichts zu tun. Auch die Standard-Einbettung habe ich versucht, der Fehler tritt auch dann auf.

  4. #4
    PostRank: 10
    Registriert seit
    17.05.2007
    Beiträge
    1.872
    Wenn du einen Link zu einem Video einfügst und WordPress dafür oEmbed aktiviert hat, wird das Video automatisch eingebettet und es erscheint eben nicht nur der Link.
    https://codex.wordpress.org/Embeds
    Aber wenn das bei dir nicht funktioniert, liegt der Fehler wohl wo anders.

  5. #5
    PostRank: 0 Avatar von viehrig
    Registriert seit
    30.12.2012
    Beiträge
    19
    @Narcanti

    Ganz herzlichen Dank für den Link! Der Artikel ist ein echter Augenöffner.

    Der Fehler ist in den Augen der Entwickler von WP also gar kein Fehler, sondern Feature. WP schränkt die Möglichkeiten, Videos in das eigene Blog einzubetten, erheblich ein, erleichtert dafür aber die Handhabung der einzig verbliebenen Einbettungsmöglichkeit. Der Apple-Weg halt. Damit ist auch klar, daß das absehbar nicht behoben wird. Im Gegenteil hat man nun auch noch seit Version 3.5 die Möglichkeit gestrichen, dies wenigstens abzuschalten.

    Nun, das ist nicht mein Weg.

    Vorgehensweise für diejenigen, die das auch nicht haben und ebenfalls weiterhin selbst entscheiden wollen, wie sie vom wem welche Medien einbinden:

    Downgrade

    Voraussetzung: FTP-Zugang zum eigenen Blog, die meisten Hoster bieten dafür auch ein entsprechendes Web-Interface.

    Backup der Wordpress-Datenbank anlegen, herunterladen und sicher speichern.

    1. Download der letzten 3.4-Version von Wordpress (3.4.2) von hier:

    Deutsch
    http://wpde.org/files/2012/09/wordpress_342-de.zip

    Englisch/International
    http://wordpress.org/wordpress-3.4.2.zip

    2. Speichern auf eigenem Rechner und entpacken.

    3. Alle Plugins deaktivieren

    4. Löschen sämtlicher Worpress-Ordner auf dem eigenen Webspace, ausgenommen des Ordners "wp-content"

    5. Löschen sämtlicher WP-Dateien auf dem eigenem Webspace, ausgenommen ".htaccess", "wp-config.php"

    6. Die Ordner der Version 3.4.2 hochladen, ausgenommen "wp-content"

    7. Die entsprechenden WP-Dateien des Hauptverzeichnisses an die entsprechende Stelle hochladen

    8. Den Admin-Zugang bzw. Login-Bereich aufrufen

    9. Einloggen

    10. Den Anweisungen zur Aktualisierung der Datenbank folgen

    11. Im Admin-Bereich (Dashboard) auf Einstellungen --> Mediathek gehen

    12. Haken entfernen bei "Einbettungen" --> "Automatische Einbettungen" --> "Versuchen Sie wenn möglich, Medieninhalte einer eingegebenen Adresse direkt im Artikel einzubetten. Beispielsweise für flickr oder YouTube."

    13. Speichern durch Klick auf "Änderungen übernehmen"

    14. Vorläufig auf Upgrades von WP verzichten

    Nun funktionieren die Einbettungen der Medien wieder wie gewohnt und können selbst umfassend individuell gestaltet werden.

    Danke nochmals, @Narcanti!
    Geändert von viehrig (31.12.2012 um 00:16 Uhr)

  6. #6
    PostRank: 0 Avatar von viehrig
    Registriert seit
    30.12.2012
    Beiträge
    19
    PS:

    @Narcanti

    Unter Link hatte ich verstanden, ein normales HTML-Tag zu bilden, also

    <a href="URL" target="_blank">verlinkter Text</a>

    gemeint war wohl aber der reine URL, richtig?
    Geändert von viehrig (31.12.2012 um 02:14 Uhr)

  7. #7
    PostRank: 10
    Registriert seit
    17.05.2007
    Beiträge
    1.872
    Viehrig, ja meinte ich.
    Leider ist der von dir gewählte Lösungsweg der falsche. WP 3.5 enthält ja nicht nur oEmbed, sondern schließt auch andere Sicherheitslücken, die du mit 3.4.2 wieder öffnest.
    oEmbed lässt sich für einzelne Websites (Provider) oder auch ganz deaktivieren.
    Hier z.B. Lösung für Twitter: http://bueltge.de/twitter-oembed-deaktiveren/1421/

    Komplett deaktiveren lässt sich oEmbed in WP 3.5 mit einer Zeile:
    PHP-Code:
    // Disable auto-embeds for WordPress >= v3.5
    remove_filter'the_content', array( $GLOBALS['wp_embed'], 'autoembed' ), ); 

  8. #8
    PostRank: 0 Avatar von viehrig
    Registriert seit
    30.12.2012
    Beiträge
    19
    @Narcanti

    Nochmals vielen Dank! Auch noch am Sylvestertag hier helfend präsent zu sein, ist ganz großartig!

    Bleiben mir abschließend einige Fragen: Wo füge ich den Code ein? In welche Datei? Oder gehört der in eine eigene PHP-Datei ausgelagert, die ich als eigenes Plugin in den Plugins-Ordner verschiebe, so wie es Herr Bültge bezüglich Twitter vorschlägt?

    Guten Rutsch!

  9. #9
    PostRank: 0 Avatar von viehrig
    Registriert seit
    30.12.2012
    Beiträge
    19
    Kurzer Zwischenbericht

    Als eigenes Plugin in einen eigenen Plugin-Ordner ausgelagert habe ich den Code folgendermaßen getestet:

    PHP-Code:
    <?php
    /*
    Plugin Name: Disable auto-embeds
    Description: Disable auto-embeds in WordPress >= 3.5
    Version:     1.0.0
    */

    remove_filter'the_content', array( $GLOBALS['wp_embed'], 'autoembed' ), );

    ?>
    In dieser Weise funktioniert er schon mal nicht. Höchstwahrscheinlich habe ich da ein paar Fehler drin, nur welche?

    Nun aber: Bis nächstes Jahr!

  10. #10
    PostRank: 10
    Registriert seit
    17.05.2007
    Beiträge
    1.872
    Hast Du's schon mal in der functions.php deines Themes versucht?

Seite 1 von 4 123 ... LetzteLetzte

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •