Weitere Informationen und den Download findest du auf der offiziellen Anlaufstelle de.wordpress.org
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 11
Like Tree3Likes

Thema: Seite schaltet immer auf https um und ist sehr langsam

  1. #1
    PostRank: 0
    Registriert seit
    19.04.2017
    Beiträge
    3

    Seite schaltet immer auf https um und ist sehr langsam

    Hallo.
    Wir haben eine Seite von einem Kunden übernommen. Er hat eine ZIP und eine installer.php beosrgt. Provider weiß ich nicht, wer das war. Aber ich denke, die Rest deuten auf Linux Hoster hin.
    Die Seite haben wir nun bei uns eingespielt (Apache Windows) und angepasst. Die Seite war vorher schon langsam, weil es meiner Meinung nach ein überladenes Template ist, aber "/egal".
    Wir haben nun das Problem, dass die Seite sofort auf https umschaltet und auch ansonsten auch sehr langsam ist. Aber halt noch mal ein Stück langsamer als unter Linux.

    Nun meine Frage: Kann ich irgendwo feststellen, an welcher Stelle er auf https geht?
    .htaccess ist meiner Meinung nach nicht das Problem. Da steht nicht viel drin. Auch im Backend habe ich nichts gefunden. Aber irgendwo muss ja.....

    Wenn ihr noch Angaben außer der URL braucht, dann bitte melden.
    die URL: www.straubingerosten.de
    bzw. www.straubinger-osten.de

    Viele Grüße
    Andreas


  2. #2
    PostRank: 10 Avatar von JABA-Hosting
    Registriert seit
    29.03.2016
    Beiträge
    1.774
    Wo schaltet die Seite auf HTTPS um? Bei mir nicht. Die Seite ist auch nicht per HTTPS zu erreichen.

    Aber ja, langsam ist die Seite extrem.

  3. #3
    PostRank: 10 Avatar von SirEctor
    Registriert seit
    28.10.2008
    Beiträge
    9.606
    Bei mir schaltet auch nichts auf https um. Aber hier mal ein paar Gründe, warum die Seite so langsam ist:

    • Server antwortet sehr langsam (3,5 Sek. TTFB)
    • 43 Javascripts, die geladen werden müssen
    • 24 Stylesheet-Dateien
    • Kein Gzip oder ähnliches aktiviert
    • kein Browser-Caching
    • sämtliche Bilder sind nicht optimiert und werden nur per CSS runter skaliert
    • usw.
    Das Geheimnis des Könnens liegt im Wollen!

  4. #4
    PostRank: 0
    Registriert seit
    19.04.2017
    Beiträge
    3
    Danke für Eure Hilfe. Die Anregungen von SirEctor werde ich mir ansehen.
    Komisch allerdings, dass bei meinem FireFox im F12 Fenster solche Zeilen stehen wie:

    GET https://straubingerosten.de/wp-conte...ebook_dark.png net::ERR_CONNECTION_RESET

    Hab auch schon Cache geleert. Ohne Erfolg. Ist das evtl. browser-abhängig? Wäre totaler Kram, aber wer weiß?

  5. #5
    r23
    r23 ist offline
    PostRank: 10
    Registriert seit
    09.12.2006
    Beiträge
    3.724
    Zitat Zitat von fischerandreas Beitrag anzeigen
    bei meinem FireFox im F12 Fenster solche Zeilen stehen wie:

    GET https://straubingerosten.de/wp-conte...ebook_dark.png net::ERR_CONNECTION_RESET
    bei mir nicht.

    URLs stehen in der Datenbank bei jedem Beitrag, Seite ...
    und

    Admin => Einstellungen hier Allgemein

    einige Theme Autoren hauen auch schon mal Links fest in das Theme.

    Zitat Zitat von fischerandreas Beitrag anzeigen
    Ist das evtl. browser-abhängig? Wäre totaler Kram, aber wer weiß?
    wenn man keine Ahnung hat - sollte man evtl. die Finger von dem Job lassen?
    Edi likes this.

  6. #6
    PostRank: 10 Avatar von b3317133
    Registriert seit
    21.11.2014
    Beiträge
    1.887
    Zitat Zitat von fischerandreas Beitrag anzeigen
    Hab auch schon Cache geleert. Ohne Erfolg.
    Welchen Cache hast Du geleert? Euer Theme hat in den Theme-Options einen eigenen Code- und Bildercache, meinst Du den?

    Die .zip Datei und installer.php stammt aller Wahrscheinlichkeit nach aus dem Plugin Duplicator (das man als WordPress-Dienstleister kennen sollte).
    Geändert von b3317133 (19.04.2017 um 16:47 Uhr) Grund: Ergänzung

  7. #7
    PostRank: 0
    Registriert seit
    19.04.2017
    Beiträge
    3
    @b3317133. Nein, den mein ich nicht. Hab ich zwar auch schon geleert, aber trotzdem.
    Ich meine den Browser-Cache. Im IE funktioniert z.B. http://www.straubinger-osten.de/wir-ueber-uns-2/ ohne Probleme. Schnell.
    Im FF und Chrome will er ständig https.....

    Die ständigen Seitenhiebe in allen möglichen Foren nerven übrigens. Viele Postings triefen von Ratschlägen, die nix mit dem eigentlichen Problem zu tun haben. Hier war das bisher die Ausnahme.

    Aber: "was man als WP-Dienstleister kennen sollte" und "wenn man keine Ahnung hat....." Erstens ist keiner allwissend, zweitens hab ich vom Browser-Cache geschrieben, drittens bin ich kein WP-Dienstleister, viertens helfen solche "Hilfestellungen" auch nicht weiter. Schade um die Tipparbeit. Man sollte sich eher um die Problembehebung kümmern......

    Das Problem besteht also weiterhin, dass die Seite mit dem IE relativ schnell angezeigt wird und https nicht verlangt wird. Im FF und Chrome dauert es 10 sec. bis endlich mal Inhalt kommt. Die Seite will dann auf https....
    Browser-Cache habe ich geleert.

    Viele Grüße

  8. #8
    PostRank: 10 Avatar von JABA-Hosting
    Registriert seit
    29.03.2016
    Beiträge
    1.774
    Privat Modus im Firefox oder chrome testen.

  9. #9
    PostRank: 5
    Registriert seit
    02.01.2016
    Ort
    Schweiz
    Beiträge
    455
    Das du hier diese "Seitenhiebe" geschrieben bekommst liegt vermutlich an folgendem:
    Du outest dich hier als Dienstleister - haben von einem Kunden übernommen - und stellst Fragen die wir nun für dich beantworten sollen.
    Da ich selber kein Profi bin, kann ich nicht alles nachvollziehen. Aber ich weis das ein Fachmann und der willst du angeblich sein, mehr Hintergrundwissen haben sollte als andere und was ich hier so rauslese sind die meisten dieser Probleme hier solche, die man als Fachmann selber lösen sollte. Aber das ist meine Vermutung. Dazu kommt eben das wir hier Gratis lösen sollen was du vermutlich in Rechnung stellst. Aber auch das ist reine Vermutung. Ich will dich damit auch nicht angreifen oder so, sondern nur aufzeigen worum es geht.

    Mich persönlich stört es schon das du von einem Microsoft Server sprichst und der Linux Server so sagen wir, als schlecht hingestellt wird. So klingt es zumindest für mich und persönlich würde ich auch wieder behaupten das Linux/Unix besser wäre. Aber meine Zeit im Server Bereich ist schon zu lange zurück, vielleicht sind MS Produkte ja mittlerweile wirklich gut. Wobei ich noch nie einen Webhoster hatte der mir MS angeboten hat.
    Dazu kommt das es so klingt als wäre das euer eigener Server. Also ein Rechner irgendwo in eurem Büro, ist dem so? Denn wenn eine Website lahm ist, kann es ja durchaus auch an dem liegen. Denn leider erwähnst du nirgends das andere Websites auf diesem Server problemlos laufen.

    Was das https angeht, kein Browser stellt einfach von http auf https um. Der Befehl muss irgendwoher kommen. Gerade bei Links (und Grafiken sind ja auch nichts anders als Links) kann es gerne mal vorkommen das direkte Adressen gesetzt wurden und dort dann ein s drin vorkommt.
    Wenn ich mir aber ansehe was SirEctor da geschrieben hat, würde ich dort mal anfangen mit dem Ausmisten und vielleicht gehts dann ja schon schneller
    Edi likes this.
    gruss Benzli

  10. #10
    Edi
    Edi ist offline
    PostRank: 10 Avatar von Edi
    Registriert seit
    26.07.2006
    Ort
    Zürich
    Beiträge
    3.650
    Zitat Zitat von fischerandreas Beitrag anzeigen
    Man sollte sich eher um die Problembehebung kümmern...
    Wer ist hier "man"? Wer hier wie Support leistet, muss Dich nicht kümmern. Und dass sich die Bereitschaft in Grenzen hält, für einen, der WordPress als Dienstleistung verkauft (und behauptet, er sei kein WordPress-Dienstleister), die Sache kostenlos zu machen, ist mehr als verständlich.

    Wenn Du mit einem Windows-Server werkeln willst, ist das Deine Sache. Nur, wundere Dich dann nicht, wenn WordPress nicht richtig läuft. Und hier entsprechende Kommentare von Leuten mit Erfahrung geschrieben werden.
    Col Pain likes this.

Seite 1 von 2 12 LetzteLetzte

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •