Weitere Informationen und den Download findest du auf der offiziellen Anlaufstelle de.wordpress.org
Ergebnis 1 bis 8 von 8
  1. #1
    PostRank: 0
    Registriert seit
    14.07.2017
    Beiträge
    3

    Linux Woocommerce Permalinks funktionieren nicht.

    Guten Tag,

    ich habe mir wordpress heruntergeladen damit ich mir ein kleines shopsystem einrichten kann.

    doch leider sobald ich einen Produkt mit "WooCommerce" erstellt habe sowie auch einen Menu dazu erstellt und auf dem Menu Button klicke kommt eine error meldung:


    ************************************************** ****

    Not FoundThe requested URL /shop/ was not found on this server.

    Apache/2.4.10 (Debian) Server at *********Port 80

    ************************************************** ****

    Bei der instllation von wordpress habe ich eine eigene wordpress datenbank erstellt sowie einen eigenen ftp benutzer wo ich wordpress hochgeladen habe und installiert.


    Würde mich über eine antwort - Hilfe sehr freuen.

    Grüsse

    Ivan


  2. #2
    Edi
    Edi ist offline
    PostRank: 10 Avatar von Edi
    Registriert seit
    26.07.2006
    Ort
    Zürich
    Beiträge
    3.397
    Ist das Module mod_rewrite auf dem Server installiert und aktiviert?
    Was ich auch noch mache und garantiert nicht mit WordPress zu tun hat: Fidus-Projekt.

  3. #3
    PostRank: 10 Avatar von Hille
    Registriert seit
    22.01.2012
    Beiträge
    7.422
    Existiert die Seite /shop denn überhaupt? Ist mod_rewrite aktiviert? Wurde eine .htaccess generiert?

  4. #4
    PostRank: 0
    Registriert seit
    14.07.2017
    Beiträge
    3
    Hallo, ehm ich kenne mich nicht so perfekt aus ich habe das an meinem windows root server getestet und da hab ich es mit xaammp problem los zum laufen gebracht.

    Ich habe einfach ein menu punkt erstellt danach einen produkt und dann an die menu bar leiste hinzugefügt dann ging das das wunderbar aber leider nicht bei linux bzw habe bisschen probleme..

    eine .htaccess datei wurde nach der installation von wordpress automatisch angelegt.

    mod_rewrite aktivert ? hmm gute frage .. ich habe einen vserver mit linux kann ich dies iwo nachlesen ? oder kann dies nur der hoster ?

    Grüsse

    Ivan

  5. #5
    PostRank: 9
    Registriert seit
    04.09.2014
    Beiträge
    1.125
    Wenn du einen vserver hast lass den Mal richtig einrichten das alles sauber und stabil läuft...

    Das ist ein WordPress Forum, und Server forum

  6. #6
    PostRank: 0
    Registriert seit
    14.07.2017
    Beiträge
    3
    Der vserver ist bereits eingerichtet mit den nötigen packete.

    Verstehe die aussage nicht ganz..

    Wordpress funktioniert wunderbar nur das ich keine permalinks erstellen kann.

  7. #7
    Edi
    Edi ist offline
    PostRank: 10 Avatar von Edi
    Registriert seit
    26.07.2006
    Ort
    Zürich
    Beiträge
    3.397
    Wenn mod_rewrite installiert und aktiviert ist, aber nicht funktioniert, musst Du Dich an Deinen Hoster wenden.
    Was ich auch noch mache und garantiert nicht mit WordPress zu tun hat: Fidus-Projekt.

  8. #8
    PostRank: 10 Avatar von Hille
    Registriert seit
    22.01.2012
    Beiträge
    7.422
    Hast du einen VServer mit root Zugang oder Managed VServer?
    Falls du einen root Zugang hast, was ich nicht hoffe, musst du folgende Befehle ausführen

    a2enmod rewrite
    /etc/init.d/apache2 restart

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •