Weitere Informationen und den Download findest du auf der offiziellen Anlaufstelle de.wordpress.org
Ergebnis 1 bis 2 von 2
  1. #1
    PostRank: 0
    Registriert seit
    24.08.2014
    Beiträge
    1

    Multisite Problem

    Ich habe nachträglich eine WP-Seite zur Multisite umgewandelt (Subdomain). Die Basis-Site (Mastersite) yyy.de funktioniert auch, die Startseite der Unterseite blog.yyy.de sowie die Admit-Seite funktioniren auch.
    Klicke ich jedoch einen Beitrag an, dann kommt die 404 Not found Fehlerseite. Wie ich diesen Knoen durchschlagen kann, ist mir allerdings auch nach längerem Suchen schleierhaft. Vielleicht hat hier ja jemand eine Idee.

    Aus der config.php:
    PHP-Code:
    define('WP_ALLOW_MULTISITE'true);
    define('MULTISITE'true);
    define('SUBDOMAIN_INSTALL'true);
    define('DOMAIN_CURRENT_SITE''www.yyy.de');
    define('PATH_CURRENT_SITE''/');
    define('SITE_ID_CURRENT_SITE'1);
    define('BLOG_ID_CURRENT_SITE'1); 
    Aus der .htaccess:
    Code:
    <IfModule mod_rewrite.c>RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    
    </IfModule>
    Die Apache-Konfig der Seite:
    Code:
    <VirtualHost *:80>        ServerAdmin post@yyy.de
            ServerName yyy.de
            ServerAlias www.yyy.de
            DocumentRoot /var/www/vhosts/yyy.de/wordpress/
    
    
            <Directory /var/www/vhosts/yyy.de/wordpress/>
                    Options Indexes FollowSymLinks MultiViews
                    AllowOverride All
                    Order allow,deny
                    allow from all
    
    
            </Directory>
    
    
    #        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    #        <Directory "/usr/lib/cgi-bin">
    #                AllowOverride None
    #                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    #                Order allow,deny
    #                Allow from all
    #        </Directory>
    
    
            ErrorLog ${APACHE_LOG_DIR}/error.log
    
    
            # Possible values include: debug, info, notice, warn, error, crit,
            # alert, emerg.
            LogLevel warn
    
    
            CustomLog ${APACHE_LOG_DIR}/access.log combined
    
    
        Alias /doc/ "/usr/share/doc/"
        <Directory "/usr/share/doc/">
            Options Indexes MultiViews FollowSymLinks
            AllowOverride None
            Order deny,allow
            Deny from all
            Allow from 127.0.0.0/255.0.0.0 ::1/128
        </Directory>
    
    
    </VirtualHost>
    
    </VirtualHost>
    
    
    <VirtualHost *:80>
    DocumentRoot /var/www/vhosts/yyy.de/wordpress
    ServerName blog.yyy.de
    ServerAlias www.blog.yyy.de
    </VirtualHost>
    Die Frage ist hier, muss ich jede Subdomain in der Apache-Konfig anlegen? Oder liegt hier mein Fehler?


  2. #2
    PostRank: 0
    Registriert seit
    13.12.2016
    Beiträge
    3
    hardcore programmieren

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •