Weitere Informationen und den Download findest du auf der offiziellen Anlaufstelle de.wordpress.org
Ergebnis 1 bis 5 von 5
  1. #1
    PostRank: 1
    Registriert seit
    13.02.2016
    Beiträge
    38

    Login-Schwierigkeiten

    Hallo!

    Folgende Situation:
    * MS-Installation (Subdomain) unter xyz.do
    * dort Website abc.xyz.do angelegt
    * Login aus MS-Inst ("Dashboard") funzt (obgleich ich in Erinnerung habe, das auch das zunächst Probleme bereitete... ist jetzt aber schon ein paar Stunden her...)

    Soweit, so gut.
    Nun dieses:
    * domain 123.do wird beim Provider umgeleitet auf abc.xyz.do (Proxy)
    * in "Websites" der MS-Inst, Feld "Website-Adresse (URL)" 123.do eingetragen
    * Login ("Dashboard") funzt nicht. Meldung: Cookies nicht aktiviert...

    Daraufhin:
    * sämtliche Cookies zu WP gelöscht - keine Änderung, selbe Meldung
    * von anderer Maschine versucht einzuloggen (via user 123 und dem mir zugegangenen PW) - keine Änderung, selbe Meldung
    * Website/Reiter Einstellungen geprüft: Site/Home-URL steht auf 123.do

    Soweit ich die MS-Doku und Hinweise von Experten verstanden habe, müsste das doch eigentlich so funktionieren - oder verstehe ich da etwas nicht?

    Danke!!!


  2. #2
    PostRank: 10 Avatar von Hille
    Registriert seit
    22.01.2012
    Beiträge
    7.579
    Läuft die Seite etwas auf einem Windows Server??
    Bedenke, WordPress benutzt absolute URL's. Was hast du als Blog und Site URL festgelegt? Welche URL nutzt du, um die Seite aufzurufen?

  3. #3
    PostRank: 1
    Registriert seit
    13.02.2016
    Beiträge
    38
    Vielen Dank für die Antwort!

    1. Die Site liegt auf einem Linux-Server.
    2. Home/Siteurl (Reiter Einstellungen): 123.do; Setze ich diese auf abc.xyz.do, und lasse unter Info die Website-Adresse auf 123.do, erhalte ich einen Seiten-Ladefehler: "Die aufgerufene Website leitet die Anfrage so um, dass sie nie beendet werden kann. Dieses Problem kann manchmal auftreten, wenn Cookies deaktiviert oder abgelehnt werden."
    2.1. Ich meine das gestern auch schon probiert zu haben, allerdings war da das Ergebnis ein anderes: Die Site wurde angezeigt und eine Meldung angezeigt, von wegen dass die Site noch nicht Registriert sei (o.ä. - kann ich jetzt nicht reproduzieren...)
    3. Die Site wird über 123.do aufgerufen
    ---
    Die exakte Login-Fehlermeldung lautet: "FEHLER: Cookies sind gesperrt oder werden von deinem Browser nicht unterstützt. Du musst Cookies aktivieren, um WordPress verwenden zu können." (Firefox)
    Ich habe die Annahme von Drittanbieter-Cookies Testweise auf "Immer" eingestellt: Keine Änderung.
    ---
    Was bedeutet das, dass WP absolute URL's benutzt?

    Danke!!!

  4. #4
    PostRank: 10 Avatar von b3317133
    Registriert seit
    21.11.2014
    Beiträge
    1.872
    Wenn der Website über 123.do aufgerufen wird, stelle die Einstellungen auf 123.do und passe ggf. alle Pfade in der Datenbank auf 123.do an.

    Wenn der Website über abc.xyz.do aufgerufen werden soll, siehe oben, aber mit abc.xyz.do

  5. #5
    PostRank: 1
    Registriert seit
    13.02.2016
    Beiträge
    38
    Das Problem ist wohl gelöst. Mir haben die ständigen Cookie-Hinweise keine Ruhe gelassen. Unter http://toscho.de/2013/wordpress-mult...reren-domains/ habe ich den wohl entscheidenen Hinweis gefunden.

    Also "define('COOKIE_DOMAIN','');" in wp-config.php eingetragen, zur Sicherheit nochmal sämtliche WP-Cookies gelöscht - und siehe da, der Login ist möglich.

    Weshalb ich mich allerdings als bereits angemeldeter Super-Administrator nochmal anmelden muss, obwohl ich den "Dashboard"-Link nutze (der auf 123.do/wp-admin zeigt), verstehe ich (noch) nicht.

    Wie auch immer, es geht jetzt. Vielen Dank für die Hinweise und möge anderen geholfen sein!

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •