Weitere Informationen und den Download findest du auf der offiziellen Anlaufstelle de.wordpress.org
Ergebnis 1 bis 9 von 9
  1. #1
    PostRank: 0
    Registriert seit
    18.03.2012
    Beiträge
    12

    Wordpress Multisite Cookie-Problem

    Hallöchen, Ich mal wieder.

    Mittlerweile stehen die 3 Wordpress Domains und die Multisite ist auch erreichbar.
    Leider bekomme ich beim anmelden auf den "neuen" Domains (also nicht auf der seite wo ich wordpress installiert habe) immer den Fehler
    Code:
     FEHLER: Cookies sind gesperrt oder werden von deinem Browser nicht unterstützt. Du musst Cookies aktivieren, um WordPress verwenden zu können.


    Kann mir jemand sagen, wie ich den wegbekomme ?
    Ich hab schon ein wenig gegoogelt und einige Foren meinten, dass ich
    Code:
    define( 'COOKIE_DOMAIN', '' );
    (oder ähnliche schreibweisen) einfügen soll. Leider bekomme ich dann die Fehlermeldung
    Code:
    The constant "COOKIE_DOMAIN" is defined (probably in wp-config.php). Please remove or comment out that define() line.

    Ich verzweifel solangsam...

    // In den Einstellungen von dem Domain Mapping Plugin habe ich folgende einstellungen aktiviert:



    1. Remote Login
    2. Permanent redirect (better for your blogger's pagerank)
    3. User domain mapping page
    4. Redirect administration pages to site's original domain (remote login disabled if this redirect is disabled)


    Geändert von MrDeeTop (15.11.2017 um 00:35 Uhr)


  2. #2
    PostRank: 1
    Registriert seit
    31.10.2012
    Beiträge
    37
    Ja das kenne ich... Hast Du das Netzwerk mit Untervezeichnissen eingerichtet oder mit Subdomains?
    Wenn es mit Domains laufen soll: Netzwerk mit Subdomains einrichten.
    Dann kannst Du in den Einstellungen für die einzelnen Sites die Domain als URL angeben. Das Plugin brauchst Du eigentlich nicht.

    Code:
    define( 'COOKIE_DOMAIN', '' );
    Hab ich auch gesetzt.

  3. #3
    PostRank: 0
    Registriert seit
    18.03.2012
    Beiträge
    12
    Zitat Zitat von WebbR Beitrag anzeigen
    Ja das kenne ich... Hast Du das Netzwerk mit Untervezeichnissen eingerichtet oder mit Subdomains?
    Wenn es mit Domains laufen soll: Netzwerk mit Subdomains einrichten.
    Dann kannst Du in den Einstellungen für die einzelnen Sites die Domain als URL angeben. Das Plugin brauchst Du eigentlich nicht.

    Code:
    define( 'COOKIE_DOMAIN', '' );
    Hab ich auch gesetzt.
    Ich habe das ganze über Subdomains eingerichtet. Es soll im endeffekt aber über eigenständige .de Domains laufen und nicht über subdomains.
    Wenn ich das in die config.php einfüge, bekomme ich den Error
    Code:
    The constant "COOKIE_DOMAIN" is defined (probably in wp-config.php). Please remove or comment out that define() line

  4. #4
    PostRank: 10 Avatar von mensmaximus
    Registriert seit
    24.07.2014
    Ort
    Krefeld
    Beiträge
    6.398
    @MrDeeTop hast Du einmal Deinen eigenen Thread bis zum Ende verfolgt? Wordpress Multisite mit Hauptdomains
    Geheimtipp: Forenregeln mit Informationen zu wichtigen Inhalten in Beiträgen.

  5. #5
    PostRank: 0
    Registriert seit
    18.03.2012
    Beiträge
    12
    Zitat Zitat von mensmaximus Beitrag anzeigen
    @MrDeeTop hast Du einmal Deinen eigenen Thread bis zum Ende verfolgt? Wordpress Multisite mit Hauptdomains
    ja. leider (wenn ich diese Zeile einfüge) kommt bei allen Browsern die ich hier habe (heißt Internetexplorer, Firefox, Chrome) sowohl beim normalen als auch beim Inkognito Browser diese Cookie-Fehlermeldung. Und sobald ich das aus der config wieder rausnehme, kann ich mir zwar auf der Haupt-Seite wo es installiert wurde einloggen, aber nicht auf den anderen und aufs Dashboard von den anderen komme ich auch nicht drauf...

  6. #6
    PostRank: 10 Avatar von mensmaximus
    Registriert seit
    24.07.2014
    Ort
    Krefeld
    Beiträge
    6.398
    Ich glaube Du hast immer noch das Domain Mapping Plugin aktiviert
    Geheimtipp: Forenregeln mit Informationen zu wichtigen Inhalten in Beiträgen.

  7. #7
    PostRank: 0
    Registriert seit
    18.03.2012
    Beiträge
    12
    Zitat Zitat von mensmaximus Beitrag anzeigen
    Ich glaube Du hast immer noch das Domain Mapping Plugin aktiviert
    Natürlich. So wie ich das verstanden habe kann ich ohne das Plugin nur mit Verzeichnissen oder Subdomains arbeiten oder ? Oder muss ich die Sub-Domains einfach nur in die normale Domain umbenennen und gut is ?

    //EDIT Ich hab das Domain Mapping jez mal einfach deaktiviert. Leider bekomme ich immernoch den Cookie-fehler und wenn ich den define ... wieder einfüge, bekomme ich wieder den Cookie-Fehler beim login...

    //EDIT2 in der config stand noch define( 'SUNRISE', 'on' ); drin. Das habe ich mit // auskommentiert. Brauche ich das Domain-Mapping-Plugin überhaupt noch für irgendwas ?
    PS: Login funktioniert jetzt auch (denke einfach mal dank dem define cookie_domain

    //EDIT3 Habe grade in dem anderen Thread nachgelesen: Man kann drauf verzichten. Habe auch mal (rein aus neugierde) das define Cookie_Domain auskommentiert. Klappt trotzdem Also: Auch das braucht man nicht zwingend ^^
    Geändert von MrDeeTop (15.11.2017 um 18:58 Uhr)

  8. #8
    PostRank: 10 Avatar von mensmaximus
    Registriert seit
    24.07.2014
    Ort
    Krefeld
    Beiträge
    6.398
    Deswegen hatte ich ja gefragt ob Du den Thread bis zum Ende gelesen hast
    Geheimtipp: Forenregeln mit Informationen zu wichtigen Inhalten in Beiträgen.

  9. #9
    PostRank: 0
    Registriert seit
    18.03.2012
    Beiträge
    12
    Zitat Zitat von mensmaximus Beitrag anzeigen
    Deswegen hatte ich ja gefragt ob Du den Thread bis zum Ende gelesen hast
    Habs jetzt nochmal versucht. man muss wohl doch das define cookie-domain drin lassen Aber sonst sollte jez alles klappen Danke

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •