Weitere Informationen und den Download findest du auf der offiziellen Anlaufstelle de.wordpress.org
Ergebnis 1 bis 8 von 8
  1. #1
    PostRank: 0
    Registriert seit
    18.11.2017
    Beiträge
    3

    WordPress Multisite, kein Menü 'Meine Webseiten'

    Hallo,

    ich habe eine WordPress Multisite (Version 4.9)eingerichtet und diese macht Probleme.

    Laut Anleitung habe ich per

    define('WP_ALLOW_MULTISITE', true);

    in der wp-config.php die Multisite eingerichtet und anschließend über Netzwerk-Einrichtung den Punkt Sub-Verzeichnisse gewählt.
    Folgende Ergänzungen habe ich dann gemacht.

    wp-config.php

    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'hdb-edv-loesungen.de');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    ..htaccess
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]


    Dann habe ich mich aus dem WordPress Backend ab- und wieder angemeldet.

    Nun sollte in der Menüleiste des Backends oben „Meine Webseiten“ angezeigt werden. Dies ist aber nicht erfolgt.
    Ich kann dann natürlich keine neuen Webseiten einrichten.

    Was habe ich falsch gemacht? Wer kann mir helfen?

    MfG Detlef


  2. #2
    PostRank: 2
    Registriert seit
    31.10.2012
    Beiträge
    64
    Meine htaccess sieht so aus... Also der von der Netzwerkinstalltion kommende Teil ist vorne angefügt.
    Code:
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Ansonsten sieht das alles auf den ersten Blick gut aus.

  3. #3
    PostRank: 0
    Registriert seit
    18.11.2017
    Beiträge
    3
    Hallo WebbR,
    habe meine htaccess geändert. Keine Änderung, kein Webseiten Menü.
    Habe eine Testinstallation unter hdb-edv-loesungen.de eingerichtet.
    Adminzugang unter Benutzer: Gast, PW: GastKlaus
    Vielleicht kann dann der Fehler gefunden werden.
    MfG

  4. #4
    PostRank: 2
    Registriert seit
    31.10.2012
    Beiträge
    64
    JUNGE!!!! Du traust dich was!!! Lösch diesen Zugang!!!

  5. #5
    PostRank: 2
    Registriert seit
    31.10.2012
    Beiträge
    64
    Habe gerade mal kurz reingesehen... Also scheinbar hat dein WP nicht gerafft, dass es als Netzwerk laufen soll...

    Unter Netzwerk-Einrichtung gibt es eine Warnung
    Warnung: Ein bestehendes WordPress-Netzwerk wurde gefunden.
    Was das heißt, dazu kann ich dir leider nicht mehr sagen als dass irgendwas nicht geklappt hat.

    Ich würde das Ganze neu aufsetzten und step by step nochmal machen. Und ggf. mal den Webhoster anfragen ob denn die Anforderungen für Multisite gegeben sind.


    Viel Glück!!!

  6. #6
    PostRank: 0
    Registriert seit
    18.11.2017
    Beiträge
    3
    Hallo WebbR,
    jetzt zeigt sich das fehlende Webseiten Menü.
    Ich musste die folgenden Anweisungen nur nach oben, direkt hinter
    define('WP_DEBUG', false);
    einfügen und nicht ans Ende der Datei.

    /* Multisite */
    define('WP_ALLOW_MULTISITE', true);

    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    define('DOMAIN_CURRENT_SITE', 'eurobrick.de');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    /* Das war’s, Schluss mit dem Bearbeiten! Viel Spaß beim Bloggen. */
    /* That's all, stop editing! Happy blogging. */

    /** Der absolute Pfad zum WordPress-Verzeichnis. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    /** Definiert WordPress-Variablen und fügt Dateien ein. */
    require_once(ABSPATH . 'wp-settings.php');

    MfG

  7. #7
    PostRank: 2
    Registriert seit
    31.10.2012
    Beiträge
    64
    Prima! Kann es ja los gehen
    Aber Zugangsdaten solltest Du wirklich besser in einer PN versenden...

  8. #8
    PostRank: 0
    Registriert seit
    27.03.2007
    Beiträge
    11
    Danke, dass Du das mit dem Versetzen geschrieben hast, genau das war bei mir auch der Fehler, superfreu.....
    Liebe Grüsse Gabi [WordPress MU WordPress 4.9.1]

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •