Weitere Informationen und den Download findest du auf der offiziellen Anlaufstelle de.wordpress.org
Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 18 von 18
Like Tree5Likes

Thema: Seitentitel wird nicht angezeigt

  1. #11
    PostRank: 4
    Registriert seit
    03.02.2016
    Beiträge
    280
    Ich würde sagen es gibt weder einen geheimnisvollen Button noch ein vergessenes oder verstecktes Häkchen.
    Es ist wie richtig gesehen ein Social Media Menü und kein frei zuordenbares Menü!
    Die 12 Möglichkeiten sind im style.css ab Zeile 923 vorgegeben und mit den codierten Icons versehen!
    Wenn du nun einen eigenen href eingibst, der ab 923 nicht definiert ist kommt keine Anzeige!

    Ich habe nun z.B. den fac...k Link css-Zeile 926 auf den Münster-Essen Link und den content: von '\f09a'; auf "Münster" geändert und schon ist Münster verlinkt.
    Ob das allerdings im Sinne dieses Menüs ist .......?
    Essen in D.jpg
    rentalight likes this.
    nothing is so easy as it looks

  2. #12
    PostRank: 3
    Registriert seit
    13.06.2017
    Ort
    Im hohen Norden
    Beiträge
    149
    Ja genau... der Sinn dieses Menüs, zumindest in dieser Ausführung, wie ich es in diesem Tehme (aktuell, da heute morgen erst runtergeladen und installiert) erschließt sich mir nicht!
    Wenn es denn schon als Social Media Menü im Theme integriert ist, dann würde ich erwarten, dass mir beim Einrichten und Bearbeiten dieses Menüs die gängigen Sachen, wie Facebook, Twitter, Instagramm und Co in irgendeiner Form zur Auswahl angeboten werden - oder zumindest eine Hilfefunktion angeboten wird, die mir sagt, wie es geht.
    Stattdessen bekomme ich, wie bei anderen Menüs auch, die Auswahl dort Seiten, Beiträge.... und individuelle Links als Menüpunkt hinzuzufügen. Aber anscheinend funktioniert keine der Optionen, weil immer nur dieses 1x1 Pixel screen-reader-text span eingefügt wird - oder will der Entwickler des Themes tatsächlich was für die Weiterbildung der Nutzer tun und sie dazu bringen, sich in den Tiefe der styles.css die richtigen Zeilen auszusuchen um dort einen einfachen Link zu Münster.de einzubauen - ok, da mit Umlaut würde das auch nicht funktionieren.
    Letztlich ist es wohl aber auch nicht dafür gedacht individuelle Links darzustellen... eben Social-Media... aber dann ist es nicht benutzerfreundlich gemacht.
    rentalight likes this.

  3. #13
    PostRank: 0
    Registriert seit
    09.09.2017
    Beiträge
    10
    Danke für eure ausführlichen Antworten!
    Den CSS Code von dir habe ich mal in die entsprechende Datei einfügt.
    Hierbei wurde mir die gesamte Website gecrashed!
    Hatte nur noch einen Whitescreen und keinerlei Zugriff mehr auf irgendwas. Sowohl Website als auch Backend waren nicht zugänglich ...

  4. #14
    PostRank: 0
    Registriert seit
    09.09.2017
    Beiträge
    10
    Wenn ich deinen Code in die normale style.css einfüge funktioniert es!

    EDIT: Aber leider nur am PC. Die mobile Version zeigt weiterhin keine Namen an...
    Geändert von rentalight (10.09.2017 um 21:25 Uhr)

  5. #15
    PostRank: 3
    Registriert seit
    13.06.2017
    Ort
    Im hohen Norden
    Beiträge
    149
    In welche (entsprechende) Datei hast du den Code denn eingefügt? Ein CSS Code kann dir zwar dein Design zerschießen - aber die komplette Webseite crashen lassen? Und wenn es so wäre und es läge an dem Code, den ich gepostet habe, dann täte es mir wirklich leid ! Aber an dem Code ist nichts geheimnisvolles und schon gar nichts gefährliches.

    In Sachen Anzeige auf einem Smartphon... ja, da wird noch irgendwo eine @media query in deinem CSS sein, die die Formate für kleine Displays anpasst und dann kann es sein, dass der zusätzliche CSS Code wieder 'überschrieben' wird.
    rentalight likes this.

  6. #16
    PostRank: 0
    Registriert seit
    09.09.2017
    Beiträge
    10
    Guten Morgen Sailor,
    ich habe leider beim Editor nicht auf die Dateiendung geachtet.
    Du sagtest nur etwas von "Customizer". Die einzige Datei mit "Customizer" war leider eine php. Datei.
    D.h. ich hab mir die entsprechende Datei dann aufm FTP rausgesucht. Nun würde es theoretisch auf allen Desktopversionen laufen, aber nicht mobil

  7. #17
    PostRank: 4
    Registriert seit
    03.02.2016
    Beiträge
    280
    Zitat Zitat von rentalight Beitrag anzeigen
    Guten Morgen Sailor,
    ich habe leider beim Editor nicht auf die Dateiendung geachtet.
    Du sagtest nur etwas von "Customizer". Die einzige Datei mit "Customizer" war leider eine php. Datei.
    D.h. ich hab mir die entsprechende Datei dann aufm FTP rausgesucht. Nun würde es theoretisch auf allen Desktopversionen laufen, aber nicht mobil
    ich bin jetzt nicht Sailor56,

    aber Änderungen NIEMALS in den Originaldateien machen!
    Wenn vom Customizer geschrieben wird, dann heißt das Dashboard - Design - Customizer - Zusätzliche CSS!
    Das ist meistens der letzte Menuepunkt.
    Dabei sieht man in time was die Änderung auslöst.
    Wenn du in den originalen Dateien fuhrwerkst ist das mit dem nächsten Update wieder weg, zusätzlich kannst du bei unsachgemäßer Behandlung ohne weiteres WP crashen.
    Wenn eine Änderung in Dasteien notwendig erscheint dann ist ein Childtheme anzulegen Pflicht.

    Die zu tode editierte Datei kannst du per FTP wieder gegen ein Original austauschen.
    rentalight likes this.
    nothing is so easy as it looks

  8. #18
    PostRank: 3
    Registriert seit
    13.06.2017
    Ort
    Im hohen Norden
    Beiträge
    149
    .. ist klar, CSS ist eben kein PHP.
    Dann ist es eventuell doch mein Fehler - in Beitrag #10 hatte ich geschrieben
    Füge folgenden Code in das 'zusätzliche CSS' (im Dashboard unter 'Design' -> 'Custumizer') ein
    War vielleicht nicht deutlich genug! Ansonsten ist das, was SEpp55 geschrieben hat, absolut korrekt! Fummel niemals an den Origanldateien herum, es sei denn es gibt dafür einen guten Grund und du weißt, was du machst.
    Aber das löst jetzt natürlich dein Problem nicht. Leider kann ich das auch nicht nachvollziehen und deswegen keine weitere Hilfe anbieten, bei meiner lokal installierten Testversion deines Themes läuft das (mit exakt dem CSS... eingefügt unter Dashboard -> Design -> Customiser -> zusätzliches CSS) fehlerfrei für alle Bildschirmgrößen (von 280px bis 1600px). Ich kann auch keine @media query im CSS finden und eine JavaScript Funktion, die dort was ändert sehe ich auch nicht.
    Möglich wäre allerdings, dass auf dem SmartPhone unterschiedliche Betriebssysteme (Android, Apple, Windows) unterschiedlich reagieren - oder auch der verwendete Browser auf dem SmartPhone dort Probleme macht.
    Da hilft nur ausprobieren, bis man den Fehler besser lokalisieren kann, um dann vielleicht gezielter vorgehen zu können.
    rentalight likes this.

Seite 2 von 2 ErsteErste 12

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •