Weitere Informationen und den Download findest du auf der offiziellen Anlaufstelle de.wordpress.org
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12
  1. #1
    PostRank: 1
    Registriert seit
    25.09.2014
    Beiträge
    29

    Fehlermeldung: Cannot modify header information

    Hallo liebe Foren-User,

    habe heute das erste mal versucht WordPress 4.0 zu installieren. Bin dabei nach der bekannten 5 min Installationsanleitung vorgegangen. Leider erhielt ich während der Installation folgende Fehlermeldungen:

    Warning
    : Cannot modify header information - headers already sent by (output started at /homepages/34/d123940350/htdocs/TAG-Fussballcamp/wp-config.php:1) in /homepages/34/d123940350/htdocs/TAG-Fussballcamp/wp-login.php on line 418

    Warning: Cannot modify header information - headers already sent by (output started at /homepages/34/d123940350/htdocs/TAG-Fussballcamp/wp-config.php:1) in /homepages/34/d123940350/htdocs/TAG-Fussballcamp/wp-login.php on line 431

    Bei der Installation früherer WordPress Seiten (mit älteren WP-Versionen) auf dem gleichen Webspace bei 1&1 (natürlich andere Domain / Verzeichnis / Datenbank) klappte es immer problemlos. Ich hoffe Ihr könnt mir sagen, was da los ist. Danke!

    MfG Thomas


  2. #2
    PostRank: 1
    Registriert seit
    25.09.2014
    Beiträge
    29
    Anmerkung. Die per SuFu gefundenen Tipps "Keine Zeichen vor <?php>" und utf-8 Speicherung habe ich bereits beherzigt. Ohne Erfolg!

  3. #3
    PostRank: 7 Avatar von AmFearLiath
    Registriert seit
    12.08.2012
    Ort
    München
    Beiträge
    731
    hast Du die /wp-config.php auch überprüft?

    Dort in Zeile 1 ist ein Fehler

  4. #4
    PostRank: 1
    Registriert seit
    25.09.2014
    Beiträge
    29
    Hallo AmFearLiath,

    danke für die Info. Da ich mich mit Programmierung leider überhaupt nicht auskenne, hilft mir diese Antwort noch nicht weiter, da ich den Fehler nicht erkennen würde. Habe mal aus diesem Grund den Inhalt meiner wp-config.php unten eingefügt. Vielleicht kannst Du mir ja den Fehler sagen. Die Angaben zur Datenbank etc. hab ich mal mit XXX unkenntlich gemacht. Danke und Grüße Thomas

    <?php
    /**
    * In dieser Datei werden die Grundeinstellungen für WordPress vorgenommen.
    *
    * Zu diesen Einstellungen gehören: MySQL-Zugangsdaten, Tabellenpräfix,
    * Secret-Keys, Sprache und ABSPATH. Mehr Informationen zur wp-config.php gibt es
    * auf der {@link http://codex.wordpress.org/Editing_wp-config.php wp-config.php editieren}
    * Seite im Codex. Die Informationen für die MySQL-Datenbank bekommst du von deinem Webhoster.
    *
    * Diese Datei wird von der wp-config.php-Erzeugungsroutine verwendet. Sie wird ausgeführt,
    * wenn noch keine wp-config.php (aber eine wp-config-sample.php) vorhanden ist,
    * und die Installationsroutine (/wp-admin/install.php) aufgerufen wird.
    * Man kann aber auch direkt in dieser Datei alle Eingaben vornehmen und sie von
    * wp-config-sample.php in wp-config.php umbenennen und die Installation starten.
    *
    * @package WordPress
    */

    /** MySQL Einstellungen - diese Angaben bekommst du von deinem Webhoster. */
    /** Ersetze database_name_here mit dem Namen der Datenbank, die du verwenden möchtest. */
    define('DB_NAME', 'db545969539');

    /** Ersetze username_here mit deinem MySQL-Datenbank-Benutzernamen */
    define('DB_USER', 'XXX');

    /** Ersetze password_here mit deinem MySQL-Passwort */
    define('DB_PASSWORD', 'XXX');

    /** Ersetze localhost mit der MySQL-Serveradresse */
    define('DB_HOST', 'XXX');

    /** Der Datenbankzeichensatz der beim Erstellen der Datenbanktabellen verwendet werden soll */
    define('DB_CHARSET', 'utf8');

    /** Der collate type sollte nicht geändert werden */
    define('DB_COLLATE', '');

    /**#@+
    * Sicherheitsschlüssel
    *
    * Ändere jeden KEY in eine beliebige, möglichst einzigartige Phrase.
    * Auf der Seite {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
    * kannst du dir alle KEYS generieren lassen.
    * Bitte trage für jeden KEY eine eigene Phrase ein. Du kannst die Schlüssel jederzeit wieder ändern,
    * alle angemeldeten Benutzer müssen sich danach erneut anmelden.
    *
    * @seit 2.6.0
    */
    define('AUTH_KEY', 'put your unique phrase here');
    define('SECURE_AUTH_KEY', 'put your unique phrase here');
    define('LOGGED_IN_KEY', 'put your unique phrase here');
    define('NONCE_KEY', 'put your unique phrase here');
    define('AUTH_SALT', 'put your unique phrase here');
    define('SECURE_AUTH_SALT', 'put your unique phrase here');
    define('LOGGED_IN_SALT', 'put your unique phrase here');
    define('NONCE_SALT', 'put your unique phrase here');

    /**#@-*/

    /**
    * WordPress Datenbanktabellen-Präfix
    *
    * Wenn du verschiedene Präfixe benutzt, kannst du innerhalb einer Datenbank
    * verschiedene WordPress-Installationen betreiben. Nur Zahlen, Buchstaben und Unterstriche bitte!
    */
    $table_prefix = 'wp_';

    /**
    * For developers: WordPress debugging mode.
    *
    * Change this to true to enable the display of notices during development.
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    */
    define('WP_DEBUG', false);

    /* That's all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

  5. #5
    PostRank: 7 Avatar von AmFearLiath
    Registriert seit
    12.08.2012
    Ort
    München
    Beiträge
    731
    schau mal, ob in der wp-config.php als allererste Zeile eine Leerzeile steht, wenn ja dann löschen, das <?php muss in der ersten Zeile und an erster Stelle stehen.

    Mit welchem Programm hast Du die Datei bearbeitet? Dafür kommen nur reine Texteditoren wie Notepad, Notepad++ in Frage, Mit Word sollte man solche Dateien nicht bearbeiten.

    Für die Zukunft, solltest Du hier Codes posten, gewöhn Dir bitte auch an, den dafür entsprechenden [code] Tag zu benutzen, dann sind Codes besser lesbar

  6. #6
    PostRank: 1
    Registriert seit
    25.09.2014
    Beiträge
    29
    Hallo und danke für die Antwort. Meine Reaktion ist etwas verspätet, weil ich beruflich unterwegs und damit nicht am PC war.

    Es standen keine Leerzeilen vor <?php und ich habe natürlich auch mit dem Editor (von Win) gearbeitet. Aber genau da lag das Problem. Als UTF-8 abgespeichert wurde die besagte Fehlermeldung erzeugt, als ich die wp-config.php jedoch als ANSI abgespeichert habe gab es keine Fehler mehr bei der WP-Installation. Ich dachte nur der Dateityp UTF-8 BOM würde Probleme machen, soweit ich das lesen konnte?

    Auf alle Fälle scheint das Problem damit gelöst. Bezüglich der Hinweise Code zu posten beziehungsweise einen [code] Tag zu benutzen, weiß ich allerdings nicht so recht wie ich das machen soll, sorry.

    Viele Grüße Thomas

  7. #7
    PostRank: 7 Avatar von AmFearLiath
    Registriert seit
    12.08.2012
    Ort
    München
    Beiträge
    731
    schön dass Du das Problem gelöst und das Ergebnis hier mitgeteilt hast...

    bezüglich der [code] tags: wenn du hier eine Antwort verfasst, klick am besten unten auf Erweitert

    dort hast Du die entsprechenden Buttons, um Codes zu posten

  8. #8
    PostRank: 1
    Registriert seit
    04.12.2009
    Beiträge
    37
    Ich habe exakt dasselbe Problem, sogar inkl. der als fehlerhaft angezeigten Zeilen. Nur habe ich leider noch keine Lösung dafür. Die wp-config.php als ANSI abspeichern? was soll das heißen? Wie geht das?
    Die Folge des Problems ist bei mir gerade, dass ich mich nicht einmal ins Backend einloggen kann. Ist das mit dem Abspeichern als ANSI dann auch behoben?
    Anstatt über /wp-login.php habe ich mich bisher immer über wp-adin eingeloggt. Das klappt aber überhaupt nicht, da sehe ich nur "Warning: Cannot modify header information - headers already sent by (output started at /www/htdocs/[Passwort]/[Verzeichnis]/wordpress-4.0-de_DE/wordpress/wp-config.php:1) in /www/htdocs/[Passwort]/[Verzeichnis]/wordpress-4.0-de_DE/wordpress/wp-includes/pluggable.php on line 1173"
    Was hat das zu bedeuten?

  9. #9
    WPDE-Moderator Avatar von maxe
    Registriert seit
    01.05.2008
    Beiträge
    17.998
    Schau mal in unsere FAQ, da haben wir die Lösung schon vor langem nieder geschrieben.
    Bitte immer zuerst die Suchmaschine Deines Vertrauens nutzen, dann die FAQ und die Forensuche, und erst danach Deine Fragen hier im Forum stellen, denn sehr vieles wurde schon mehrfach beantwortet. Bitte dabei auch die Forenregeln beachten.

    Wenn du eine weise Antwort verlangst, musst du vernünftig fragen. (Johann Wolfgang von Goethe)

  10. #10
    PostRank: 0
    Registriert seit
    30.01.2007
    Beiträge
    11
    Ich konnte das gleiche Problem mit dem der Lösung aus der FAQ lösen. Was mich aber wundert: Das Problem tauchte bei mir nur phasenweise auf. Manchmal gab es die Fehlerfeldung, manchmal ließ sich das Blog normal ausgeben. Einen Zusammenhang konnte ich noch nicht erkennen. Ich habe das Theme Branford-Magazine installiert, die Fehlermeldung war exakt die gleiche wie bei Avinus (ein anderer Pfad natürlich.

    Kann es sein, dass ein Plugin die index.php fehlerhaft überschreibt?

Seite 1 von 2 12 LetzteLetzte

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •