Weitere Informationen und den Download findest du auf der offiziellen Anlaufstelle de.wordpress.org
Ergebnis 1 bis 6 von 6
  1. #1
    PostRank: 0
    Registriert seit
    01.09.2011
    Beiträge
    11

    Umlaut-Domain - Blockiert von der Inhaltsicherheitsrichtlinie (CSP)

    Hallo,

    ich mächte Wordpress auf einer Umlaut-Domain installieren

    Wordpressadresse und Websiteadresse sind mit Puny-Code eingetragen.

    Erstmal läuft alles wie gewohnt,

    nur bei Design -> Customizer (Header, Hintergrundbild) bekomme ich Links das Menü und Rechts

    "Blockiert von der Inhaltsicherheitsrichtlinie (CSP)"

    Jemand ne Idee ausser die Sicherheitsfunktion in Firefox ausschalten?

    Grüsse


  2. #2
    PostRank: 0
    Registriert seit
    01.09.2011
    Beiträge
    11
    Hab das jetzt erstmal so gelöst,

    <meta http-equiv="Content-Security-Policy" content="default-src 'self' umlaut-domain.tld"> in admin-header.php reinkopiert.

    Das kann ja aber nicht die Lösung sein, da das nach dem nächsten Update wieder weg ist

  3. #3
    PostRank: 10 Avatar von gericoach
    Registriert seit
    12.08.2008
    Beiträge
    7.176
    umlaut-domains sind murks, das solltest du ändern.

  4. #4
    r23
    r23 ist offline
    PostRank: 10
    Registriert seit
    09.12.2006
    Beiträge
    3.567
    Zitat Zitat von bugscout Beitrag anzeigen
    <meta http-equiv="Content-Security-Policy" content="default-src 'self' umlaut-domain.tld"> in admin-header.php reinkopiert.

    Das kann ja aber nicht die Lösung sein, da das nach dem nächsten Update wieder weg ist
    dann trage es in die Server Konfiguration ein - wie steht im "Handbuch"

    https://content-security-policy.com/


    Zum Beispiel

    Nginx

    Code:
    add_header Content-Security-Policy "default-src 'self';";

  5. #5
    PostRank: 0
    Registriert seit
    24.02.2017
    Beiträge
    1
    Habe genau das gleiche Problem,
    @ r23 wo soll man diesen Code einfügen.

    Server Konfiguration ?. Ich bin ganz neu bei Wordpress und habe dummerweise den gleichen Fehler mit der Umlaut Domain gemacht.
    Ich weiß nicht wie ich dieses CSP Problem lösen kann außer ich deaktiviere die Option in Firefox ?.

    Gibts den keine anderen Möglichkeiten ?

  6. #6
    PostRank: 3
    Registriert seit
    04.01.2017
    Beiträge
    147
    Ich kann nur raten eine andere Domain zu verwenden. Denn bei Emails senden wirds wirklich schwierig dies richtig zu konfigurieren. Denn je nach dem Emailempfänger-Programm erscheint dann deine Emailadresse mit dem Punycode, was ich sehr unschön finde. Ich hatte Swiftmailer benutzt und ich bezweifle dass WP dies besser macht.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •