Weitere Informationen und den Download findest du auf der offiziellen Anlaufstelle de.wordpress.org
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12
Like Tree3Likes

Thema: Fehler bei Plugin Installation

  1. #1
    PostRank: 1
    Registriert seit
    01.01.2017
    Beiträge
    28

    Fehler bei Plugin Installation

    Hallo,

    ich wollte das Plugin w3 total cache installieren. Dabei gab es eine Fehlermeldung und seitdem kann ich nichts mehr machen.
    Ich bin im Backend drin, bekomme aber nur die Seite Design --> Menü angezeigt, egal was ich sonst anklicke, es kommt immer die Meldung
    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Was kann ich nun tun? Bin noch ganz neu und hab keine Ahnung, was ich jetz machen kann.
    Ich verwende das Theme "yoko" von Elmastudios"
    Wollt mich grad in einem anderen Browser anmelden, da komm ich nicht mal ins Backend rein
    Geändert von Barbarella (01.01.2017 um 17:45 Uhr)

  2. #2
    PostRank: 2
    Registriert seit
    12.06.2015
    Beiträge
    64
    Hallo,
    das einfachste ist, das Plugin über deinen FTP-Zugang "abzuschalten", d.h. einfach das Plugin umbenennen.
    Dadurch findet WP das Plugin nicht mehr und es wird nicht geladen.
    Zufinden unter:
    wp-content/plugins.

  3. #3
    PostRank: 8 Avatar von b3317133
    Registriert seit
    21.11.2014
    Beiträge
    883
    Per FTP zum Server verbinden, den Ordner /wp-content/plugins/w3-total-cache umbenennen in z.B. w3-total-cache-aus o.ä. Danach sollte ein Einloggen wieder möglich sein. Wenn das klappt würde ich den Ordner per FTP komplett löschen und ein anderes Cache Plugin, z.B. WP Fastest Cache o.ä. verwenden. W3 Total Cache ist zwar sehr komplex und mächtig, aber seit den jüngsten Updates leider nicht mehr sehr stabil bei z.B. älteren PHP-Versionen usw.

  4. #4
    PostRank: 1
    Registriert seit
    01.01.2017
    Beiträge
    28
    vielen Dank für die Antworten. Dumme Frage, aber wie verbinde ich mich per ftp mit dem Server. Hab schon gegooglet, aber finde nichts, womit ich was anfangen kann.
    Geändert von Barbarella (01.01.2017 um 18:11 Uhr)

  5. #5
    PostRank: 1
    Registriert seit
    01.01.2017
    Beiträge
    28
    hab gefunden, wie ich mich verbinden kann (glaub ich zumindest ), weiß jetzt aber nicht, wie ich da hinkomm, das plugin zu löschen (host is webgo)

  6. #6
    PostRank: 2
    Registriert seit
    12.06.2015
    Beiträge
    64
    Hallo,
    hast du dich auf deinem FTP-Server mit einenm FTP-Programm angemeldet?
    Wenn ja, einfach durch die Verzeichnisse suchen.
    Ich empfehle als FTp-Programm Filezilla.
    Die Zugangsdaten findest du bei deinem Hoster auf der Seite.

  7. #7
    PostRank: 1
    Registriert seit
    01.01.2017
    Beiträge
    28
    nach langem suchen konnt ich jetz über den web-ftp von meinem hoster reingehen. hab das plugin auch gelöscht (sowie die plugins, die ich davor auch installiert habe). leider bekomm ich immer noch die selbe fehlermeldung...
    ein ftp-programm hab ich noch nicht, werd mir aber noch eins installieren. danke für den tipp mit filezilla.

  8. #8
    PostRank: 6 Avatar von danielgoehr
    Registriert seit
    13.07.2016
    Ort
    Berlin
    Beiträge
    676
    Bei W3 Total Cache reicht das umbenennen des Ordners nicht aus.

    Prüf mal deine htaccess Datei. Ich vermute, W3 Total Cache hat dort zusätzliche Dinge reingeschrieben, die von deinem Server nicht unterstützt oder von deinem Hoster nicht erlaubt werden.
    Am einfachsten wäre es wahrscheinlich, wenn du die htaccess Datei einfach aus einem Backup wiederherstellst.

    Zusätzlich musst du die folgenden Dateien und Ordner aus dem Ordner wp-content entfernen:
    w3-total-cache-config.php
    db.php
    advanced-cache.php

    Und ebenfalls aus dem wp-content Ordner noch folgende Verzeichnisse löschen:
    w3tc
    w3tc-config



    Bevor du irgendwelche Dateien entfernst, solltest du am besten nochmal ein Backup durchführen. Eigentlich dürfte dabei nicht viel schief gehen, aber sicher ist sicher...
    Barbarella likes this.

  9. #9
    PostRank: 1
    Registriert seit
    01.01.2017
    Beiträge
    28
    hallo Daniel,

    danke für die Info und Hilfe.
    w3-total-cache-config.php hab ich gefunden und ebenfalls gelöscht. db-php hab ich nirgendwo gefunden. alles was nach w3tc aussieht, is weg. leider besteht mein problem immer noch.
    hab in die htaccess-Datei reingeschaut und da steht tatsächlich auch noch was von w3tc. ich weiß leider auch nicht, wie ich die datei aus einem backup herstelle, bzw. ich hab noch gar keins backup gemacht, da ich die domain erst ganz kurz habe und erst seit heute daran gearbeitet habe.
    könnt ich denn sonst notfalls irgendwie alles zurücksetzen? und wenn ja wie geht das? mir wärs fast egal, falls alles verloren geht, hauptsache es funktioniert wieder.

  10. #10
    PostRank: 6 Avatar von danielgoehr
    Registriert seit
    13.07.2016
    Ort
    Berlin
    Beiträge
    676
    Zitat Zitat von Barbarella Beitrag anzeigen
    hallo Daniel,

    danke für die Info und Hilfe.
    Gerne


    Zitat Zitat von Barbarella Beitrag anzeigen
    db-php hab ich nirgendwo gefunden.
    Es existieren nicht immer alle von diesen Dateien. Warum das so ist, weiß ich auch nicht.
    Aber wenn sie alle weg sind, sollte alles ok sein.

    Zitat Zitat von Barbarella Beitrag anzeigen
    leider besteht mein problem immer noch.
    hab in die htaccess-Datei reingeschaut und da steht tatsächlich auch noch was von w3tc. ich weiß leider auch nicht, wie ich die datei aus einem backup herstelle, bzw. ich hab noch gar keins backup gemacht, da ich die domain erst ganz kurz habe und erst seit heute daran gearbeitet habe.
    könnt ich denn sonst notfalls irgendwie alles zurücksetzen? und wenn ja wie geht das? mir wärs fast egal, falls alles verloren geht, hauptsache es funktioniert wieder.
    Du solltest dir unbedingt angewöhnen regelmäßige Backups zu machen. Gerade als Anfänger wirst du immer mal wieder etwas "kaputt" machen und wirst dann froh sein, wenn du einen voherigen Stand gesichert hast.

    Du kannst die htaccess auch einfach neu erstellen. Dazu musst du die Datei löschen, dich dann im Admin Bereich anmelden und unter Einstellungen/Permalinks einmal auf "Standard" und wieder zu deiner aktuellen Einstellung zurückwechseln. Dabei sollte die htaccess neu erstellt werden.
    Barbarella likes this.

Seite 1 von 2 12 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •