Weitere Informationen und den Download findest du auf der offiziellen Anlaufstelle de.wordpress.org
Ergebnis 1 bis 2 von 2
  1. #1
    PostRank: 0
    Registriert seit
    24.07.2014
    Beiträge
    1

    operator not supported for strings

    Hallo zusammen,
    ich habe nach Aktualisierung von Wordpress auf 4.7 und auf PHP 7.1 folgende Fehlermeldung:
    [] operator not supported for strings

    Dies betrifft 2 meiner Seiten der MultiSite Installation:

    Seite 1 Das Frontend gibt diesen Fehler aus
    Warning: Parameter 2 to M_DataMapper::set_custom_wp_query_where() expected to be a reference, value given in ...class-wp-hook.php on line 298
    Error thrown
    [] operator not supported for strings

    Seite 2 in Verbindung mit Buddypress: Nach Aktivierung des Plugins folgt dieser Fehler.
    Hängt vielleicht mit Fehler 1 zusammen?
    Fatal error: Uncaught Error: [] operator not supported for strings in /var/www/web/html/wp-content/plugins/buddypress/bp-activity/classes/class-bp-activity-component.php:281 Stack trace: #0 /var/www/web/html/wp-includes/class-wp-hook.php(298): BP_Activity_Component->setup_admin_bar('') #1 /var/www/web/html/wp-includes/class-wp-hook.php(323): WP_Hook->apply_filters(NULL, Array) #2 /var/www/web/html/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #3 /var/www/web/html/wp-content/plugins/buddypress/bp-core/bp-core-dependency.php(143): do_action('bp_setup_admin_...') #4 /var/www/web/html/wp-includes/class-wp-hook.php(298): bp_setup_admin_bar(Object(WP_Admin_Bar)) #5 /var/www/web/html/wp-includes/class-wp-hook.php(323): WP_Hook->apply_filters(NULL, Array) #6 /var/www/web/html/wp-includes/plugin.php(515): WP_Hook->do_action(Array) #7 /var/www/web/html/wp-includes/admin-bar.php(83): do_action_ref_array('admin_bar_menu', Array) #8 /var/www/web/html/wp-includes/class-wp-hook.php(298): wp_admin_b in /var/www/web/html/wp-content/plugins/buddypress/bp-activity/classes/class-bp-activity-component.php on line 281

    Ich hoffe auf eure Hilfe, vielen Dank vorab!

  2. #2
    PostRank: 3
    Registriert seit
    07.07.2015
    Beiträge
    124
    BuddyPress verträgt sich (noch) nicht mit PHP 7.

    https://buddypress.org/support/topic...error-php-7-1/

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •