Weitere Informationen und den Download findest du auf der offiziellen Anlaufstelle de.wordpress.org
Ergebnis 1 bis 7 von 7
  1. #1
    PostRank: 1 Avatar von MI(|-|A3L
    Registriert seit
    12.03.2006
    Ort
    Vettelschoß
    Beiträge
    36

    Upgrade von PHP5.6 auf 7.1 gibt eine Fehlermeldung im Wordpress 4.7

    Hi, ich wollte heute von PHP5.6 auf 7.1 umstellen da mein Webhoster das seit kurzem im Angebot hat, leider aber ist erstmal das Audio Player Plugin scheinbar nicht mehr kompatibel, denn es gibt mir folgenden Fehler und die komplette Seite ist weg und es steht folgendes da:

    Code:
    Parse error: syntax error, unexpected 'new' (T_NEW) in  /var/www/vhosts/hosting5703.af939.netcup.net/httpdocs/sleip.de/sleip.de/wp-content/plugins/audio-player/audio-player.php  on line 903
    Wenn ich das Plugin deaktiviere ist der Blog wieder aufrufbar, aber dort wo die Artikel stehen müssten findet man immer nur folgenden Code:

    Code:
    Warning: preg_replace(): The /e modifier is no longer supported, use  preg_replace_callback instead in  /var/www/vhosts/hosting5703.af939.netcup.net/httpdocs/sleip.de/sleip.de/wp-content/plugins/wp-code-highlight/wp-code-highlight.php  on line 68
    Wenn ich jetzt die Zeile 68 aus der wp-code-highlight.php hier...
    Code:
    return preg_replace("/<pre(.*?)>(.*?)<\/pre>/ise",
    in diese ändere...
    Code:
    return preg_replace_callback("/<pre(.*?)>(.*?)<\/pre>/ise",
    dann wird zwar der Beitrag wieder angezeigt, aber über jedem Beitrag steht dann noch folgendes:
    Code:
    Warning: preg_replace_callback(): Requires argument 2, '''.wch_stripslashes('$2').''',  to be a valid callback in  /var/www/vhosts/hosting5703.af939.netcup.net/httpdocs/sleip.de/sleip.de/wp-content/plugins/wp-code-highlight/wp-code-highlight.php  on line 68
    Was müsste ich da jetzt denn noch machen damit das verschwindet? Und wieso muss das überhaupt bei Wordpress 4.7 per Hand geändert werden, ich dachte es ist zu PHP7.1 kompatibel?


  2. #2
    WPDE-Moderator Avatar von maxe
    Registriert seit
    01.05.2008
    Beiträge
    17.706
    WP ist auch kompatibel, nur manche Plugins /Themes nicht.
    Bitte immer zuerst die Suchmaschine Deines Vertrauens nutzen, dann die FAQ und die Forensuche, und erst danach Deine Fragen hier im Forum stellen, denn sehr vieles wurde schon mehrfach beantwortet. Bitte dabei auch die Forenregeln beachten.

    Wenn du eine weise Antwort verlangst, musst du vernünftig fragen. (Johann Wolfgang von Goethe)

  3. #3
    PostRank: 10 Avatar von b3317133
    Registriert seit
    21.11.2014
    Beiträge
    1.585
    Wende Dich am besten an die Autoren der beiden Plugins Audio Player und Code Highlight.

  4. #4
    PostRank: 1 Avatar von MI(|-|A3L
    Registriert seit
    12.03.2006
    Ort
    Vettelschoß
    Beiträge
    36
    Jetzt erst gesehen das der zweite Fehler auch von einem Plugin kommt, hab jetzt mal beide deaktiviert und werde mich dann an die Autoren wenden, allerdings ist das letzte Update von dem Audio Player Plugin von 2008.

    Danke!

  5. #5
    PostRank: 1 Avatar von MI(|-|A3L
    Registriert seit
    12.03.2006
    Ort
    Vettelschoß
    Beiträge
    36
    Falls noch jemand danach sucht, hier ist der Fix für Code Highlight:
    https://wordpress.org/support/topic/.../#post-8043051

  6. #6
    PostRank: 10 Avatar von b3317133
    Registriert seit
    21.11.2014
    Beiträge
    1.585

  7. #7
    PostRank: 10 Avatar von Hille
    Registriert seit
    22.01.2012
    Beiträge
    7.227
    Zitat Zitat von MI(|-|A3L Beitrag anzeigen
    allerdings ist das letzte Update von dem Audio Player Plugin von 2008.
    Solche uralten Plugins sollte man nicht mehr einsetzen, sondern eher nach Alternativen suchen.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •