Weitere Informationen und den Download findest du auf der offiziellen Anlaufstelle de.wordpress.org
Ergebnis 1 bis 9 von 9
  1. #1
    PostRank: 0
    Registriert seit
    14.09.2017
    Beiträge
    5

    Umzugsproblem mit Wordpress unter Xampp

    Hallo,

    folgendes Szenario:

    Xampp ist unter einem Laufwerk, sagen wir mal E:\Xampp installiert und läuft einwandfrei. In htdocs befinden sich Wordpressinstallationen, die auch ohne Probleme funktionieren.

    Jetzt möchte ich mit Xampp auf ein anderes Laufwerk umziehen, nennen wir den neuen Speicherort X:/Xampp.
    Um für die reine Funktionalität von Xampp keine Ordnerpfade anpassen zu müssen, installiere ich Xampp neu im neuen Pfad.
    Dann kopiere ich die Datenbanken der alten Installation unter E:\Xampp in die neue Installation (also den Ordner mysql/data), um die Datenbanken in der neuen Installation zu haben und den Ordner htdocs ebenfalls zum neuen Installationsort.

    Trotzdem starten meine Wordpressinstallationen nicht wie gewohnt, sondern gehen davon aus, daß es sich um eine neue Wordpress-Seite handelt und wollen Wordpress neu einrichten.

    Warum komme ich nicht ganz normal in das schon fertig eingerichtete Wordpress-Backend? Was habe ich übersehen? Ich gehe davon aus, daß alle Datenbankeinträge sich auf localhost beziehen und deshalb nicht angepasst werden müssen. Liege ich da falsch?

    Danke für jede Hilfe,
    chapolote


  2. #2
    WPDE-Moderator Avatar von maxe
    Registriert seit
    01.05.2008
    Beiträge
    17.887
    wie sind die Datenbank-Daten in der wp-config.php bzw. stimmen die noch?
    Bitte immer zuerst die Suchmaschine Deines Vertrauens nutzen, dann die FAQ und die Forensuche, und erst danach Deine Fragen hier im Forum stellen, denn sehr vieles wurde schon mehrfach beantwortet. Bitte dabei auch die Forenregeln beachten.

    Wenn du eine weise Antwort verlangst, musst du vernünftig fragen. (Johann Wolfgang von Goethe)

  3. #3
    PostRank: 0
    Registriert seit
    14.09.2017
    Beiträge
    5
    Zitat Zitat von maxe Beitrag anzeigen
    wie sind die Datenbank-Daten in der wp-config.php bzw. stimmen die noch?
    Es sind diesselben wie aus der vorhergehenden Installation. Ich habe daran nichts geändert.

  4. #4
    PostRank: 10 Avatar von mensmaximus
    Registriert seit
    24.07.2014
    Ort
    Krefeld
    Beiträge
    6.033
    httpd.conf umkopiert und Pfade geändert?

  5. #5
    PostRank: 0
    Registriert seit
    14.09.2017
    Beiträge
    5
    Zitat Zitat von mensmaximus Beitrag anzeigen
    httpd.conf umkopiert und Pfade geändert?
    Nicht nötig, da ich, wie oben erwähnt, Xampp ja frisch ins neue Laufwerk installiert habe.

    Die Seiten unter htdocs sind ja auch ganz normal aufrufbar, nur Wordpress meint dann, es handle sich um eine frische Installation anstatt um eine schon bestehende.

  6. #6
    PostRank: 10 Avatar von mensmaximus
    Registriert seit
    24.07.2014
    Ort
    Krefeld
    Beiträge
    6.033
    Zitat Zitat von chapolote Beitrag anzeigen
    Nicht nötig
    Na dann ist ja alles bestens! Oder Du schaust dann doch mal nach ob eventuell Pfade geändert werden müssen (httpd.conf, wp-config.php, .htaccess und Datenbank).

  7. #7
    PostRank: 0
    Registriert seit
    14.09.2017
    Beiträge
    5
    Ich habe mich nur auf die httpd.conf bezogen. Sorry für das Missverständnis.

    Es ist ja gerade meine Frage, wo denn noch Pfade anzupassen sind, weil daran scheint es ja zu scheitern. In der wp-config.php habe ich außer der Einstellung von WP Super Cache keine weiteren Pfadangaben gefunden und in der Datenbank bezieht sich doch alles nur auf localhost/meine Installation, oder etwa nicht?

  8. #8
    PostRank: 9 Avatar von danielgoehr
    Registriert seit
    13.07.2016
    Ort
    Berlin
    Beiträge
    1.490
    Ich glaube, du musst normalerweise keine Pfade anpassen. Aber soweit ich mich erinnere, musst du die exakt gleichen MySQL Versionen verwenden, wenn du die Datenbank-Dateien einfach rüberkopieren möchtest.

    Sind die Datenbanken denn korrekt vorhanden, wenn du z.B. in phpmyadmin schaust?

  9. #9
    PostRank: 0
    Registriert seit
    14.09.2017
    Beiträge
    5
    Die Datenbanken sind, soweit ich das beurteilen kann, korrekt vorhanden. Ich hab mir aus Zeitgründen erst einmal mit dem Duplicator beholfen, auch wenn es mich weiter interessiert, warum es mit Paste&Copy nicht funktioniert. Mir fehlt gerade die Zeit, mich hier tiefer einzuarbeiten, ich vermute, daß es doch an Pfadangaben in der Datenbank liegt, die sich nicht auf localhost sondern auf den physischen Pfad der xampp-Installation beziehen. Wenn ich wieder etwas mehr Luft habe, werde ich das nochmal ohne den Duplicator testen.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •