Weitere Informationen und den Download findest du auf der offiziellen Anlaufstelle de.wordpress.org
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 20
  1. #1
    PostRank: 1
    Registriert seit
    25.08.2015
    Beiträge
    21

    Datenbankfehler nach Migration von Strato auf lokalen Server (MAMP).

    Ich habe eine Wordpress Installation (morgenward.net, bei STRATO gehostet) per FTP auf meinen lokalen Server (MAMP auf MacBook) runtergeladen und die dazugehörige Datenbank importiert. Die Fehlermeldung lautet: Fehler beim Aufbau einer Datenbankverbindung. Ich komme einfach nicht darauf was da falsch läuft. Ich habe neulich meinen LapTop neu aufgesetzt und im Zuge dessen ein BackUp von htdocs und den zugehörigen DB-Sätzen gemacht. War anschließend überhaupt kein Problem die zu den einzelnen WP-Installationen gehörenden DB-Sätze wieder zu importieren und die Installationen zum laufen zu bringen. Jemand 'ne Idee dazu?


  2. #2
    PostRank: 10 Avatar von JABA-Hosting
    Registriert seit
    29.03.2016
    Beiträge
    1.836
    Ändere deine wp-config.php. Beim Datenbankserver sollte localhost stehen.

  3. #3
    PostRank: 1
    Registriert seit
    25.08.2015
    Beiträge
    21
    Hmm... Das hat mir sofort eingeleuchtet. Also hab ich die wp_config.php geändert wie vorgeschlagen:
    /** MySQL hostname */
    define('DB_HOST', 'localhost');
    Ändert aber nichts, es kommt immer noch: Fehler beim Aufbau einer Datenbankverbindung.
    'localhost:8888' (MAMP Konfiguration) funzt auch nicht. Komisch...

  4. #4
    PostRank: 10 Avatar von Hille
    Registriert seit
    22.01.2012
    Beiträge
    7.654
    Läuft denn der MySQL Server überhaupt?

  5. #5
    PostRank: 1
    Registriert seit
    25.08.2015
    Beiträge
    21
    Ja, der Server läuft. Hab ich mit einer anderen (lokalen) WP-Installation getestet. Muss jetzt offline gehen, danke für euer Mitdenken, morgen geht's weiter.

  6. #6
    PostRank: 1
    Registriert seit
    25.08.2015
    Beiträge
    21
    MoinMoin. Wie gesagt, der Server läuft. So sieht die vom Strate-Server runtergeladene wp-config.php aus:
    .
    .
    .
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', '-------------');


    /** MySQL database username */
    define('DB_USER', '-------------');


    /** MySQL database password */
    define('DB_PASSWORD', '-------------');


    /** MySQL hostname */
    define('DB_HOST', 'rdbms.strato.de');


    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');


    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    .
    .
    .
    Den hostname habe ich zu 'localhost' geändert. Mein lokaler MAMP-Server verwendet für DB_USER eigentlich 'root' und für DB_PASSWORD ebenfalls 'root'. Also habe ich das ebenfalls so geändert. Jetzt kommt die Meldung "Safari kann keine Verbindung zum Server aufnehmen".
    Geändert von Olaf (30.11.2017 um 11:03 Uhr)

  7. #7
    PostRank: 1
    Registriert seit
    25.08.2015
    Beiträge
    21
    Moin. Beim Datenbankserver hab ich wie gesagt localhost eingetragen, ohne Erfolg. Zum Vergleich, so sieht eine bei mir lokal funktionierende wp-config.php (Auszug) aus:
    .
    .
    define('DB_NAME', 'archaeomare');


    /**
    * Ersetze benutzername_hier_einfuegen
    * mit deinem MySQL-Datenbank-Benutzernamen.
    */
    define('DB_USER', 'root');


    /**
    * Ersetze passwort_hier_einfuegen mit deinem MySQL-Passwort.
    */
    define('DB_PASSWORD', 'root');


    /**
    * Ersetze localhost mit der MySQL-Serveradresse.
    */
    define('DB_HOST', 'localhost');
    .
    .
    Und so die von Strato runtergeladene:
    .
    .
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', '-------------');


    /** MySQL database username */
    define('DB_USER', '-------------');


    /** MySQL database password */
    define('DB_PASSWORD', '-------------');


    /** MySQL hostname */
    define('DB_HOST', 'rdbms.strato.de');


    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');


    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');

    DB_HOST hatte ich zu 'localhost' geändert und DB_USER und DB_PASSWORD zu 'root'.
    Ohne Erfolg...

    Auffällig ist das die URL einer funktionierenden lokalen Installation so aussieht:

    http://localhost:8888/archaeomare_wp4.8/ (:8888!)

    und die ohne Serververbindung so:

    http://localhost/WordPress_01/ (ohne :8888 )
    Geändert von Olaf (30.11.2017 um 11:04 Uhr)

  8. #8
    PostRank: 10 Avatar von danielgoehr
    Registriert seit
    13.07.2016
    Ort
    Berlin
    Beiträge
    1.879
    Versuch mal, das Passwort leer zu lassen. Je nach Version kann es entweder "root" oder leer sein. Benutzername bleibt in beiden Fällen root.

    Edit: Wie sieht denn die URL von phpmyadmin aus? Ist dort auch ein Port angehängt? Falls ja, musst du beim Host ggf. auch diesen Port anhängen.
    Geändert von danielgoehr (30.11.2017 um 11:17 Uhr)

  9. #9
    PostRank: 10 Avatar von JABA-Hosting
    Registriert seit
    29.03.2016
    Beiträge
    1.836
    Vielleicht hilft auch statt localhost auch 127.0.0.1. Benutzernamen und Passwort gehe ich mal davon aus das die richtig sind.

  10. #10
    PostRank: 1
    Registriert seit
    25.08.2015
    Beiträge
    21
    Hab alles durchprobiert: PW root, PW leer, localhost mit Port / ohne Port, localhost oder 127.0.0.1. Nix geht.


    Hier nochmal die URL:
    localhost:8888/WordPress_01/


    Und die wp-config.php Einstellungen:
    /** The name of the database for WordPress */
    define('DB_NAME', 'DB2928345');


    /** MySQL database username */
    define('DB_USER', 'root');


    /** MySQL database password */
    define('DB_PASSWORD', 'root');


    /** MySQL hostname */
    define('DB_HOST', '127.0.0.1.'); /* 'localhost' und 'localhost:8888' hab ich auch probiert */


    Zum Vergleich hier eine andere lokale Installation die funktioniert:
    define('DB_NAME', 'archaeomare');
    /**
    * Ersetze benutzername_hier_einfuegen
    * mit deinem MySQL-Datenbank-Benutzernamen.
    */
    define('DB_USER', 'root');


    /**
    * Ersetze passwort_hier_einfuegen mit deinem MySQL-Passwort.
    */
    define('DB_PASSWORD', 'root');


    /**
    * Ersetze localhost mit der MySQL-Serveradresse.
    */
    define('DB_HOST', 'localhost');

Seite 1 von 2 12 LetzteLetzte

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •