Weitere Informationen und den Download findest du auf der offiziellen Anlaufstelle de.wordpress.org
Ergebnis 1 bis 9 von 9
Like Tree1Likes
  • 1 Post By Karretto

Thema: Plugins und Themes laden sich ins falsche Verzeichnis!

  1. #1
    PostRank: 1
    Registriert seit
    26.02.2014
    Beiträge
    28

    Plugins und Themes laden sich ins falsche Verzeichnis!

    Guten Tag..

    ich habe eine frische Wordpress Installation durchgeführt. Es ist die zweite auf meinem Server. Für diese installation habe ich auch eine extra Datenbank eingerichtet.

    Lade ich nun ein Plugin oder ein Theme runter, lädt er es nicht für die neue Installation hoch, sondern in der alten (der andere Wordpressblog). Hat da jemand eine Ahnung was da schief gelaufen sein könnte?


  2. #2
    PostRank: 2
    Registriert seit
    31.10.2012
    Beiträge
    64
    Welche URLs sind denn unter Einstellungen -> Allgemein eingetragen? Vielleicht die selbe wie in der anderen?

  3. #3
    PostRank: 1
    Registriert seit
    26.02.2014
    Beiträge
    28
    Da ist die URL der neuen Installation eingetragen... deswegen mein großes fragezeichen. Hab bereits in der Datenbank geschaut ob das irgendwie Buggy ist.. aber auch da stimmts.

    Frage mich ob es halt in irgendeiner Datei verankert wurde oder ob man das via .htaccess oder wp-config genau festlegen kann.

  4. #4
    PostRank: 2
    Registriert seit
    31.10.2012
    Beiträge
    64
    ruf mal deinedomain.xy/wp-admin/options.php auf und schau mal ob Du da was mit dem falschen Pfad findest...

  5. #5
    PostRank: 1
    Registriert seit
    26.02.2014
    Beiträge
    28
    Auch an dieser Stelle stimmen die Pfade.. habe noch Mal versucht ein Theme zu installieren.. aber wieder in der falschen WP Installation gelandet..

  6. #6
    PostRank: 2
    Registriert seit
    31.10.2012
    Beiträge
    64
    Da Du schreibst, dass es eine frische Installation ist, gehe ich mal davon aus, dass Du nichts in die wp-config eingetragen oder geändert hast?
    so was wie
    Code:
    define('UPLOADS', 'anderes_verzeichnis');
    Ansonsten bin ich mit Ratschlägen erst mal am Ende... Ohne da selbst rein zu schauen fällt mir leider auch nichts mehr ein...

  7. #7
    PostRank: 1
    Registriert seit
    26.02.2014
    Beiträge
    28
    Lediglich die Zugangsdaten für den FTP... und habe den Fehler gefunden.. man bin ich dumm xD..
    Den ftp Zugang habe ich extra eingerichtet, um nur auf die eine Installation zu gehen. Verdammt noch mal.. trotzdem danke!

  8. #8
    PostRank: 2
    Registriert seit
    31.10.2012
    Beiträge
    64
    HAHA! OK...
    Aber vielleicht beschreibst Du nochmal konkret was genau verkehrt war - hab nicht verstanden - das kann immer auch anderen helfen

  9. #9
    PostRank: 1
    Registriert seit
    26.02.2014
    Beiträge
    28
    Also:

    Ich habe aus der älteren installion die wp-config.php runtergeladen und den Datenbankzugang angepasst. Ich hatte in der Datei aber bereits einen FTP Zugang festgelegt:
    define('FTP_HOST', 'IP'); define('FTP_USER', 'Max');
    define('FTP_PASS', 'Tralala');
    Dieser FTP-Zugang hat direkt auf der Verzeichnis der älteren Wordpress Installation gezeigt.

    Da ich nun diese Datei in der neuen Installation hochgeladen habe, wurde bei einem Download eines Plugins oder Themes automatisch das Verzeichnis der alten Installation anvisiert. Die neue Installation hatte also nie etwas erhalten.

    Ich habe nun einen neuen FTP-Zugang angelegt, der auf die neue Installation zeigt und das entsprechend in der wp-config.php der neuen Installation angepasst.
    WebbR likes this.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •