Weitere Informationen und den Download findest du auf der offiziellen Anlaufstelle de.wordpress.org
Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 18 von 18
Like Tree3Likes

Thema: Wie stelle ich meine Seite wieder her?

  1. #11
    PostRank: 10 Avatar von b3317133
    Registriert seit
    21.11.2014
    Beiträge
    2.287
    Zitat Zitat von Collector Beitrag anzeigen
    Was soll ich jetzt machen?
    Zurück auf Anfang und das ganze sauber und ohne manuelle .htaccess Hackerei einrichten.

    1. jungfräuliche Datenbank (alles löschen), SQL File importieren
    2. per FTP alle Dateien einspielen
    3. die DB_xxxxx Zugangsdaten in die wp-config.php eintragen
    4. über deineseite.de/wp-admin/ anmelden
    5. in WordPress "Einstellungen -> Permalinks -> Speichern" - das erzeugt die passende .htaccess automatisch.

    Ggf. vor dem Login das Cache-Plugin deaktivieren.

    3.1. den Punkt define('WP_CACHE', true); aus der wp-config.php entfernen
    3.2. den Ordner des Cache-Plugins im Verzeichnis wp-content/plugins/xxx umbenennen oder löschen

    Ebenfalls ggf. vor dem Login das HideMyIrgendwas-Plugin deaktivieren.

    3.3. den Ordner des HideMyIrgendwas-Plugins im Verzeichnis wp-content/plugins/xxx umbenennen oder löschen
    Geändert von b3317133 (02.01.2018 um 22:31 Uhr) Grund: Ergänzung bzgl. Cache / HideMyIrgendwas
    Collector likes this.

  2. #12
    PostRank: 10 Avatar von b3317133
    Registriert seit
    21.11.2014
    Beiträge
    2.287
    3.4. Und ebenfalls ggf. vor dem Login eine (falls vorhandene) Datei .htaccess im Ordner /wp-admin/ entfernen.
    Collector likes this.

  3. #13
    PostRank: 2
    Registriert seit
    20.06.2016
    Beiträge
    94
    Das war schon super, danke!

    Man kann die Seite sehen und ich kann mich über wp-login.php einloggen ABER das Dashboard ist eine weiße Seite.
    Dann gehe ich zurück zum Frontend, sehe meine Seite und oben die Zeile für das Backend ABER egal was ich anklicke, das Backend ist immer eine leere, weiße Seite.

    Was jetzt?

  4. #14
    PostRank: 10 Avatar von b3317133
    Registriert seit
    21.11.2014
    Beiträge
    2.287
    Zitat Zitat von Collector Beitrag anzeigen
    Was jetzt?
    Schwer zu erraten, ohne Link bzw. Login.

    Eine "weiße Seite" stellt üblicherweise einen "Fehler 500" dar, das sieht man z.B. im Browser-Inspector unter "Netzwerk", und mehr dazu im Server Errorlog.

    Ggf. gibt es auch Hinweise, wenn man WP_DEBUG in der wp-config.php mal kurz testweise auf true setzt.

    Ergänzung: Sehe gerade, dass sich unter Domain/de/wp-admin/ tatsächlich ein "Fehler 500" zeigt, also sind da wohl nach wie vor irgendwelche Plugins, .htaccess o.ä. im Weg.
    Geändert von b3317133 (03.01.2018 um 15:29 Uhr)

  5. #15
    PostRank: 2
    Registriert seit
    20.06.2016
    Beiträge
    94
    Zuerst einmal danke für die Hilfe!!!!!!!!!!!!!!!!

    Ich werde also nach htaccess Dateien suchen und diese entfernen und dann nach und nach einen Pluginordner nach dem anderen umbenennen und schauen was passiert?

    Ist das eine Idee?

  6. #16
    PostRank: 10 Avatar von b3317133
    Registriert seit
    21.11.2014
    Beiträge
    2.287
    Würde wie beschrieben erstmal ein Blick ins Server Errorlog werfen und/oder WP_DEBUG nutzen, um mehr Hinweise zu bekommen.
    Collector likes this.

  7. #17
    PostRank: 2
    Registriert seit
    20.06.2016
    Beiträge
    94
    Im Error Log stand:

    mod_fcgid: stderr: #6 in /var/www/vhosts/collectorbase.net/httpdocs/de/wp-content/plugins/revslider/includes/framework/base-admin.class.php on line 141, referer: https://www.collectorbase.net/de/
    Also habe ich den Ordner für revslider umbenannt.

    JETZT FUNKT WIEDER ALLES!!!!!!!!!!!!!
    Danke!!!

    Was mache ich mit den Plugins die ich durch Umbenennung deaktiviert habe?
    Soll ich die Ordner löschen und die Plugins neu installieren?

  8. #18
    PostRank: 10 Avatar von b3317133
    Registriert seit
    21.11.2014
    Beiträge
    2.287
    Zitat Zitat von Collector Beitrag anzeigen
    Was mache ich mit den Plugins die ich durch Umbenennung deaktiviert habe?
    Soll ich die Ordner löschen und die Plugins neu installieren?
    Würde ich so machen, aber nur neu installieren, wenn sie wirklich notwendig sind. Pseudosecurity-Plugins wie "HideMyIrgendwas" usw. sind sinnlos seit es XMLRPC (schon immer) und die REST API (schon lange) gibt.

Seite 2 von 2 ErsteErste 12

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •