Weitere Informationen und den Download findest du auf der offiziellen Anlaufstelle de.wordpress.org
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 17
Like Tree2Likes

Thema: Website Umleitung korrekt einrichten

  1. #1
    PostRank: 2
    Registriert seit
    18.02.2016
    Beiträge
    79

    Website Umleitung korrekt einrichten

    Hallo liebe Wpler,

    ich stehe vor folgendem Problem: Ich habe vor einem Jahr eine Website entworfen, nennen wir sie mal www.bücherwurm.de und lange Zeit mit der Gestaltung dieser verbracht. Als sie fertig war und die ersten Artikel publiziert wurden, ist mir aufgefallen, dass mir der Name überhaupt nicht mehr gefällt. Deswegen habe ich eine neue Domain bei meinem Hoster (all inkl.) gekauft und diese (fiktiv) www.bücherlager.de gennant.

    Da ich aber meine Website nicht noch mal von Anfang an neu machen wollte, habe ich einfach das Wordpress- Verzeichnis von www.bücherwurm.de in das Verzeichnis von www.bücherlager.de zeigen lassen. Die Website ist unter dem Namen www.bücherwurm.de wie auch unter dem Namen www.bücherlager.de zu finden. Wenn ich die Website aufrufe wird in der Url- Zeile des Browers allerdings immer noch der alte Domianname angezeigt, zudem sind alle Backlinks die auf die neue Domain zeigen wirkungslos.

    Ein Feund hat mir empfohlen in meinen Dashbord unter dem Menüpunkt "Einstellungen" einfach in das Feld der "Website-Adresse (URL)" den neuen Domiannamen zeigen zu lassen. Allerdings war jetzt das Problem, dass ich immer automatisch von meinen Wp-admin abgemeldet wurde sobald meine Website besuchte. Das Problem war weg, als ich meine alte Domain in das Feld schrieb.

    In diesem Forum wurde mir empfohlen eine 301er Weiterleitung einzurichten, würde dies mein Problem lösen? Und wenn ja, wie richte ich so eine Weiterleitung?

    Viele Dank für eure Unterstützung Cheers!

  2. #2
    PostRank: 6 Avatar von danielgoehr
    Registriert seit
    13.07.2016
    Ort
    Berlin
    Beiträge
    550
    Das was du machen möchtest ist im Prinzip ein Umzug, auch wenn du bei dem gleichen Hoster bleibst.

    Du musst natürlich in dem Fall keine Dateien kopieren oder die Datenbank ex- oder importieren. Aber du musst trotzdem in der Datenbank alle Verweise auf deine alte Domain auf die neue ändern. Das geht z.B. mit dem Plugin "Better Search Replace".

    Danach sollte normalerweise alles ok sein.

    Noch kurz für dich zum Verständnis:
    WordPress braucht immer genau eine Hauptdomain. Du kannst zwar beliebig viele Domains weiterleiten, es gibt am Ende aber eben immer nur eine Domain, mit der dein WordPress "läuft".

  3. #3
    PostRank: 2
    Registriert seit
    18.02.2016
    Beiträge
    79
    Der Held des Tages Award geht an danielgoehr. ;D

    Viele Leute gefragt, viele antworten bekommen, deine Lösung ging am schnellsten, leichtesten und hat auch noch super funktioniert!

    Vielen Dank!

  4. #4
    PostRank: 6 Avatar von danielgoehr
    Registriert seit
    13.07.2016
    Ort
    Berlin
    Beiträge
    550
    Zitat Zitat von aubers Beitrag anzeigen
    Der Held des Tages Award geht an danielgoehr. ;D

    Viele Leute gefragt, viele antworten bekommen, deine Lösung ging am schnellsten, leichtesten und hat auch noch super funktioniert!

    Vielen Dank!
    Sehr gerne. Freut mich, dass es geklappt hat

  5. #5
    PostRank: 2
    Registriert seit
    18.02.2016
    Beiträge
    79
    Hmm komischer Weise funktioniert jetzt mein responsive Layout nicht mehr.

  6. #6
    Edi
    Edi ist offline
    PostRank: 10 Avatar von Edi
    Registriert seit
    26.07.2006
    Ort
    Zürich
    Beiträge
    2.521
    Und das lässt sich wie ohne Link zur Website anschauen?
    CMS-Basics - Nützliches für die Arbeit mit Content-Managament-Systemen.

  7. #7
    PostRank: 2
    Registriert seit
    18.02.2016
    Beiträge
    79
    Ruhig Brauner Hier hast du deinen Link http://live-yourlove.de und das Layout funktioniert eigentlich, allerdings springt der gesamte Content bei einer Auflösung von c. 400 px nach links.

  8. #8
    Edi
    Edi ist offline
    PostRank: 10 Avatar von Edi
    Registriert seit
    26.07.2006
    Ort
    Zürich
    Beiträge
    2.521
    Bei mir funktioniert es problemlos... Vielleicht ein Cache-Problem?
    CMS-Basics - Nützliches für die Arbeit mit Content-Managament-Systemen.

  9. #9
    PostRank: 6 Avatar von danielgoehr
    Registriert seit
    13.07.2016
    Ort
    Berlin
    Beiträge
    550
    Zitat Zitat von Edi Beitrag anzeigen
    Bei mir funktioniert es problemlos... Vielleicht ein Cache-Problem?
    Bei mir sieht es auch komisch aus. Das Mobil-Menü verschwindet und der Content ist plötzlich links rausgerückt und läuft rechts raus.
    Ich kann auf die schnelle aber auch überhaupt nicht erkennen, woher das kommt.

    Edit: Ok, ich würde sagen, es liegt irgendwie an dem Page-Builder-Plugin. Das erzeugt ja gruseligen Code. Also auf die schnelle finde ich da den Fehler leider nicht :/
    Geändert von danielgoehr (09.01.2017 um 19:00 Uhr)

  10. #10
    PostRank: 2
    Registriert seit
    18.02.2016
    Beiträge
    79
    Der fehlerhafte Code wird durch die Änderung von "dqDQ1_options (1.17MB)" hervorgerufen. Ich versuche jetzt mal einen Domianwechsel ohne eine Änderung dieses Feldes.

    Edit: Anscheinend ist genau dieses Feld für den Urlwechsel verantwortlich. Schade! Kennt sonst jemand noch alternative Lösungen?
    Geändert von aubers (09.01.2017 um 20:04 Uhr)

Seite 1 von 2 12 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •