Weitere Informationen und den Download findest du auf der offiziellen Anlaufstelle de.wordpress.org
Ergebnis 1 bis 7 von 7
  1. #1
    PostRank: 1
    Registriert seit
    10.11.2006
    Beiträge
    20

    Sprache lässt sich nicht ändern

    Hallo zusammen,

    in meiner WordPress Installation lässt sich im Dashboard unter allgemein die Sprache nicht ändern.
    WordPress selbst ist Deutsch, zeigt aber Englisch an bei der Spracheinstellung. Ein Wechsel wird nicht angenommen (springt auf englisch zurück).
    Versuch von deutsch (Sie) zu installieren glückt zwar, springt Aber beim auswählen ebenfalls auf englisch zurück.

    Ein Problem ist das im Endeffekt wegen den Sprachdateien der Plugins, wo dann natürlich die englische Version gezogen wird.

    Ein wp_lang Eintrag in der Config bringt übrigens auch nix

    Aber vielleicht wisst ihr ja Rat
    Danke und Gruß,
    KlyX


  2. #2
    PostRank: 10 Avatar von b3317133
    Registriert seit
    21.11.2014
    Beiträge
    1.662
    Zitat Zitat von KlyX Beitrag anzeigen
    Ein wp_lang Eintrag in der Config bringt übrigens auch nix
    Der Eintrag in der wp-config.php heisst WPLANG und nicht wp_lang und ist nur für alte WordPress-Versionen gedacht.

    Evtl. steht dort eine Voreinstellung wie define('WPLANG', 'en_US'); o.ä.?

    Falls ja, ändern auf define('WPLANG', '');

  3. #3
    PostRank: 1
    Registriert seit
    10.11.2006
    Beiträge
    20
    Sorry, meinte natürlich WPLANG
    Der Eintrag war ursprünglich nicht drin, ich hab ihn testweise gesetzt. Mir ist bewusst, dass der Eintrag nur für ältere Versionen war.
    Selbst mit '' oder 'de_DE' und auch ganz ohne Eintrag lässt sich an der Spracheinstellung nichts ändern.
    Sie fliegt immer auf "English (United States)" zurück... bin ziemlich ratlos...

  4. #4
    Edi
    Edi ist offline
    PostRank: 10 Avatar von Edi
    Registriert seit
    26.07.2006
    Ort
    Zürich
    Beiträge
    3.239
    Ist das bei einem Standardtheme auch so?
    <clickwork> - Microsponsor WordCamp Bern, 8./9. September 2017.

  5. #5
    PostRank: 1
    Registriert seit
    10.11.2006
    Beiträge
    20
    Hi Edi,

    du hast recht, auf deinem der Standard-Themes ist es korrekt auf Deutsch. Dann liegt es wohl am Theme?
    Wie kann man sowas beheben?

  6. #6
    Edi
    Edi ist offline
    PostRank: 10 Avatar von Edi
    Registriert seit
    26.07.2006
    Ort
    Zürich
    Beiträge
    3.239
    Welches Theme verwendest Du? Kann die Sprache separat als Theme-Option gewählt werden?
    <clickwork> - Microsponsor WordCamp Bern, 8./9. September 2017.

  7. #7
    PostRank: 1
    Registriert seit
    10.11.2006
    Beiträge
    20
    Hi Edi,

    ja, das ist tatsächlich richtig. Dort war die Einstellung auf Deutsch gesetzt.
    Sobald ich die Einstellung entfernt habe (also wieder Englisch als Standard), setzt sich die Sprache in den Allgemeinen Einstellungen auch wieder auf Deutsch (dann klappt das auch mit den Plugins).
    Ist aber ein seeeehr seltsames Verhalten

    KlyX.

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •