Weitere Informationen und den Download findest du auf der offiziellen Anlaufstelle de.wordpress.org
Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 22
  1. #11
    PostRank: 10 Avatar von Hille
    Registriert seit
    22.01.2012
    Beiträge
    6.794
    Sichere mal deine vhost und teste das hier (nur den Bereich für SSL ersetzen)

    Code:
    <IfModule mod_ssl.c>
    <VirtualHost *:443>
    ServerAdmin webmaster@cloudload.eu
    DocumentRoot /var/www/cloudload/
    ServerName cloudload.eu
    
    Header always set Strict-Transport-Security: 'max-age=31536000; preload'
    
    ErrorLog /var/log/apache2/cloudload-error.log
    
    SSLEngine on
    SSLProtocol All -SSLv2 -SSLv3
    SSLHonorCipherOrder On
    SSLCompression off
    
    CustomLog /var/log/apache2/cloudload-access.log combined
    ServerSignature Off
    SSLCertificateFile    /etc/letsencrypt/live/certs/fullchain.pem
    SSLCertificateKeyFile /etc/letsencrypt/live/certs/privkey.pem
    Include /etc/letsencrypt/options-ssl-apache.conf
    
    <Directory "/var/www/cloudload/">
    
    Options -Indexes +FollowSymLinks
    
    AllowOverride all
    Require all granted
    
    </Directory>
    
    
    # Mod_rewrite Wordpress
    RewriteEngine On
    
    RewriteRule ^/$ /index.php [L]
    RewriteCond %{DOCUMENT_ROOT}%{REQUEST_FILENAME} !-f
    RewriteCond %{DOCUMENT_ROOT}%{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ /index.php/$1 [L]
    
    </VirtualHost>
    
    </IfModule>
    Code:
    /etc/init.d/apache2 reload

  2. #12
    PostRank: 10 Avatar von Hille
    Registriert seit
    22.01.2012
    Beiträge
    6.794
    Ich meine den Bereich :443 zu ändern, :80 erstmal so lassen.

  3. #13
    PostRank: 0
    Registriert seit
    25.11.2016
    Beiträge
    15
    Vielen Dank für die korrigierte vhost!
    habe die vhost jetzt für alle Seiten angepasst und alle laufen wieder.
    Unvorstellbar und dennoch frage ich mich warum es die drei Monate zuvor ohne Ärger lief.
    Vielen lieben Dank dafür!

  4. #14
    PostRank: 0
    Registriert seit
    25.11.2016
    Beiträge
    15
    Leider fällt mir jetzt ein anderer Fehler auf. Ich scheine WP Probleme anzuziehen und auch dieser ist einer bei dem ich auf Google nicht fündig wurde.
    Die /wp-admin Seite funktioniert nicht. Es aktualisiert sich lediglich die Startseite.
    Ich habe mich dann mit /wp-login.php eingeloggt und hatte dann immerhin schon einmal die Leiste des Adminpanels am oberen Bildschirmrand.
    Wenn ich dort jetzt aber auf Dashboard klicke passiert nichts. Wenn ich aber andere Funktionen auswähle wie z.B. "Seite bearbeiten" komme ich ins Admin Panel.
    Klicke ich im Admin Panel dann auf Dashboard geht es. Ich habe die Verlinkung überprüft. Wenn man im Adminpanel ist, lautet die Verlinkung /wp-admin/index.php (funktioniert)
    Klicke ich aber von einer beliebigen WP Seite oben links auf Dashboard lautet die Verlinkung /wp-admin (funktioniert nicht)
    Woran hakt das denn nun schon wieder?
    Es ist auch wieder bei allen WP Seiten auf dem Server das gleiche also muss es wieder eine allgemeine Konfiguration sein. Es funktioniert nicht einmal beim neu aufgesetzten Wordpress.
    Zum Test https://cloudload.eu/wp-admin

    Hat dazu vielleicht nochmal jemand eine Idee?
    Permalinks habe ich schon neu geschrieben, .htaccess habe ich schon testweise umbenannt.


    Edit:

    Es liegt an der Zeile "RewriteRule ^(.*)$ /index.php/$1 [L]".
    Nehme ich sie raus geht /wp-admin einwadfrei aber die Seite nicht.
    Setze ich sie rein geht die Seite aber /wp-admin nicht.
    Geändert von KSCNeon (21.03.2017 um 13:53 Uhr)

  5. #15
    PostRank: 9 Avatar von b3317133
    Registriert seit
    21.11.2014
    Beiträge
    1.125
    Die Seite geht hier derzeit gar nicht. Evtl. kommen bei Dir vermeintlich funktionierende Seiten aus dem Browser-Cache.

  6. #16
    PostRank: 0
    Registriert seit
    25.11.2016
    Beiträge
    15
    bei mir geht die Seite. Um den Cache auszuschließen haben ich eben sowohl den WP Cache sowie meinen Browser Cache geleert ohne erfolg. Auch ein anderer Browser macht den selben Fehler.

  7. #17
    PostRank: 10 Avatar von Hille
    Registriert seit
    22.01.2012
    Beiträge
    6.794
    Alle Plugins deaktivieren und Standardtheme aktivieren und dann nochmal testen

  8. #18
    PostRank: 9 Avatar von b3317133
    Registriert seit
    21.11.2014
    Beiträge
    1.125
    Um 14:56 ging die Seite nicht, weder Login noch irgendwas sonst, der Server war "tot". Da wurde also mehr geändert, als eine index.php Zeile in .htaccess

  9. #19
    PostRank: 10 Avatar von Hille
    Registriert seit
    22.01.2012
    Beiträge
    6.794

    Nach Server Neustart alle Wordpress Seiten Fehler 404

    Hier scheint einiges geändert worden sein bzw im argen zu liegen.
    @TS warum administrierst du eigentlich einen Server, ohne aber das nötige Wissen zu haben? Wäre ein Hosting Paket da nicht besser geeignet?

  10. #20
    PostRank: 0
    Registriert seit
    25.11.2016
    Beiträge
    15
    Zugegebenermaßen bin ich zwar ausgebildeter Fachinformatiker und beherrsche gängige Windows Server und Software dennoch sind meine Linux Server Kenntnisse relativ gering bzw. ich habe mir mein wissen selbst aneignen müssen weil´s mir keiner beibringt :P
    Ich habe mich gegen ein Hostingpaket entschieden weil ich einmal sehr wissbegierig bin und mir IT Kram meist sehr schnell aneigne. Zudem ist es für mich günstiger einen großen Linux Server zu mieten als viele einzelne Pakete. Auf dem Server läuft noch Owncloud, Open-Exchange, ein Gameserver usw. Grundsätzlich ist das für mich auch alles kein Problem mehr aber mit Wordpress habe ich seit Anbeginn nur Ärger, auch schon im Hostingpaket da es der last der Nutzer nicht stand hielt und die Antwortzeit mehrere Sekunden betrug und das obwohl ich bei keinem Billighoster war (DF).

Seite 2 von 3 ErsteErste 123 LetzteLetzte

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •