Weitere Informationen und den Download findest du auf der offiziellen Anlaufstelle de.wordpress.org
Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 22
  1. #1
    PostRank: 0
    Registriert seit
    25.11.2016
    Beiträge
    15

    Nach Server Neustart alle Wordpress Seiten Fehler 404

    Guten Abend werte Community,
    da ihr mir schon sehr oft geholfen habt muss ich mich heute wieder an euch wenden.
    Vor etwa 3 Tagen startete Ich meinen Debian Server neu. Auf dem Server laufen drei Wordpress Instanzen.
    Die letzten Tage wunderte ich mich sehr als meine Adsense Einnahmen stetig Richtung 0 schwanden und wollte der Sache heute mal auf den Grund gehen.
    Zuerst dachte ich alles sei soweit okay da die Startseiten alle Problemlos laden, aber dem ist nicht so denn jeder Beitrag zeigt einen 404 Fehler an.
    Das hatte ich schon einmal bei Wordpress also vollzog ich meine gängige Fehleranalyse:
    mod_rewrite ist an
    Datenbank ist heile
    Permalinks sind korrigiert
    alles nochmal neu gestartet
    AllowOverride All steht in der conifg
    .htaccess ist korrekt.
    Cache wurde überall geleert

    Konfiguration meiner Testseite:
    Code:
    <VirtualHost *:80>ServerAdmin webmaster@cloudload.eu
    DocumentRoot /var/www/cloudload
    ServerName cloudload.eu
    DirectoryIndex index.php
    ErrorLog /var/log/apache2/cloudload-error.log
    </VirtualHost>
    <Location />
    RewriteEngine on
    RewriteCond %{HTTPS} off
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R]
    </Location>
    <Directory "/var/www/cloudload">
            Require all granted
            Options Indexes FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
    </Directory>
    <IfModule mod_ssl.c>
    <VirtualHost *:443>
    <IfModule mod_headers.c>
    Header always set Strict-Transport-Security "max-age=15552000; includeSubDomains; preload"
    </IfModule>
    ServerAdmin webmaster@cloudload.eu
    DocumentRoot /var/www/cloudload
    ServerName cloudload.eu
    SSLStrictSNIVHostCheck off
    DirectoryIndex index.php
    ErrorLog /var/log/apache2/polr-error.log
    SSLCertificateFile /etc/letsencrypt/live/stoecklmayer.net/fullchain.pem
    SSLCertificateKeyFile /etc/letsencrypt/live/stoecklmayer.net/privkey.pem
    Include /etc/letsencrypt/options-ssl-apache.conf
    </VirtualHost>
    <Location />
    RewriteEngine on
    </Location>
    <Directory /var/www/cloudload/>
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
    </Directory>
    </IfModule>
    htaccess
    Code:
    # BEGIN WordPress<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    
    # END WordPress
    php_value max_input_vars 1500
    php_value max_execution_time 300
    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresByType image/gif "access plus 7 days"
    ExpiresByType image/jpeg "access plus 7 days"
    ExpiresByType image/jpg "access plus 7 days"
    ExpiresByType image/png "access plus 7 days"
    ExpiresByType text/css "access plus 7 days"
    ExpiresByType text/javascript "access plus 2 hours"
    ExpiresByType application/x-javascript "access plus 7 days"
    ExpiresByType application/javascript "access plus 7 days"
    </IfModule>
    Es muss ja irgendwie an einer allgemeinen Konfiguration liegen, da alle drei Wordpress Seiten gleichzeitig schlagartig versagen.
    Auf dem Server laufen noch mehr Webseiten und Dienste. Diese laufen alle einwandfrei!


  2. #2
    PostRank: 10 Avatar von SirEctor
    Registriert seit
    28.10.2008
    Beiträge
    9.682
    Stell mal die Permalinks auf Standard und teste damit. Es liest sich stark nach fehlendem mod_rewrite. Bist du wirklich sicher, dass das Modul aktiviert ist?
    Das Geheimnis des Könnens liegt im Wollen!

  3. #3
    PostRank: 10 Avatar von Hille
    Registriert seit
    22.01.2012
    Beiträge
    7.653

    Nach Server Neustart alle Wordpress Seiten Fehler 404

    Die vhost Konfiguration ist fehlerhaft. Hier wurde eine Konfiguration vor und nach der Apache 2.4 Version gemischt.

  4. #4
    PostRank: 0
    Registriert seit
    25.11.2016
    Beiträge
    15
    Vielen Dank für den Tipp.
    Die Permalinks habe ich schon neu geschrieben aber ohne erfolg.
    Wenn ich sie aber auf "Einfach" stelle funktioniert alles.
    Wie kann das sein?
    Sobald ich wieder "Beitragsname" anwähle ist die Seite wieder im Eimer.
    btw.:
    root@307981:~# sudo a2enmod rewrite
    Module rewrite already enabled

  5. #5
    PostRank: 10 Avatar von b3317133
    Registriert seit
    21.11.2014
    Beiträge
    1.980
    Am Rande bemerkt, falls in der .htaccess tatsächlich so

    Code:
    # BEGIN WordPress<IfModule mod_rewrite.c>
    Rewri...
    steht, ist das <IfModule... auskommentiert.

  6. #6
    PostRank: 0
    Registriert seit
    25.11.2016
    Beiträge
    15
    Eben nochmal überprüft. Leider ist es nicht auskommentiert :/

  7. #7
    PostRank: 10 Avatar von Hille
    Registriert seit
    22.01.2012
    Beiträge
    7.653
    Korrigiere doch erst mal deine fehlerhafte vhost. Irgendwo musst du doch beginnen

  8. #8
    PostRank: 0
    Registriert seit
    25.11.2016
    Beiträge
    15
    Ist mittlerweile schon Korrigiert. Ich saß die halbe Nacht noch am Rechner und habe herum probiert.
    Mittlerweile habe ich selbst Wordpress schon neu installiert und den selben Fehler.
    Bin schon kurz davor Apache neu drüber zu installieren da ich alles was ich irgendwo im netz finden konnte schon getestet habe.
    Bei den Permalinks funktioniert wirklich nur ausschließlich die Standard Einstellung. Alls andere verursacht 404 Fehler. Die Server Logs sind alle okay.

  9. #9
    PostRank: 10 Avatar von JABA-Hosting
    Registriert seit
    29.03.2016
    Beiträge
    1.836
    Zeig uns doch mal deine korrigierte vHost.

  10. #10
    PostRank: 0
    Registriert seit
    25.11.2016
    Beiträge
    15
    Code:
    <VirtualHost *:80>ServerAdmin webmaster@cloudload.eu
    DocumentRoot /var/www/cloudload/
    ServerName cloudload.eu
    DirectoryIndex index.php
    ErrorLog /var/log/apache2/cloudload-error.log
    <Location />
    RewriteEngine on
    RewriteCond %{HTTPS} off
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R]
    </Location>
    <Directory /var/www/cloudload/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride all
        Order allow,deny
        allow from all
    </Directory>
    </VirtualHost>
    
    <VirtualHost *:443>
    ServerAdmin webmaster@cloudlad.eu
    DocumentRoot /var/www/cloudload/
    ServerName cloudload.eu
    ServerAlias *cloudload.eu
    DirectoryIndex index.php
    ErrorLog /var/log/apache2/cloudload-error.log
    CustomLog /var/log/apache2/cloudload-access.log combined
    SSLEngine on
    SSLStrictSNIVHostCheck on
    SSLCertificateFile /etc/letsencrypt/live/certs/fullchain.pem
    SSLCertificateKeyFile /etc/letsencrypt/live/certs/privkey.pem
    Include /etc/letsencrypt/options-ssl-apache.conf
    <Directory /var/www/cloudload/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride all
        Order allow,deny
        allow from all
    </Directory>
    </VirtualHost>
    Auch wenn in der vhost noch ein Fehler sein sollte wird es nicht daran liegen, da alle WP Seiten ja über drei Monate ohne ärger liefen.
    Ich habe auch diverse Backups gemacht, aber die würde ich ungerne wieder einspielen, das letzte ist von Mitte letzter Woche aber danach habe ich noch einiges am Mailserver etc. konfiguriert was ich ungerne nochmal neu machen möchte und einzelne Dateien wiederherzustellen wird ja nicht viel bringen wenn nicht einmal eine WP Neuinstallation hilft.

Seite 1 von 3 123 LetzteLetzte

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •