Weitere Informationen und den Download findest du auf der offiziellen Anlaufstelle de.wordpress.org
Ergebnis 1 bis 5 von 5
  1. #1
    PostRank: 0
    Registriert seit
    18.09.2016
    Beiträge
    12

    Automatische Aktualisierung Problem

    Liebe Wissende,

    meine Seite ist auf einem Server von belwue. Ich habe das Problem, dass die automatische Aktualisierung von Wordpress (nicht die der Plugins - die funktioniert) nicht geht. Im Dashboard wird mir immer angezeigt, dass ich die aktuelle Version hätte (auch wenn das nicht stimmt). Auch wenn ich den "nach neuer Version suchen"-Button drücke, dann sucht er (zumindest scheint es so) und meldet dann wieder: Ihre Version ist aktuell - zuletzt überprüft am (aktuelles Datum). Ich kann also erst gar nicht "aktualisiern" anwählen, da mir das gar nicht angeboten wird.
    Was ich nicht verstehen: Ich bekomme auch keinerlei Fehlermeldung.
    Ich habe nun schon mehrfach händisch installiert (keine one-click-Lösung) und das Problem bleibt bestehen.
    Hat mir jemand einen Tipp? Den Betreiber des Servers habe ich angemailt. Der sagt es könnte was mit url-fopen zu tun haben, das wäre aber aus Sicherheitsgründen deaktiviert...
    In den Foren und im Netz habe ich bisher mein Problem nicht gefunden


  2. #2
    PostRank: 10 Avatar von Marcus[IS]
    Registriert seit
    23.08.2009
    Ort
    Uerdingen (KR)
    Beiträge
    4.783
    Zitat Zitat von Man of Hatschi Beitrag anzeigen
    ... Den Betreiber des Servers habe ich angemailt. Der sagt es könnte was mit url-fopen zu tun haben, das wäre aber aus Sicherheitsgründen deaktiviert...
    Mojn,

    Hm... am url-fopen wird es wohl nicht liegen liegt, da WordPress anstelle fopen dann automatisch curl verwendet. Und wenn fopen und curl deaktiviert wären, wage ich mal zu behaupten würde WP denke ich nur so mit Fehlermeldungen um sich werfen.

    Was mich stutzig macht ist, das deine Autoupdates für die Plugins wohl funktionieren, aber du Probleme beim Update des WordPress Kern hast.

    Ist natürlich jetzt nicht einfach nachzuvollziehen was da gerade nicht rund läuft und da kann man leider auch nur allgemeine Tipps geben, was die Ursachenforschung angeht.

    1. Debug Modus von WordPress mal aktivieren, und schauen was so an Fehlern angezeigt wird.
    https://codex.wordpress.org/Debugging_in_WordPress

    2. Die wp-config.php Datei mal anschauen, ob dort Eintragungen bezüglich der Update Funktionen eingetragen sind und diese notfalls mal auskommentieren (/* ..Anweisung.. */), damit sie nicht mehr ausgeführt werden.
    https://codex.wordpress.org/Configur...ground_Updates

    3. Die Plugins mal alle deaktivieren.
    Es kommt immer wieder mal vor, das Plugins mit älteren WP Versionen (ist ja scheinbar bei dir so) nicht klar kommen und sich das ganze dann negativ auf die Funktionen im Adminbereich auswirken kann.

    3. Eventuell mal ein anderes Theme ausprobieren, falls kein Standard Theme von WP im Einsatz ist.
    Es gibt bei den meisten Themes auch eine functions.php, deren Anweisungen auch zu diversen Störungen in der Funktionsweise führen kann.

    4. Notfalls ein Update per Hand durchführen.
    Es kann ja sein, dass ein Autoupdate mal daneben gegangen ist und WP daher nicht mehr rund läuft.
    In dem Fall hilft es meist sich eine aktuelle WP Version herunter zu laden, das File auf der Festplatte zu entpacken und die darin enthaltenen Dateien und Ordner per FTP Programm nochmals auf den Webspace zu überspielen, damit die dort befindlichen Dateien alle überschrieben werden.

    Ich hoffe ich konnte dir mit den Tipps soweit helfen, damit du weißt, wo du ansetzen kannst.

  3. #3
    PostRank: 0
    Registriert seit
    18.09.2016
    Beiträge
    12
    Super lieben Dank für den ausführlichen Hilfeversuch, Marcus! Ich habe gerade einiges getestet. Meine WP Version war eigentlich immer recht aktuell (maximal 2-3 Wochen hinterher). Ich habe es aber eben immer händisch gemacht.
    Die Plugins hatte ich auch schon einmal alle deaktiviert - keine Änderung. Ich habe allerdings auch nicht all zu viele. Das Theme (Graphene) dürfte es auch nicht sein (ich hatte zuvor das Standard-Theme und da war das Problem auch schon).
    Nun habe ich aber am Ende der config-Datei folgendes gefunden:

    define( 'AUTOMATIC_UPDATER_DISABLED', true );

    add_filter('pre_site_transient_update_core','__ret urn_null');

    Gerade die letzte Zeile scheint mir als nicht php-wissender aber fragwürdig...
    Könnte das das Problem sein?
    Kann ich die beiden Zeilen einfach rauskommentieren?
    Aktuell kann ich mein Problem ja nicht mehr testen, da ich die aktuelle Version habe und noch keine neue draußen ist...

    Liebe Grüße,
    Daniel

  4. #4
    PostRank: 10 Avatar von Marcus[IS]
    Registriert seit
    23.08.2009
    Ort
    Uerdingen (KR)
    Beiträge
    4.783
    Jo, da dürfte das Problem liegen.

    Die Erste Zeile sagt aus, das die Auto Update Funktion abgeschaltet werden soll.

    Die kannst du auskommentieren, oder das true durch false ersetzen.

    Dann sollte auch im Adminbereich unter dem Punkt Aktualisierungen ein Hinweis stehen, welcher lautet Du benutzt die aktuelle Version von WordPress. Zukünftige Sicherheitsaktualisierungen werden automatisch durchgeführt.

    Edit;
    Die Zweite Zeile kommentiere auch mal aus, die scheint wohl einen Fehler zu enthalten bei der Anweisung Return ist ein Leerzeichen drin. Entweder ist das jetzt beim Einfügen in diesem Thread passiert, oder steht das wirklich so in der config Datei?
    Zumal diese die Meldung unterdrücken soll, dass WP Updates vorliegen und dann fehlt da noch eine wichtige Zeile, bezüglich des WP Versionscheck. Alleine funktioniert die zweite Zeile nicht und das könnte auch die ganze Problematik erklären.
    Geändert von Marcus[IS] (21.05.2017 um 00:49 Uhr) Grund: Ergänzung

  5. #5
    PostRank: 0
    Registriert seit
    18.09.2016
    Beiträge
    12
    Super. Nochmals Danke. Ich gehe davon aus, dass nun das Problem behoben ist. Sollte es das nicht sein, dann werde ich nach dem Erscheinen der Version 4.7.6 nochmal hier reinschreiben.
    Bis dahin: Frohes Schaffen!

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •