Weitere Informationen und den Download findest du auf der offiziellen Anlaufstelle de.wordpress.org
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 15
  1. #1
    PostRank: 0
    Registriert seit
    01.02.2018
    Beiträge
    11

    Bilder hochladen fehler mit Datenbank

    Hallo,
    bin bin bei Strato und haben mit dort WP installiert. Nun habe ich die Datenbank gesichert und in einer neuen wiederhergestellt. WP neu installiert und den Upload Ordner wieder per FTP hochgeladen. Es klappt auch so weiter alles. Jedoch wenn ich neue Bilder hochladen will in WP kommt immer die Meldung:
    Der Beitrag konnte nicht in die Datenbank eingefügt werden

    hat jemand eine Idee?


  2. #2
    PostRank: 0
    Registriert seit
    01.02.2018
    Beiträge
    11
    Folgender in der Logdatei
    02.02.2018 18:55:46 ff-kues.de [client 91.66.127.0] WordPress-Datenbank-Fehler Duplicate entry '0' for key 'PRIMARY' f\xc3\xbcr Abfrage INSERT INTO `wp_posts` (`post_author`, `post_date`, `post_date_gmt`, `post_content`, `post_content_filtered`, `post_title`, `post_excerpt`, `post_status`, `post_type`, `comment_status`, `ping_status`, `post_password`, `post_name`, `to_ping`, `pinged`, `post_modified`, `post_modified_gmt`, `post_parent`, `menu_order`, `post_mime_type`, `guid`) VALUES (1, '2018-02-02 18:55:46', '2018-02-02 17:55:46', '', '', 'test Upload', '', 'inherit', 'attachment', 'open', 'closed', '', 'test-upload', '', '', '2018-02-02 18:55:46', '2018-02-02 17:55:46', 0, 0, 'image/jpeg', 'http://ff-kues.de/wp-content/uploads/test-Upload-4.jpg') von wp_ajax_upload_attachment, media_handle_upload, wp_insert_attachment, wp_insert_post

  3. #3
    PostRank: 10 Avatar von b3317133
    Registriert seit
    21.11.2014
    Beiträge
    2.540
    Versuche nach Erstellen eines Backups über phpMyAdmin im Strato-Backend unter SQL einzugeben:
    Code:
    REPAIR TABLE wp_posts

  4. #4
    PostRank: 0
    Registriert seit
    01.02.2018
    Beiträge
    11
    wo genau soll ich das eingeben ???

  5. #5
    PostRank: 0
    Registriert seit
    01.02.2018
    Beiträge
    11
    Habe es gefunden.

    Ihr SQL Befehl wurde erfolgreich ausgeführt kam und unten steht noch

    Table Op Msg_type Msg_text
    DB3253616.wp_posts repair note The storage engine for the table doesn't support repair



  6. #6
    PostRank: 10 Avatar von b3317133
    Registriert seit
    21.11.2014
    Beiträge
    2.540
    Zitat Zitat von Manuel.P Beitrag anzeigen
    Nun habe ich die Datenbank gesichert und in einer neuen wiederhergestellt.
    Beschreibe mal was genau Du hier gemacht hast.

  7. #7
    PostRank: 0
    Registriert seit
    01.02.2018
    Beiträge
    11
    also ich bin hingegangen und habe meine Datenbank in phpmy admin exportiert dann in eine neue Datenbank Importiert. Dann habe ich Wordpress installiert und in die config Datei die Zugangsdaten zur Datenbank geändert. nun habe ich noch den Upload Ordner über ftp hochgeladen. Meine Plugins wieder installiert ( also die die ich noch brauche) und das war es, was ich nun auch noch festgellste. habe das ich auch keine neuen Benutzer anlegen kann. Ist es möglich das ich warum auch immer keine Sachen in die Datenbank schreiben kann ?

    Also und ich habe noch in der config Datei die Adresse der Seite geändert.

  8. #8
    PostRank: 10 Avatar von b3317133
    Registriert seit
    21.11.2014
    Beiträge
    2.540
    Zitat Zitat von Manuel.P Beitrag anzeigen
    Also und ich habe noch in der config Datei die Adresse der Seite geändert.
    Beschreibe mal was genau Du hier gemacht hast.

  9. #9
    PostRank: 0
    Registriert seit
    01.02.2018
    Beiträge
    11
    Habe in Phpmyadmin unter wp_options die Spalten 1 und 2 die neue Domain eingegeben.
    Dann habe ich unter FTP die Datei wp_config die Angaben der DB_Name DB_User und DB_Passwort geändert

  10. #10
    PostRank: 10 Avatar von b3317133
    Registriert seit
    21.11.2014
    Beiträge
    2.540
    Ok. Wenn man hier die Domain ändert, sind noch weitere Dinge zu beachten, Stichwort "WordPress Umzug", Plugin "Better Search Replace", das ist aber ein anderes Problem.

    Evtl. ist bei Deiner Art Export/Import der AUTO_INCREMENT in der Datenbank verlorengegangen, ähnlich wie hier durch einen unvollständigen Export. Prüfe das mal im Direktvergleich der alten/neuen Datenbank mit phpMyAdmin.
    Geändert von b3317133 (02.02.2018 um 19:55 Uhr)

Seite 1 von 2 12 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •