Weitere Informationen und den Download findest du auf der offiziellen Anlaufstelle de.wordpress.org
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 11
  1. #1
    PostRank: 2
    Registriert seit
    27.07.2008
    Ort
    Köln
    Beiträge
    78

    localhost + Zugriff verweigert. Geht nicht ohne index.php

    Hallo!
    Ich habe ein ein wenig seltsames Problem.. Ich habe local eine XAMPP Installation und WP 2.6.1. Installation ist gut abgelaufen. Wenn ich aber versuche "http://localhost/wordpress" aufzurufen bekomme ich
    Zugriff verweigert!

    Der Zugriff auf das angeforderte Verzeichnis ist nicht möglich.
    Wenn ich aber http://localhost/wordpress/index.php eingebe, funktioniert es. Dasselbe mit wp-admin (nur mit index.php).
    Dasselbe auch, wenn ich z.B. das Thema ändern möchte usw.

    Die Beiträge werden in dieser Form: http://localhost/wordpress/?p=1 nicht angezeigt. Nur so: http://localhost/wordpress/index.php?p=1 oder wenn mod_rewrite aktiviert ist http://localhost/wordpress/herzlich-willkommen/

    Es geht also nicht ohne index.php am Ende! Weiß jemand was das ist? Danke!
    Unsere Agentur setzt auf Wordpress! WordPress Probleme & Lösungen


  2. #2
    PostRank: 10 Avatar von Ammaletu
    Registriert seit
    14.07.2007
    Ort
    Bonn
    Beiträge
    4.694
    Ich hätte nur eine Vermutung: Wenn Du einen Ordner aufrufst, hat Apache normalerweise eine Liste an Dateien, die es anzeigt. Wenn keine davon gefunden wurde, würde Apache ein Directory Listing anzeigen, was bei Dir offenbar ausgestellt ist. Das kann man in der httpd.conf (unter xampp/apache/conf) des Apache mit dieser Einstellung konfigurieren. Apache-Neustart danach nicht vergessen:

    Code:
    #
    # DirectoryIndex: sets the file that Apache will serve if a directory
    # is requested.
    #
    <IfModule dir_module>
        DirectoryIndex index.php index.php4 index.php3 index.cgi index.pl index.html index.htm index.shtml index.phtml
    </IfModule>
    Ich nehme mal an, dass das bei Dir fehlt oder nicht index.php enthält. Wenn es das nicht ist, könnte ich mir so auf Anhieb auch keinen Grund vorstellen.
    Mein Blog || Code-Notizen || Schon in die FAQ geschaut?

  3. #3
    PostRank: 2
    Registriert seit
    27.07.2008
    Ort
    Köln
    Beiträge
    78
    Danke, ist aber genauso wie bei dir eingestellt. Auch nicht auskommentiert.

    #
    # DirectoryIndex: sets the file that Apache will serve if a directory
    # is requested.
    #
    <IfModule dir_module>
    DirectoryIndex index.php index.php4 index.php3 index.cgi index.pl index.html index.htm index.shtml index.phtml
    </IfModule>
    Das Problem ist noch nicht behoben, ich habe keine Ahnung, ehrlich gesagt.. Kann es nicht an 2.6.1 liegen?
    Unsere Agentur setzt auf Wordpress! WordPress Probleme & Lösungen

  4. #4
    WPD-Team Avatar von codestyling
    Registriert seit
    30.03.2008
    Ort
    Leipzig
    Beiträge
    1.904
    Es gibt eine sehr einfach Möglichkeit, XAMMP so zu konfigurieren, das man mit "schmucken" Urls arbeiten kann. Dazu muß man in xampp/apache/conf/extra/httpd-vhosts.conf folgendes eintragen:
    Code:
    <VirtualHost 127.0.0.1:8080>
        ServerName www.wordpress261.test
        ServerAdmin deine@email-adresse.de
        DocumentRoot "C:/Program Files (x86)/xampp/htdocs/_root_wp261"
        <Directory "C:/Program Files (x86)/xampp/htdocs/_root_wp261">
            Options Indexes FollowSymLinks Includes +ExecCGI
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
    </VirtualHost>
    127.0.0.1:8080 => localhost IP mit Port 8080 (kannst 80 nehmen, wenn das bei dir Standard ist)
    www.wordpress261.test => über diese URL wird das Blog erreichbar sein
    C:/Program Files (x86)/xampp/htdocs/_root_wp261 => Root Verzeichnis

    Damit das mit der URL funktioniert, mußt du noch im Verzeichnis WINDOWS/system32/drivers/etc die Datei hosts bearbeiten und folgendes einfügen:

    Code:
    # Copyright (c) 1993-1999 Microsoft Corp.
    #
    # This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
    #
    # This file contains the mappings of IP addresses to host names. Each
    # entry should be kept on an individual line. The IP address should
    # be placed in the first column followed by the corresponding host name.
    # The IP address and the host name should be separated by at least one
    # space.
    #
    # Additionally, comments (such as these) may be inserted on individual
    # lines or following the machine name denoted by a '#' symbol.
    #
    # For example:
    #
    #      102.54.94.97     rhino.acme.com          # source server
    #       38.25.63.10     x.acme.com              # x client host
    
    127.0.0.1    localhost
    127.0.0.1    www.wordpress261.test
    Danach entweder den Rechner neu starten oder die Netzwerkverbindungen deaktivieren und wieder aktivieren, damit die hosts Datei neu eingelesen wird und dann den Apache neu starten.

    Danach solltest du im Browser mit dieser URI arbeiten können. Entpacke dann WordPress in dein neues Root Verzeichnis und installier es. Dann solltest du ein funktionierendes System haben, das über URI läuft.

    Dieser Ansatz geht natürlich nur auf deinem Rechner, andere Rechner im Netzwerk können den Blog dann so nicht erreichen. Dazu müsstest du in der hosts Datei des anderen Rechners im Netzwerk deine richtige IP eingeben:
    Code:
    192.168.0.40    www.wordpress261.test
    Auf diese Weise kann man auch einen 1:1 Spiegel der öffentlichen Internet Domain machen, denn wenn du in der hosts Datei deine öffentliche Adresse angibst, wird die TCP/IP Schicht nicht mehr des Internet befragen sondern lokal arbeiten (Adressumleitung).
    It's not a bug, it's always a feature. | Code Styling | Plugins | Plugins & Themes übersetzen

  5. #5
    PostRank: 2
    Registriert seit
    27.07.2008
    Ort
    Köln
    Beiträge
    78
    Hallo!
    Vielen Dank für die Antwort, ich habe nur noch eine blöde Frage.. Im letzten von dir beschriebenen Schritt muss man: "im Verzeichnis WINDOWS/system32/drivers/etc die Datei hosts bearbeiten".
    Das klappt aber nicht Ich bekomme immer die Meldung dass die Datei entweder nicht existiert oder nicht erstellt werden kann. (Wohl weil die über keine Erweiterung verfügt..) Ich habe Vista. Wie soll ich das Problem beheben?
    Danke!

    Die Lösung gefunden:
    Hosts-Datei bzw. Lmhosts-Datei l&#228;sst sich in Windows Vista nicht &#228;ndern

    PS. Vielen Dank, dies hier www.wordpress261.test funktioniert! Aber mod_rewrite geht immer noch nict.. Woran könnte das liegen? Danke!
    Geändert von VoinG (10.09.2008 um 01:56 Uhr)
    Unsere Agentur setzt auf Wordpress! WordPress Probleme & Lösungen

  6. #6
    WPD-Team Avatar von codestyling
    Registriert seit
    30.03.2008
    Ort
    Leipzig
    Beiträge
    1.904
    Hmm, da bin ich momentan ein wenig ratlos, denn die sollte es dort geben.
    Allerdings setze ich kein Vista ein und kann das nicht mal eben schnell prüfen.
    Ich werd mir mal einen Vista Rechner im Laufe des Tages anschauen und werde dann hoffentlich wissen, wo MS die nun wieder versteckt hat

    Ergänzung: Google hilft: Vista Hosts Datei editieren - Windows Vista
    Geändert von codestyling (10.09.2008 um 01:55 Uhr)
    It's not a bug, it's always a feature. | Code Styling | Plugins | Plugins & Themes übersetzen

  7. #7
    PostRank: 2
    Registriert seit
    27.07.2008
    Ort
    Köln
    Beiträge
    78
    Danke schön, ich hab was Ähnliches auch gefunden (siehe oben), du warst aber schneller Mod_rewrite geht immer noch nicht, gibt es eine Lösung? Danke!
    Unsere Agentur setzt auf Wordpress! WordPress Probleme & Lösungen

  8. #8
    WPD-Team Avatar von codestyling
    Registriert seit
    30.03.2008
    Ort
    Leipzig
    Beiträge
    1.904
    Zitat Zitat von VoinG Beitrag anzeigen
    PS. Vielen Dank, dies hier www.wordpress261.test funktioniert! Aber mod_rewrite geht immer noch nict.. Woran könnte das liegen? Danke!
    Im Verzeichnis xampp/apache/conf/ gibt es eine Datei httpd.conf in der du u.U. mod_rewrite einschalten musst. Suche das hier:
    Code:
    #LoadModule rewrite_module modules/mod_rewrite.so
    Falls die Raute davor ist, bitte rausnehmen (ist das Kommentarzeichen), speichern und den Apache neu starten. Dann sollte es funktionieren.
    It's not a bug, it's always a feature. | Code Styling | Plugins | Plugins & Themes übersetzen

  9. #9
    PostRank: 2
    Registriert seit
    27.07.2008
    Ort
    Köln
    Beiträge
    78
    Vielen herzlichen Dank! Nun funktioniert es endgültig! (hoffentlich). Die von dir, codestyling, beschriebenen Schritte werde ich nun immer wiederholen und bedanke mich dafür nochmals!
    Unsere Agentur setzt auf Wordpress! WordPress Probleme & Lösungen

  10. #10
    PostRank: 1
    Registriert seit
    05.03.2009
    Ort
    Bremen
    Beiträge
    37
    Hallo codestyling!
    Bei mir wurde zwar von Anfang an die (bereits bestehende und per Backup lokal importierte) Wordpress-Installation angezeigt, allerdings verwies sogar der css link auf einen absoluten web-pfad, weswegen ich sehr an Deiner Lösung interessiert bin, mit der ich lokal URLs laufen lassen kann.
    Ich habe alles befolgt:

    host datei

    Code:
    127.0.0.1       localhost
    127.0.0.1       www.globetreter.de
    und httpd-vhosts.conf:


    Code:
    # match a ServerName or ServerAlias in any <VirtualHost> block.
    
    <VirtualHost 127.0.0.1:80>
        ServerName www.globetreter.de
        ServerAdmin test@seba.de
        DocumentRoot "C:\xampplite\htdocs\globetreter-wp"
        <Directory "C:\xampplite\htdocs\globetreter-wp">
           Options Indexes FollowSymLinks Includes +ExecCGI
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
    </VirtualHost>
    
    ##<VirtualHost *:80>
    danach die lanverbindung dis- und wieder enabled. flush dns per cmd und den apache + mysql wieder angeschmissen. Ergebnis bei Eingabe "www.globetreter.de" im Browser:

    Code:
    Die von Ihnen aufgerufene Adresse http://www.globetreter.de/ ist zurzeit nicht erreichbar. Bitte überprüfen Sie die korrekte Schreibweise der Webadresse (URL) und versuchen Sie dann die Seite neu zu laden.

    Hast Du noch eine Idee, woran es hapern könnte ?!
    Danke für jeden Hinweis, Sebastian

Seite 1 von 2 12 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •