Weitere Informationen und den Download findest du auf der offiziellen Anlaufstelle de.wordpress.org
Ergebnis 1 bis 6 von 6
  1. #1
    PostRank: 0
    Registriert seit
    16.03.2017
    Beiträge
    4

    WooCommerce Bilder

    Guten Abend,

    meine Frage bezieht sich auf die Erstellung der Bilder. Wenn ich ein Bild hochlade, dann werden je Bild 8 weitere Bilder erzeugt bzw. skaliert und abgespeichert.
    Dabei werden die Bilder in den drei eingestellten Größen korrekt dargestellt, aber es entstehen 5 weitere Bilder, die abgeschnitten werden.
    Greift hier dann noch mein Theme "ShopIsle" und erzeugt die falschen Bilder?

    Aufgefallen ist mir das, da mir die Bilder im Warenkorb hart eingeschrieben werden. Dadurch ist eine .css bearbeitung nicht möglich. Die anderen Bilder werden korrekt skalliert und auch eingefügt. Nur im Warenkorb nimmt es sich die falschen Bilder.

    Gruß
    Marvin


  2. #2
    Edi
    Edi ist offline
    PostRank: 10 Avatar von Edi
    Registriert seit
    26.07.2006
    Ort
    Zürich
    Beiträge
    3.235
    Was ist unter "WooCommerce" > "Produkte" > "Darstellung" > "Produktbilder" eingestellt? Ist "Genau zuschneiden?" aktiviert oder nicht?
    <clickwork> - Microsponsor WordCamp Bern, 8./9. September 2017.

  3. #3
    PostRank: 0
    Registriert seit
    16.03.2017
    Beiträge
    4
    Genau zuschneiden ist deaktiviert.

    Hier habe ich mal die Einstellung abgebildet.

    snip.PNG

  4. #4
    PostRank: 10 Avatar von SirEctor
    Registriert seit
    28.10.2008
    Beiträge
    9.293
    War das schon immer so eingestellt oder hast du das erst später umgestellt? Wenn letzteres zutrifft, musst du die Vorschaubilder neu generieren lassen.
    Das Geheimnis des Könnens liegt im Wollen!

  5. #5
    PostRank: 0
    Registriert seit
    16.03.2017
    Beiträge
    4
    Diese Einstellung war schon, bevor ich die Bilder hochgeladen habe.
    Die andere Einstellung im Bereich Einstellungen>>Media habe ich auch schon angepasst.

  6. #6
    PostRank: 0
    Registriert seit
    16.03.2017
    Beiträge
    4
    Also, ich habe jetzt mal in der media.php rumgespielt und einige $crop rausgenommen/gelöscht. $crop stand aber schon immer auf "false" - also nicht beschneiden. Nun wird es nicht mehr beschnitten, sondern resized.
    Außerdem habe ich in der setup.php vom theme die Einstellungen noch geändert. Hier habe ich andere Größen für das thumbnail eingestellt.
    Muss dann noch ein child-theme drauß machen oder nach Updates einfach neu reinkopieren.

    Gefunden habe ich die Einträge beim erörtern wo die Einträge herkommen und in Verbindung mit TotalCommander habe ich die Ur-Einträge bzw. Definitionen ausfindig gemacht.

    Toi, toi, toi das alles auch weiter so klappt.
    Geändert von MAKoeR (16.03.2017 um 14:29 Uhr)

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •