Mir ist nach dem heutigen Update von Wordpress, WooCommerce und Themen aufgefallen das einige Begriffe auf unserer Webseite in Englisch dargestellt werden.
Ob dies nun durch das Update aufgetreten ist oder bereits schon etwas länger der Fall ist, kann ich nicht mit Bestimmtheit sagen. Ein paar Monate altes Abbild auf dem Testserver von unserer Seite zeigt eine korrekte Lokalisierung an.

Im ersten Moment habe ich nachfolgende Maßnahmen ergriffen:


  1. Einstellungen überprüft, ob alles wirklich auf Deutsch gestellt ist (Wordpress, WooCommerce, Plugins) -> Kein Erofolg
  2. In den Wordpress Einstellungen die Sprache umgestellt. -> Kein Erfolg
  3. Das gleiche nochmal mit einer nicht installierten Sprache. -> Kein Erfolg
  4. Die aktuelle Poedit Datei des Themes genommen, neu übersetzt und in mein Child-Theme übertragen. -> Kein Erfolg


Noch immer sind viele kleine Elemente auf der Webseite nicht in deutscher, sondern Englischer Sprache dargestellt.

Nun würde ich gerne herausfinden woran das genau liegt, ob die Quellen (Sprachdateien) überhaupt noch vom Theme bezogen oder ignoriert werden.

Im Theme sieht eine der betroffenen Zeilen zum Beispiel so aus:

PHP-Code:
<?php _e'Product Name''porto' ); ?>
Entsprechende Referenz kann ich auch in der de_DE.po finden, welche ich ja auf Basis der en_GB.po angelegt und übersetzt habe:

Code:
#: woocommerce/cart/cart-v1.php:19 woocommerce/cart/cart-v2.php:27
#: woocommerce/wishlist-view.php:58
#, fuzzy
msgid "Product Name"
msgstr "Produkt-Bezeichnung"
Dennoch, wird diese Zeile nicht übersetzt, obwohl entsprechend deutsche de_DE.po und de_DE.mo sich in beiden "language"-Verzeichnissen befinden. ( Theme und Child-Theme)

Nun würde ich gerne erfahren, wodurch das nicht-laden der deutschen Übersetzung hervorgerufen werden und wie ich weiter dem Grund auf die Spur kommen könnte.