Weitere Informationen und den Download findest du auf der offiziellen Anlaufstelle de.wordpress.org
Ergebnis 1 bis 4 von 4

Thema: Shop kaputt?

  1. #1
    PostRank: 0 Avatar von Martin-R
    Registriert seit
    15.11.2016
    Ort
    Leipzig
    Beiträge
    8

    Shop kaputt?

    Hallo,

    ich habe einen Mini Woocommerce Shop aufgebaut und alles funktionierte soweit: http://www.topcar.de/shop/

    Wie ihr seht haut da was nicht hin. In der Zeile 3829 steht nur das: trigger_error( sprintf( __('%1$s is <strong>deprecated</strong> since version %2$s! Use %3$s instead.'), $function, $version, $replacement ) );

    Was kann ich damit anfangen? Soll ich da überhaupt etwas ändern? Google spuckt zu dem Spruch leider nichts aus. Alle Updates sind gemacht.
    Hat jemand eine Idee für eine Lösung?

    viele Grüße,
    Martin


  2. #2
    r23
    r23 ist offline
    PostRank: 10
    Registriert seit
    09.12.2006
    Beiträge
    3.567
    Zitat Zitat von Martin-R Beitrag anzeigen
    und alles funktionierte soweit: http://www.topcar.de/shop/
    eigentlich funktionierte nach der Fehlerausgabe ein nichts wirklich richtig...

    Zitat Zitat von Martin-R Beitrag anzeigen
    In der Zeile 3829 steht nur das: trigger_error( sprintf( __('%1$s is <strong>deprecated</strong> since version %2$s! Use %3$s instead.'), $function, $version, $replacement ) );
    Damit erzeugt WooCommerce die "hilfreichen" Hinweise:


    <b>Notice</b>: woocommerce_get_page_id ist seit Version 3.0 <strong>veraltet</strong>! Benutzen Sie stattdessen wc_get_page_id. in <b>~/wp-includes/functions.php</b> on line <b>3829</b><br />

    Zitat Zitat von Martin-R Beitrag anzeigen
    Alle Updates sind gemacht.
    Deine Theme passt leider nicht mehr zu deiner WooCommerce Version. Wenn dir dein Theme Autor (Entwickler fällt mir jetzt nicht ein) kein Update erstellt hat - musst du in dem theme
    woocommerce_get_page_id durch wc_get_page_id ändern - vermutlich sind weitere Änderungen nötig.

  3. #3
    PostRank: 10 Avatar von mensmaximus
    Registriert seit
    24.07.2014
    Ort
    Krefeld
    Beiträge
    5.998
    Zitat Zitat von Martin-R Beitrag anzeigen
    Updates sind gemacht.
    Das ist nicht korrekt. Die Themeversion ist NICHT aktuell (4.0.2 anstatt 4.0.5), ebenso die WooCommerce Version (3.0.2 statt 3.0.3). Mit Enfold hast Du auch Support gekauft, entsprechend solltest Du auch zuerst in das Forum auf kriesi.at sehen. Dort gibt es bereits etliche Threads zum Theme. Die Warnmeldungen schaltet man auf einem Produktionssystem durch Deaktivieren des DEBUG Modus in der wp-config.php ab.

  4. #4
    PostRank: 0 Avatar von Martin-R
    Registriert seit
    15.11.2016
    Ort
    Leipzig
    Beiträge
    8
    Or ihr seit gut, stimmt, das Update des Themes war nicht gemacht und hatte das Problem verursacht. Ich hatte dort den API Key nicht eingegeben und so hat es mir keine Updates angezeigt. Vielen vielen Dank, jetzt geht wieder alles! Super!!!

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •