1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

admin login nicht erreichbar

Dieses Thema im Forum "Konfiguration" wurde erstellt von Haendrickson, 4. Juni 2019.

Schlagworte:
  1. Haendrickson

    Haendrickson New Member

    Registriert seit:
    4. Juni 2019
    Beiträge:
    3
    Zustimmungen:
    0
    hallo zusammen,
    meine website (wordpress 3.4.2-4) liegt bei starto und über den üblichen wp-admin login erscheint nur eine weiße browser seite – alle cookies usw gelöscht, browser gewechselt, rechner gewechselt – nix – dann mit starto hotline telefoniert: im php admin bereich fehlt angeblich der wp-home-url eintrag und ich soll mir doch bitte einen neuen home-url eintrag von wordpress besorgen…
    tja, und da steh ich nu im regen.
    ich wäre euch sehr verbunden, wenn ihr mir da helfen könntet.
    besten dank schon mal.
     
  2. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    5.877
    Zustimmungen:
    505
    Das ist ein relativ altes WordPress.

    Seit wann tritt der Fehler auf? Was genau wurde vorher gemacht? Wann konntest Du Dich das letzte Mal korrekt anmelden?

    Funktioniert die normale Webseite oder erscheint dort auch eine leere Seite?

    Ändert sich was, wenn Du die PHP-Version bei Strato auf so alt wie möglich stellst?

    Was steht im Server Error Log in zeitlichem Zusammenhang zum Aufruf Deiner leeren Seite?

    Die Error-Logs bei Strato stehen üblicherweise unter "Datenbanken & Webspace -> Statistik -> Logfiles (oben) -> Error-Logfile anzeigen (Button)". Exemplarisch hier ein Screenshot wie man da hinkommt.
     
  3. Haendrickson

    Haendrickson New Member

    Registriert seit:
    4. Juni 2019
    Beiträge:
    3
    Zustimmungen:
    0
    vielen dank für deine schnelle antwort.

    die website funktioniert - nur der admin- login ist nicht erreichbar.

    im zeitlichen zusammenhang mit meinem login-problem steht im error log ne menge, hier mal beispiele:


    PHP Warning: Illegal string offset 'remember' in /mnt/web419/a3/57/52275657/htdocs/WordPress_01/wp-includes/user.php on line 38: /home/strato/http/premium/rid/56/57/52275657/htdocs/WordPress_01/wp-login.php


    PHP Warning: Cannot assign an empty string to a string offset in /mnt/web419/a3/57/52275657/htdocs/WordPress_01/wp-includes/user.php on line 38: /home/strato/http/premium/rid/56/57/52275657/htdocs/WordPress_01/wp-login.php


    PHP Warning: Illegal string offset 'user_login' in /mnt/web419/a3/57/52275657/htdocs/WordPress_01/wp-includes/user.php on line 41: /home/strato/http/premium/rid/56/57/52275657/htdocs/WordPress_01/wp-login.php


    PHP Fatal error: Uncaught Error: Cannot create references to/from string offsets in /mnt/web419/a3/57/52275657/htdocs/WordPress_01/wp-includes/user.php:41: /home/strato/http/premium/rid/56/57/52275657/htdocs/WordPress_01/wp-login.php


    Stack trace:: /home/strato/http/premium/rid/56/57/52275657/htdocs/WordPress_01/wp-login.php


    ...ich kann damit leider nicht viel anfangen…



    mein wordpress ist veraltet aber momentan trau ich mich nicht es zu aktualisieren...

    die php version hab ich auf 7.1 gestellt - leider macht das keinen unterschied.

    jetzt wieder auf 7.3




    besten dank.
     
  4. fhwebdesign

    fhwebdesign Well-Known Member

    Registriert seit:
    2. Januar 2018
    Beiträge:
    90
    Zustimmungen:
    5
    Hallo, ist denn 7.1 die älteste Version, die du einstellen kannst?
    Es ist durchaus denkbar, dass deine Wordpress-Version eine ältere braucht... (z.B. PHP 5.6).
    Falls du das nicht auf deiner aktiven Website testen möchtest (was auch sinnvoll ist), würde ich dir empfehlen XAMPP zu installieren, dort die PHP-Version mal auf 5.6 zu konfigurieren und die Website dahin umzuziehen, um zu sehen, ob das dein Problem löst.

    Überprüfe auch mal in deiner Datenbank in der Tabelle "wp_options", ob dort die richtige URL unter "home" (üblicherweise DB-Eintrag 2) eingetragen ist.
     
  5. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    5.877
    Zustimmungen:
    505
    Das Problem kommt durch die Kombination "uraltes" WordPress und neuere PHP-Version.

    Wenn Du FTP-Zugang hast, kannst Du die hier beschriebene Änderung versuchen, dann sollte ein Login mit PHP 7.1 wieder möglich sein und Du kannst nach entspr. Backup Updates versuchen (am besten mit PHP 7.1 bzw. der ältestmöglichen PHP-Version).
     
  6. Haendrickson

    Haendrickson New Member

    Registriert seit:
    4. Juni 2019
    Beiträge:
    3
    Zustimmungen:
    0
    besten dank.
    ich versuch mal mein glück.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden