1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Ältere Beiträge anzeigen funktioniert nicht

Dieses Thema im Forum "Konfiguration" wurde erstellt von ragi, 20. März 2008.

  1. ragi

    ragi Active Member

    Registriert seit:
    20. Dezember 2005
    Beiträge:
    26
    Zustimmungen:
    0
    Hallo, irgendwie stehe ich auf dem Schlauch.

    Folgendes Problem: Bei meinem Blog verwende ich sogenannte statische Seite als Startseite.

    Zusätzlich habe ich eine eigene Seite entworfen, welche mir alle Beiträge von sämtlichen Kategorien anzeigt (mittels: "query_posts('cat=0')"). Klappt alles wunderbar. In meinem Fall werden die letzten zehn Beiträge angezeigt.

    Das Problem ist, dass ich keine älteren Beiträge mittels "next_posts_link" ansehen kann, sondern immer nur dieselben letzten 10 Beiträge, egal ob "page/2" oder "page/3" etc.

    Hat wer eine Ahnung, was ich hier falsch mache?

    Danke
     
  2. ragi

    ragi Active Member

    Registriert seit:
    20. Dezember 2005
    Beiträge:
    26
    Zustimmungen:
    0
    Ok, sorry, hat sich schon erledigt.

    Falls noch für wem interessant hier die Lösung meines Problemes:

    Statt:
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    verwende ich nun diesen:
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Keine Ahnung, ob dies nun technisch sauber ist, aber nun funktioniert die Anzeige von älteren Beiträgen auch bei Pages.
     
  3. bettym

    bettym Member

    Registriert seit:
    8. Juli 2012
    Beiträge:
    12
    Zustimmungen:
    0
    Moin moin aus Hamburg,

    bin hier neu im Forum. Das liegt vielleicht daran, dass ich bisher noch nie Probleme mit Wordpress hatte. Jetzt benötige ich aber dringend Unterstützung.

    Auf dem Portal (www.Link-im-Web.de) habe ich die Version aktualisiert.
    Seit dem funktioniert nicht mehr die Anzeige der älteren Beiträge.

    Beispiel: www.link-im-web.de/pressemitteilungen/page/2 (Nachricht: "Seite nicht gefunden".)

    Im Archiv klappt alles richtig. Kann vorwärts und rückwärts blättern.
    www.link-im-web.de/2012/06

    Zunächst dachte ich es liegt am Theme. Haben div. ausprobiert. Ergebnis immer gleich.

    Übrigens auf www.Blog-Werbung.net klappt alles richtig.
    www.blog-werbung.net/presse-news/page/2

    Da läuft aber noch die Vorgängerversion.

    Wäre für konstruktive Unterstützung dankbar. Gruß Betty
     
  4. mfitzen

    mfitzen Well-Known Member

    Registriert seit:
    9. Juli 2006
    Beiträge:
    9.818
    Zustimmungen:
    2
    Hast Du die Permalinkstruktur mal aktualisiert? Einmal auf Standard setzen, anschließend die .htaccess löschen und Permalinkstruktur neu einstellen (ggf. .htaccess manuell erstellen).
     
  5. bettym

    bettym Member

    Registriert seit:
    8. Juli 2012
    Beiträge:
    12
    Zustimmungen:
    0
    Moin infected, nein habe ich nicht verändert. Werde aber Deinen Tipp gleich anwenden.
     
  6. bettym

    bettym Member

    Registriert seit:
    8. Juli 2012
    Beiträge:
    12
    Zustimmungen:
    0
    Habe ich gemacht. In der Standardversion klappt das Blättern.

    In der Version
    /%category%/%postname%.html
    nicht.
     
  7. mfitzen

    mfitzen Well-Known Member

    Registriert seit:
    9. Juli 2006
    Beiträge:
    9.818
    Zustimmungen:
    2
    Wechsel mal das Theme (nimm TwentyEleven) und lösche dann den Browsercache. Wenn´s damit funktioniert. Liegt´s an Deinem Theme.

    Testweise auch mal alle Plugins deaktivieren.

    Was Du auch noch testen könntest/solltest: Entferne mal das .html aus der Permalinkstruktur und probiere es dann nochmal. Ich meine, dass die Endung bei Seiten (mal) nicht funktionierte und man sich da mit Plugins behelfen musste. Weiß aber nicht wie da der aktuelle Stand ist.
     
  8. bettym

    bettym Member

    Registriert seit:
    8. Juli 2012
    Beiträge:
    12
    Zustimmungen:
    0
    Twenty Eleven habe ich schon probiert - kein Resultat.

    Hat nichts mit dem Theme zu tun. Habe seit gestern 6 verschiedene Theme probiert.

    Was ich nicht verstehe:
    In der Version 3.4 klappt alles korrekt. Siehe www.blog-werbung.net/presse-news/page/2
     
  9. mfitzen

    mfitzen Well-Known Member

    Registriert seit:
    9. Juli 2006
    Beiträge:
    9.818
    Zustimmungen:
    2
    Das stimmt nicht. Dort läuft nicht WP 3.4 sondern 3.3.2. ;)

    Gut, am Theme liegts Deiner Meinung nach nicht, Plugins hast Du bestimmt schon alle deaktiviert und Permalinkstruktur wurde auch aktualisiert... Momentan weiß ich nicht weiter. Benutze bitte mal die Sufu. Das Thema wurde hier schon einige Male angegangen. Suche nach /page/2

    Erfüllt der Server die minimalen Anforderungen?
     
  10. bettym

    bettym Member

    Registriert seit:
    8. Juli 2012
    Beiträge:
    12
    Zustimmungen:
    0
    Du hast mich aber auf die richtige Spur gebracht. Es ist ein Plugin. Ich teste alles gerade durch und melde mich dann noch einmal. Danke für den Tipp.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden