1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Änderung der Permalinks

Dieses Thema im Forum "Konfiguration" wurde erstellt von Traxxxel, 14. September 2016.

Schlagworte:
  1. Traxxxel

    Traxxxel Member

    Registriert seit:
    14. September 2016
    Beiträge:
    7
    Zustimmungen:
    0
    Hallo zusammen,

    ich habe als WP-Newbie WP ein paar mal installiert und erfolglos versucht, die Permalinks zu ändern.
    Derzeit ist meine Seite konfiguriert als "Einfach", was natürlich nicht schön ist.
    Wenn ich die Permalinks umstelle (z.B. auf "Beitragsname"), so funktionieren die Links nicht mehr.

    z.B. Alter Link von der Startseite: https://meine-seite.de/?p=15 --> OK
    Neuer Link nach Umstellung: https://meine-seite.de/Mein-toller-Beitrag --> Error 404

    Meine .htaccess-Datei ändert sich erwartungsgemäß von:
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    auf
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!

    Was muss ich bei der Umstellung beachten? Welche Angaben fehlen noch, damit Ihr mir helfen könnt?

    Ich habe WP 4.6.1 auf einem Ubuntu Apachen laufen und mod_rewrite ist aktiviert.
    Glaube ich zumindest, da ein
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    die Ausgabe
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    liefert.

    Vielen Dank im Voraus
    Der Traxxxel
     
    #1 Traxxxel, 14. September 2016
    Zuletzt bearbeitet: 14. September 2016
  2. maxe

    maxe Well-Known Member
    Ehrenmitglied

    Registriert seit:
    1. Mai 2008
    Beiträge:
    19.581
    Zustimmungen:
    277
    i.d.R. liegt es wirklich an einem deaktivierten mod_rewrite. Frag doch am besten noch mal bei deinem Hoster nach.
     
  3. Traxxxel

    Traxxxel Member

    Registriert seit:
    14. September 2016
    Beiträge:
    7
    Zustimmungen:
    0
    Hallo maxe,

    vielen Dank für Deine Antwort.
    Es handelt sich um meinen eigenen Server.
    Sagt denn "Module rewrite already enabled" nicht aus, dass es enabled ist?
     
  4. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    Schau mal in deiner vhost, ob dort AllowOverride None steht. Wenn ja, das None in All ändern
     
  5. Traxxxel

    Traxxxel Member

    Registriert seit:
    14. September 2016
    Beiträge:
    7
    Zustimmungen:
    0
    Nein, da steht leider kein AllowOverride:
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
     
  6. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    Mal davon abgesehen, das die vhost unvollständig ist, füge AllowOverride All einfach mal ein. Danach den Webserver neu starten
     
  7. Traxxxel

    Traxxxel Member

    Registriert seit:
    14. September 2016
    Beiträge:
    7
    Zustimmungen:
    0
    Huch, was ist denn da unvollständig - was habe ich vergessen?

    Wenn ich AllowOverride All einfüge, startet das Web nicht mehr:

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    So sieht die conf-Datei aus:

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    An welcher Stelle bin ich zu doof :( ?
     
  8. Traxxxel

    Traxxxel Member

    Registriert seit:
    14. September 2016
    Beiträge:
    7
    Zustimmungen:
    0
    Alles klar, ich habe es gefunden.

    Vielen Dank für Eure Unterstützung!

    Ich habe in der /etc/apache2/apache2.conf das AllowOverride eingetragen und nun funktioniert es!

    Noch mal vielen Dank!
     
  9. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    Da fehlt die komplette <Directory> Konfiguration.

    Da gehört das nicht rein :cry:, sondern in den fehlenden <Directory> Bereich.
     
    #9 Hille, 14. September 2016
    Zuletzt bearbeitet: 14. September 2016
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden