1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Allowed memory size of... bei Installation

Dieses Thema im Forum "Installation" wurde erstellt von patrick-de, 1. August 2009.

Schlagworte:
  1. patrick-de

    patrick-de Member

    Registriert seit:
    1. August 2009
    Beiträge:
    6
    Zustimmungen:
    0
    Hallo,

    ich habe ein Installationsproblem. Obwohl ich bei meinem Hoster schon zwei WP's laufen habe, gelingt es mir nicht, auf einer dritten Domain dieses zu installieren. Die anderen beiden WP's waren 2.7'er Installer, beide sind auch aktuell auf 2.8.2 und funktionieren.

    Die dritte Installation ist nun direkt die 2.8.2.

    Nach Aufruf der /wp-admin/install.php bleibt die Seite leer. Im Errorlog finde ich folgenden Eintrag:

    Beim Hoster läuft PHP Version 5.1.6.

    Ja, der grosse Unterschied zu den anderen beiden Installationen ist allerdings, dass im aktuellen Fall php safe mode aktiv ist. Das müsste ich dann quasi wieder "erbetteln". Deswegen würde ich gerne vorher wissen, ob das mein Problem löst.

    Schon jetzt Danke für die Antworten & Tipps,

    Patrick


    Nachtrag:

    Die in der FAQ unter http://faq.wordpress-deutschland.org/exhausted-php-memory/ beschriebenen Tipps habe ich erfolglos getestet.
     
    #1 patrick-de, 1. August 2009
    Zuletzt bearbeitet: 1. August 2009
  2. maxe

    maxe Well-Known Member
    Ehrenmitglied

    Registriert seit:
    1. Mai 2008
    Beiträge:
    19.318
    Zustimmungen:
    223
    Auf jeden Fall ist 16mb für WP mit dt. Sprache zu wenig. Ich würd mind. 32mb empfehlen.
     
  3. Arno Simon

    Arno Simon Well-Known Member

    Registriert seit:
    30. November 2005
    Beiträge:
    2.170
    Zustimmungen:
    0
    und das was in den übrigen 27.356.893 forum-threads steht, welche das thema "allowed memory size" behandeln? was ist damit?

    SCNR aber irgendwie scheint keiner die sufu zu kennen..... die FAQ ist ein teil der community - die sufu ein anderer und die tausenden weiterer beiträge sind teilweise sehr hilfreich, auch wenn sie teilweise auf älteren versionen beruhen.....
     
  4. patrick-de

    patrick-de Member

    Registriert seit:
    1. August 2009
    Beiträge:
    6
    Zustimmungen:
    0
    Ach ja,

    darauf hab ich auch gewartet. Jemand, der garantiert nicht helfen mag aber auf die allseits beliebte Suchfunktion verweisst. Klar hab ich das, hier im Forum und auch über google generell. Dumm nur, dass zu diesem Thema ganz viel Konfusion aber ganz wenig nützliche Fakten existieren. Dein Kommentar allerdings bringt alle WP-User deutlich weiter.

    Ich hab noch immer keine Ahnung, ob das beschriebene Problem mit dem dummerweise aktivierten Safe Mode bei PHP zu tun hat. Selbige WP-Dateien samt gleicher DB lassen sich auf Webspace beim selben Hoster mit deaktiviertem Safe Mode installieren.

    Liegt es nun am Safe Mode ? Keine Ahnung, bin kein PHP/WP Crack. Aber es spricht einiges dafür.

    bye, Patrick
     
  5. Arno Simon

    Arno Simon Well-Known Member

    Registriert seit:
    30. November 2005
    Beiträge:
    2.170
    Zustimmungen:
    0
    jups... ich mag nicht helfen... habe ich 2.000 beiträge lang nicht getan und da werd ich bestimmt bei dir nicht mit anfangen....
     
  6. infected

    infected Well-Known Member

    Registriert seit:
    9. Juli 2006
    Beiträge:
    9.816
    Zustimmungen:
    1
    maxe hat Dir doch schon geschrieben, woran es scheitert. Bitte Deinen Hoster das memory limit auf mind. 32MB zu erhöhen.
     
  7. patrick-de

    patrick-de Member

    Registriert seit:
    1. August 2009
    Beiträge:
    6
    Zustimmungen:
    0
    Nö, warum ? 3 Domains bei einem Hoster im Paket, zweimal Safe mode off, einmal on. Bei on klappt WP nicht, bei off klappt WP. Warum sollte ich nun den Speicher erhöhen lassen ? Damit dann WP mit Safe Mode on funktioniert ?

    bye, Patrick
     
  8. maxe

    maxe Well-Known Member
    Ehrenmitglied

    Registriert seit:
    1. Mai 2008
    Beiträge:
    19.318
    Zustimmungen:
    223
    höö, warum fragst du hier, wenn du es doch eh nicht hören willst bzw. besser weißt :confused: Dann lass doch SafeMode auf off stellen.
     
  9. Bambaataa

    Bambaataa Well-Known Member
    Ehrenmitglied

    Registriert seit:
    17. Mai 2009
    Beiträge:
    2.478
    Zustimmungen:
    9
    ich kann dir zum safe mode nichts sagen, aber ich denke das die installation einfach an den 16mb scheitert. fertig installiert mag es laufen, aber eben die installation selber scheitert.

    und zu den anderen. er würde safe mode ja auf off stellen, allerdings wollte er gern wissen ob es damit zu tun haben kann. wenn man hier jemandem vorwürft die foren suche nicht zu benutzen bzw. ander beiträge zu lesen, sollte man selber wenigstens den beitrag hier richtig lesen. so kann man auch user vergraulen.
     
  10. infected

    infected Well-Known Member

    Registriert seit:
    9. Juli 2006
    Beiträge:
    9.816
    Zustimmungen:
    1
    Das haben wir ja schon 2x versucht dem Threadersteller mitzuteilen.

    Zum Safe-Mode: Zumindest hat der aktivierte safe-mode keine Auswirkungen auf den Speicherverbrauch. Insofern dürfte es da schonmal keinen Zusammenhang geben. Denkbar wäre, dass ein Plugin mit dem safe-mode Probleme hat. WordPress hat im Normalfall keine Probleme mit dem safe-mode (soweit ich das sagen kann).
     
  11. Holger71

    Holger71 Well-Known Member

    Registriert seit:
    14. Oktober 2007
    Beiträge:
    204
    Zustimmungen:
    0
    Du kannst das recht einfach über eine php.ini im Root deiner Wordpress Installation regeln.

    Bei mir ist da zB. ein Eintrag drin der lautet
    memory_limit = 128M

    Ob Du eigene php.ini verwenden kannst hängt jedoch vom Hoster ab. Funktioniert jedenfalls bestens damit.
     
  12. Bambaataa

    Bambaataa Well-Known Member
    Ehrenmitglied

    Registriert seit:
    17. Mai 2009
    Beiträge:
    2.478
    Zustimmungen:
    9
    geht dann aber auch nur bis zu dem limit was der hoster vorgibt. bei mir sind das auch 128M. hatte aber erst nen kunden bei dem ging es so auch nur bis 20M.
     
  13. patrick-de

    patrick-de Member

    Registriert seit:
    1. August 2009
    Beiträge:
    6
    Zustimmungen:
    0
    Hi,

    also weil es ja doch schon interessant ist, hier noch mal die Fakten.

    Das ist ein typisches Hosterangebot, 3 Domains, insgesammt 15 GB Speicher. Teilt sich auf 3 Domains auf, je 5 GB. Alles gleich, bis auf den einen Unterschied, dass ich auf 2 Domains Safe Mode off habe, bei der dritten dummerweise nicht.

    Klar... Ich kann Safe Mode bestimmt deaktivieren lassen. Aber ich habe bislang keine Info gefunden, dass WP mit Safe Mode on nicht läuft. Wie auch immer, ich hab den Blog nun auf eine der beiden anderen Domains installiert, hier ging es sofort. Die Bedingungen sind sonst absolut identisch.

    Es spricht also einiges dafür, dass Safe Mode on die Fehlermeldung mit dem Speicher auslöst.

    bye, Patrick
     
  14. Domino5702

    Domino5702 Well-Known Member

    Registriert seit:
    30. April 2009
    Beiträge:
    2.634
    Zustimmungen:
    0
  15. Arno Simon

    Arno Simon Well-Known Member

    Registriert seit:
    30. November 2005
    Beiträge:
    2.170
    Zustimmungen:
    0
    bei den hier immer wieder angemerkten speichereinstellungen geht es nicht um den zur verfügung stehenden festplattenplatz, sondern um den zur verfügung stehenden prozess-memory - sprich: wieviel arbeitsspeicher wird wp seitens deines hosters zur verfügung gestellt... und das werden mit sicherheit keine 15 GB sein!
     
  16. patrick-de

    patrick-de Member

    Registriert seit:
    1. August 2009
    Beiträge:
    6
    Zustimmungen:
    0
    oh je,

    wir beide werden auch keine Freunde mehr. Ich denke, dass düfte doch wohl jeden klar sein, geht aber auch aus den Text heraus, es sei denn Du gehst auch davon aus, dass ich glaube, dass meine 3 Domains sich je 5 GB RAM greifen (da müsste mein Hoster auch nach heutigen Massstäben eine Menge RAM vorhalten für all seine Kunden).

    @Domino5702:

    Ja! Genau die Seite hatte ich gefunden und dann gedacht, prima, ich kann also WP auch bei Safe Mode on nutzen. Ist mein Englisch so schlecht ? Ich less das so, dass es keine bekannten Probleme mit WP und Safe Mode on gibt.

    Ich habe nun ne Quengelmail an meinen Hoster geschrieben, um
    1.) PHP Safe mode auf off setzen zu lassen und 2.) Memory Limit ein wenig nach oben zu drehen.

    Mal gucken was draus wird.

    bye, Patrick
     
  17. speedschlampe

    speedschlampe New Member

    Registriert seit:
    24. April 2006
    Beiträge:
    1
    Zustimmungen:
    0
    tschuldigung das ich hier so reinplatze, aber ich habe ein sehr ähnliches problem. nach einem update auf version 2.8.2 (deutsch version) und dem betrieb von wordpress im safe-mode (hat bisher nie probleme gegeben) taucht der "fatal error" auf:

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    obwohl ich allen möglichen ratschlägen (ändern der php.ini, wp-config.php, cache.php, wordpress.php, deaktivieren der plugins, etc..) gefolgt bin, bleibt der fehler bestehen und lenkt so meinen verdacht auf den safe-mode. wo kann ich noch die erlaubte memory size ändern (die 16MB hab ich nämlich nirgendwo gefunden und in wordpress ist überall -glaube ich jedenfalls- 64M als erlaubte größe eingestellt)?

    edit: ach ja: vielleicht hilft das bei der lösung des problems. ich habe wordpress lokal installiert (also LAMP auf Ubuntu). bin also unabhängig von irgendwelchen hosterproblemen und habe alle rechte die man sich so wünschen kann ;)

    edit (2): entfernen von de_DE aus der wp-config.php
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    "löst" das problem. beim update auf 2.8.3 und der installation der deutschen sprachunterstützung taucht es allerdings in anderer form wieder auf. und zwar im admin-panel beim rss-import (incoming links, plugins, ...):

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    dass das problem an der spracheinstellung liegen soll würde mich allerdings sehr wundern. naja, als workaround funktioniert es soweit. vielleicht sollte ich auch zur deutschen komplettversion wechseln, statt nur die übersetzung zu installieren... keine ahnung
     
    #17 speedschlampe, 3. August 2009
    Zuletzt bearbeitet: 3. August 2009
  18. jottlieb

    jottlieb Well-Known Member
    Ehrenmitglied

    Registriert seit:
    20. August 2005
    Beiträge:
    17.381
    Zustimmungen:
    0
    @speedschlampe: In der php.ini solltest du fündig werden.
     
  19. Arno Simon

    Arno Simon Well-Known Member

    Registriert seit:
    30. November 2005
    Beiträge:
    2.170
    Zustimmungen:
    0
    stimmt genau.... aufgrund deiner überheblichen art und dieser tatsache bist du binnen weniger stunden der nächste der in meinem filter landet.....
     
  20. patrick-de

    patrick-de Member

    Registriert seit:
    1. August 2009
    Beiträge:
    6
    Zustimmungen:
    0
    Für die Interessieren...

    Zwei Parameter wurde geändert, der Safe Mode wurde deaktiviert, ausserdem das Memory Limit auf 32MB erhöht.

    Ich kann nun Wordpress erfolgreich installieren. Tja, schöner wäre es gewesen die Parameter nacheinander zu wechseln um die genaue Ursache, also ob nun Safe Mode oder Memorylimit, zu lokalisieren. Leider ist das für mich nicht möglich.

    Wie auch immer, für die Tipps & Tricks (und die anderen Nachrichten auch) bedanke ich mich.

    bye, Patrick
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden