1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WP 5.2 Anzeige von Bildern im Beitrag

Dieses Thema im Forum "Allgemeines" wurde erstellt von kitchenartistry, 12. Februar 2020.

  1. kitchenartistry

    Registriert seit:
    12. Februar 2020
    Beiträge:
    11
    Zustimmungen:
    0
    Ich habe ein Problem mit der Anzeige von Bildern in einem Beitrag und konnte dazu nirgends eine Lösung finden. Es geht nicht (!) um Beitragsbilder, sondern um ganz normal in den Beitrag hinzugefügte Bilddateien. Obwohl die Einstellungen den Fehler eigentlich ausschließen müssten und ich den Code überprüft habe, macht der Text neben dem Bild (es sollte neben dem Text angezeigt werden) einfach einen Sprung und geht erst darunter weiter.
    Im Beitragseditor selbst wird allerdings alles richtig angezeigt. Egal was ich mache, auf der Website bleibt der Anzeigefehler bestehen.
    http://kitchenartistry.de/cgi-bin/wordpress/2019/12/15/gebrannte-mandel-creme/

    Kann mir irgendjemand erklären, wie ich den Fehler behebe?
     
  2. Henk1060

    Henk1060 Well-Known Member

    Registriert seit:
    4. September 2014
    Beiträge:
    2.778
    Zustimmungen:
    157
    hm... kann sein das ich blind bin.
    mach mal einen screenshot wo was nicht sein sollte
     
  3. maxe

    maxe Well-Known Member
    Ehrenmitglied

    Registriert seit:
    1. Mai 2008
    Beiträge:
    19.323
    Zustimmungen:
    223
    Setzt das Bild in einen Bild-Block, diesen stellst du auf Rechtsbündig.
    Daneben kannst du dann ganz normal Absatz-Blöcke erstellen.
     
  4. kitchenartistry

    Registriert seit:
    12. Februar 2020
    Beiträge:
    11
    Zustimmungen:
    0
    Dieser leere Bereich dort sollte nicht sein. Dort befindet sich kein eingestellter Absatz oder sonstwas, da müsste laut Beitragseditor überall der Text weitergehen.
    In der PC-Ansicht ist diese Lücke deutlich größer und störender. Eine riesige freie Fläche statt Text.
     

    Anhänge:

  5. kitchenartistry

    Registriert seit:
    12. Februar 2020
    Beiträge:
    11
    Zustimmungen:
    0
    Exakt diese Einstellung verwende ich grade bereits, und dennoch der Anzeigefehler, egal wie oft ichs von neuem versuche.
     
  6. maxe

    maxe Well-Known Member
    Ehrenmitglied

    Registriert seit:
    1. Mai 2008
    Beiträge:
    19.323
    Zustimmungen:
    223
    Ich erkenne im Seitenquelltext aber kein wp-block-image, von daher vermute ich einen anderen Editor (kein Gutenberg) oder den Formatierungsfehler:
    denn das Bild hängt im ersten p, welcher auch noch die Class .has-drop-cap (.has-drop-cap:not:)focus):after bekommt ein clear:both) bekommt, von daher sitzt der 2. Absatz verständlicherweise drunter.
     
  7. kitchenartistry

    Registriert seit:
    12. Februar 2020
    Beiträge:
    11
    Zustimmungen:
    0
    Okay, das stimmt, ich habe aufgehört den Gutenberg-Editor zu benutzen, da ich mit diesem überhaupt nicht zurechtkam. Den Beitrag habe ich mit dem klassischen (alten) Wordpress-Editor erstellt. Hast du denn eine Lösung für mich, wie ich bei diesem Editor das Problem beheben kann?

    Im Beitragseditor wird wie gesagt der Text neben dem Bild angezeigt.
     
  8. maxe

    maxe Well-Known Member
    Ehrenmitglied

    Registriert seit:
    1. Mai 2008
    Beiträge:
    19.323
    Zustimmungen:
    223
    nimm das Bild aus dem ersten p oder nimm das clear:both aus dem css.
     
  9. kitchenartistry

    Registriert seit:
    12. Februar 2020
    Beiträge:
    11
    Zustimmungen:
    0
    Wenn ich das p entferne verschwindet der gewünschte Absatz zwischen den Textabschnitten, aber die Lücke bleibt dennoch bestehen. Ich will sämtliche passenden Absätze von Leerzeilen getrennt neben dem Bild haben, aber so verschwindet lediglich der Absatz und die Lücke neben dem Bild bleibt bestehen. Alle Absätze sollen voneinander getrennt neben dem Bild sitzen.
    dann.PNG jetzt.PNG
     
  10. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    6.744
    Zustimmungen:
    628
    Entferne über die "Text" Ansicht des Editor das class="has-drop-cap" im ersten Absatz, das ist ein Überrest von Gutenberg und nutzt das von @maxe bereits als Ursache Deines Problems identifizierte CSS.
     
  11. kitchenartistry

    Registriert seit:
    12. Februar 2020
    Beiträge:
    11
    Zustimmungen:
    0
    Das habe ich bereits entfernt. In meinem letzten Beitrag habe ich ein Bild hochgeladen das zeigt, dass das die Ansicht zwar verändert, das Problem aber nicht behebt.
     
  12. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    6.744
    Zustimmungen:
    628
    Die ersten beiden Absätze sind mit Entfernen des class Attributs jetzt wie gewünscht voneinander getrennt neben dem Bild, im Gegensatz zu den Screenshots in #9.

    Die dann folgenden Absätze ab Ich sehe keinen Grund, ... stecken in weiteren Überresten von Gutenberg, in zwei verschachtelten div Containern, entferne noch diese Codeteile:
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
     
  13. kitchenartistry

    Registriert seit:
    12. Februar 2020
    Beiträge:
    11
    Zustimmungen:
    0
    VIELEN DANK! Endlich hat es geklappt.
     
    #13 kitchenartistry, 12. Februar 2020
    Zuletzt von einem Moderator bearbeitet: 13. Februar 2020
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden