1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Bei Plugin Installation: "Ein unerwarteter Fehler ist aufgetreten....."

Dieses Thema im Forum "Installation" wurde erstellt von coooper, 26. Oktober 2013.

  1. coooper

    coooper Well-Known Member

    Registriert seit:
    9. August 2008
    Beiträge:
    128
    Zustimmungen:
    0
    Immer wenn ich ein Plugin installieren möchte (über das Backend) und er sollte eigentlich auf wordpress.org zugreifen, erscheint der Fehler.
    Es ist bei allen Installationen die ich schon auf 3.7 upgedatet habe.

    Der Fehler erscheint schon, wenn ich auf Plugins -> Installieren Klicke (noch in der WP-Umgebung):


    Wenn ich dann noch ein Plugin in der Suche suchen will, kommt die Fehlermeldung auf weißem Hintergrund/WP ist weg):

    Der gleiche Fehler kommt auch, wenn ich "Empfohlen", "Populär", "Neueste" oder "Favoriten Plugin Installer" klicke.

    Alle Installationen liegen auf goneo.de, allerdings in unterschiedlichen Paketen bzw. auf unterschiedlichen Servern.

    [FONT=Roboto, arial, sans-serif]Zeichne ich die Verbindungen mit Snitch auf, dann wird folgendes protokolliert:

    [/FONT]
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
     
  2. SirEctor

    SirEctor WPDE-Team
    Mitarbeiter

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    11.522
    Zustimmungen:
    271
  3. coooper

    coooper Well-Known Member

    Registriert seit:
    9. August 2008
    Beiträge:
    128
    Zustimmungen:
    0
    Natürlich.
    Wie du an meinem Namen erkennen kannst, hatte ich dort auch schon von dem Fehler berichtet, allerdings dachte ich, ich poste es nochmals, mit mehr Details.
     
  4. SirEctor

    SirEctor WPDE-Team
    Mitarbeiter

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    11.522
    Zustimmungen:
    271
    Mal beim Hoster bzgl. Port 443 nachgehakt, wie hyperjojo im anderen Threat geschrieben hat?
     
  5. coooper

    coooper Well-Known Member

    Registriert seit:
    9. August 2008
    Beiträge:
    128
    Zustimmungen:
    0
    Nein.
    Du willst mir doch aber nicht sagen, dass eine eventuelle Firewall bei 3.6 und davor keine Auswirkungen hat und jetzt plötzlich doch???
    Seit 6 Jahren bin ich bei dem Hoster... Lass dir sagen, dass liegt an anderem.
    Was sagt denn der Techniker zu der Log-Datei?
     
  6. SirEctor

    SirEctor WPDE-Team
    Mitarbeiter

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    11.522
    Zustimmungen:
    271
    Du weißt aber schon, dass sich bei 3.7 etwas bei den Update-Funktionen getan hat (Beispiel "automatische Updates"), oder?

    Wenn Du seit 6 Jahren bei dem Hoster bist und es bisher immer funktionierte, kann es das natürlich nicht sein, verstehe.
     
  7. coooper

    coooper Well-Known Member

    Registriert seit:
    9. August 2008
    Beiträge:
    128
    Zustimmungen:
    0
    Ja, ist mir bekannt.
    Wenn also WP die automatischen Updates einbaut (der ja jede Minute bei WP anfragt ob ein Update da ist), und dann funktioniert die Kommunikation mit dem WordPress Server nicht mehr, dürfte es doch nahe liegen, dass es eben an der besagten neuen Funktion liegt, die ja eh kaum jemand haben will.

    Und wie wäre deine logische Erklärung, dass der Fehler auftritt?
     
  8. coooper

    coooper Well-Known Member

    Registriert seit:
    9. August 2008
    Beiträge:
    128
    Zustimmungen:
    0
    Wenn ich die alte plugin-install.php aus 3.6 nutze, dann funktionierts tadellos.
    Somit gehe ich einfach davon aus, dass die neue einfach buggy ist. Die ist aus um einiges größer als die alte.
     
  9. coooper

    coooper Well-Known Member

    Registriert seit:
    9. August 2008
    Beiträge:
    128
    Zustimmungen:
    0
  10. SirEctor

    SirEctor WPDE-Team
    Mitarbeiter

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    11.522
    Zustimmungen:
    271
    Das es ein Problem des aktuellen Update ist, wurde nie bestritten. Ich habe Dir nur geraten mal nach dem Port 443 zu fragen, der ja für SSL-Verbindungen zuständig ist. Und ich denke weiterhin, dass da der Hund begraben ist. Denn ich habe auf meinem Server die Probleme nicht.
     
  11. ocean90

    ocean90 Well-Known Member

    Registriert seit:
    30. Mai 2010
    Beiträge:
    165
    Zustimmungen:
    0
    Hey,

    die meisten Fehler liegen nach aktuellen Erkenntnissen an fehlerhaften cURL Versionen oder GnuTLS anstatt OpenSSL.

    An alle die den Fehler haben:
    * Bitte http://dd32.id.au/uploads/2013/10/https-debugger.zip laden
    * Entpacken und nach wp-content/plugins kopieren
    * Plugin aktivieren
    * Dashboard -> HTTPS Debugger öffnen
    * Den Output bei einem "Fail" kopieren und hier in den Thread posten

    Danke!
     
  12. Diandra

    Diandra Well-Known Member

    Registriert seit:
    8. August 2009
    Beiträge:
    83
    Zustimmungen:
    0
    ich habe das Problem auch auf einigen Seiten. Nach öffnen des Port 443 geht es wieder.

    Allerdings finde ich es schon seltsam, dass ich den jetzt öffnen muss. Es funktionierte vorher doch auch problemlos.

    LG Iris
     
  13. ginsterbusch

    ginsterbusch New Member

    Registriert seit:
    28. Oktober 2013
    Beiträge:
    4
    Zustimmungen:
    0
    DAS dachte ich anfangs auch, inzwischen bin ich mir da aber nicht mehr so sicher. Stattdessen vermute ich, dass PHP 5.2 eine andere Implementation / Einbindung von cURL nutzt, als PHP 5.3+.
    Siehe dazu auch: http://forum.wpde.org/installation/121193-mgl-loesung-premature-script-headers-aufrufproblem-update-core-php-plugins-php.html

    Bei meinem Webhoster sind die Versionsnummern der Bibliotheken nämlich sowohl bei PHP 5.2 als auch PHP 5.3 IDENTISCH, mit PHP 5.3(.26) treten aber die beschriebenen Fehler nicht mehr auf. D.h. nicht nur, dass sich die Dateien problemlos aufrufen lassen, sondern auch, dass Updates problemlos durchlaufen.

    cu, w0lf.
     
  14. Monika

    Monika Well-Known Member
    Ehrenmitglied

    Registriert seit:
    4. Juni 2005
    Beiträge:
    14.126
    Zustimmungen:
    1
    ich habe auf ein und denselben Server Domains wo es anstandslos klappt und welche wo nicht
    hier wo nicht


    1. [PASS]: Your WordPress install claims to support HTTPS Connections
    2. [PASS]: Checking that the HTTPS Root Certificate bundle exists and is accessible
    3. [PASS]: cURL is installed and supports SSL communication, cURL Details: version_number=464128; age=3; features=1597; ssl_version_number=0; version=7.21.0; host=i486-pc-linux-gnu; ssl_version=OpenSSL/0.9.8o; libz_version=1.2.3.4; protocols=dict,file,ftp,ftps,http,https,imap,imaps,ldap,ldaps,pop3,pop3s,rtsp,scp,sftp,smtp,smtps,telnet,tftp
    4. [PASS]: OpenSSL is installed. OpenSSL 0.9.8o 01 Jun 2010 9470207
    5. [PASS]: Checking if stream_socket_client exists
    6. [PASS]: Checking if openssl_x509_parse exists
    7. [PASS]: Verifying api.wordpress.org resolves correctly.
    8. [FAIL]: [Streams] Communication with WordPress.org failed with error: [http_request_failed]: 111: Connection refused
    9. [FAIL]: [Streams with a POST body] Communication with WordPress.org failed with error: [http_request_failed]: 111: Connection refused
    10. [FAIL]: [cURL] Communication with WordPress.org failed with error: [http_request_failed]: couldn't connect to host
    11. [FAIL]: [cURL with a POST body] Communication with WordPress.org failed with error: [http_request_failed]: couldn't connect to host
    12. [INFO]: PHP Version: 5.3.3-7+squeeze13

    wenn ich wüßt was geändert werden muss gebe ich es in Auftrag
     
  15. Bernhard1

    Bernhard1 Member

    Registriert seit:
    31. Oktober 2013
    Beiträge:
    10
    Zustimmungen:
    0
    Ist zu erwarten, dass in absehbarer Zeit der Fehler behoben wird?
    Kann ich auf eine frühere Version von WordPress downgraden?

    Im placed-Forum bekam ich die Antwort, dass es in meinem Fall angeblich daran liegt, dass ich bplaced nutze und nicht bplaced pro:
     
  16. Bernhard1

    Bernhard1 Member

    Registriert seit:
    31. Oktober 2013
    Beiträge:
    10
    Zustimmungen:
    0
    Hallo Iris,

    wie kann ich den Port 443 öffnen?

    LG
    Bernhard
     
  17. Bernhard1

    Bernhard1 Member

    Registriert seit:
    31. Oktober 2013
    Beiträge:
    10
    Zustimmungen:
    0
    Hallo ocean90,

    hier mein Output:


    1. [FAIL]: Your WordPress install doesn't appear to support HTTPS communication, that's OK, Communication with WordPress.org will continue over HTTP, but you'll not get Automatic Updates. You should ask your host to install the openssl PHP extension, and/or to install cURL with HTTPS support
    2. [FAIL]: Checking that the HTTPS Root Certificate bundle exists and is accessible
    3. [WARNING]: cURL is not installed on this server
    4. [PASS]: OpenSSL is installed. OpenSSL 1.0.1e 11 Feb 2013 268439647
    5. [FAIL]: Checking if stream_socket_client exists
    6. [PASS]: Checking if openssl_x509_parse exists
    7. [PASS]: Verifying api.wordpress.org resolves correctly.
    8. [INFO]: PHP Version: 5.5.3


    Im placed-Forum bekam ich die Antwort, dass es in meinem Fall angeblich daran liegt, dass ich bplaced nutze und nicht bplaced pro:

    Was hältst du davon?

    L.G.

    Bernhard
     
  18. ocean90

    ocean90 Well-Known Member

    Registriert seit:
    30. Mai 2010
    Beiträge:
    165
    Zustimmungen:
    0
    @Monika
    Bei dir sieht es ganz danach aus, als sei der HTTPS Port nicht offen. Mal nachfragen.


    @Bernhard
    Das ist eben der Nachteil, wenn man auf Free-Hosting setzt.
     
  19. Monika

    Monika Well-Known Member
    Ehrenmitglied

    Registriert seit:
    4. Juni 2005
    Beiträge:
    14.126
    Zustimmungen:
    1
    HI danke dir

    sorry, dass ich so spät antworte ich habe auf eine EMail gewartet, weil ich das so einstellte, aber sie kam nicht an :)
     
  20. reim

    reim New Member

    Registriert seit:
    13. März 2011
    Beiträge:
    4
    Zustimmungen:
    0
    Hallo ocean90,
    ich habe Wordpress 3.7.1 auf einer DS 710+ installiert und bekomme ebenfalls diese Meldung. Hier mein logging vom HTTS-Debugger:


    1. [PASS]: Your WordPress install claims to support HTTPS Connections
    2. [PASS]: Checking that the HTTPS Root Certificate bundle exists and is accessible
    3. [PASS]: cURL is installed and supports SSL communication, cURL Details: version_number=465408; age=3; features=49693; ssl_version_number=0; version=7.26.0-DEV; host=i686-pc-linux-gnu; ssl_version=OpenSSL/1.0.1e; libz_version=1.2.5; protocols=dict,file,ftp,ftps,gopher,http,https,imap,imaps,pop3,pop3s,rtsp,scp,sftp,smtp,smtps,telnet,tftp
    4. [PASS]: OpenSSL is installed. OpenSSL 1.0.1e-fips 11 Feb 2013 268439647
    5. [PASS]: Checking if stream_socket_client exists
    6. [PASS]: Checking if openssl_x509_parse exists
    7. [FAIL]: Verifying api.wordpress.org resolves correctly. api.wordpress.org
    8. [FAIL]: [Streams] Communication with WordPress.org failed with error: [http_request_failed]: 0: php_network_getaddresses: getaddrinfo failed: Temporary failure in name resolution
    9. [FAIL]: [Streams with a POST body] Communication with WordPress.org failed with error: [http_request_failed]: 0: php_network_getaddresses: getaddrinfo failed: Temporary failure in name resolution
    10. [FAIL]: [cURL] Communication with WordPress.org failed with error: [http_failure]: Es sind keine HTTP-Transports verfügbar, welche die gewünschte Abfrage ausführen könnte.
    11. [FAIL]: [cURL with a POST body] Communication with WordPress.org failed with error: [http_failure]: Es sind keine HTTP-Transports verfügbar, welche die gewünschte Abfrage ausführen könnte.
    12. [INFO]: PHP Version: 5.3.27

    würde mich freuen, wenn Du auch einen Tipp für mich hättest.

    Gruss Reim
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden