1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WP 4.7 Bild in Beitrag verlinken

Dieses Thema im Forum "Konfiguration" wurde erstellt von RimFrost, 18. November 2016.

  1. RimFrost

    RimFrost Well-Known Member

    Registriert seit:
    21. März 2011
    Beiträge:
    155
    Zustimmungen:
    0
    Moin!
    Ich versuche seit geraumer Zeit Bilder in einem Template so auszugeben das, wenn man drauf klickt, zum Originalbild kommt. Leider komm ich nicht dahinter wie man das macht.

    Den Code habe ich bisher verwendet
    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Unten in der Zeile des Browsers steht nun z.B. www.domain.de/unterseite. Was ich möchte ist das es ungefähr so aussieht: www.domain.de/bilder/bild01.jpg
     
  2. RimFrost

    RimFrost Well-Known Member

    Registriert seit:
    21. März 2011
    Beiträge:
    155
    Zustimmungen:
    0
    niemand nen tipp? :(
     
  3. Nevery

    Nevery Well-Known Member

    Registriert seit:
    15. Oktober 2013
    Beiträge:
    404
    Zustimmungen:
    0
  4. RimFrost

    RimFrost Well-Known Member

    Registriert seit:
    21. März 2011
    Beiträge:
    155
    Zustimmungen:
    0
    nope hat nicht geholfen :(
     
  5. maxe

    maxe Well-Known Member
    Ehrenmitglied

    Registriert seit:
    1. Mai 2008
    Beiträge:
    19.445
    Zustimmungen:
    243
    Wie hast du es denn genau getestet?
    mMn sollte es nämlich genau mit wp_get_attachment_image_src() laufen.

    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
     
  6. SirEctor

    SirEctor Well-Known Member
    Ehrenmitglied

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    12.323
    Zustimmungen:
    412
  7. RimFrost

    RimFrost Well-Known Member

    Registriert seit:
    21. März 2011
    Beiträge:
    155
    Zustimmungen:
    0
    danke das funktioniert zu 90% wie ich es möchte.
    Leider geht meine Lightbox nicht auf wenn ichs auf Bild klicke :(
     
  8. maxe

    maxe Well-Known Member
    Ehrenmitglied

    Registriert seit:
    1. Mai 2008
    Beiträge:
    19.445
    Zustimmungen:
    243
    Lightbox? War bisher ja gar nicht die Rede von. Je nach Lightbox reicht vielleicht ein rel="lightbox"
     
  9. RimFrost

    RimFrost Well-Known Member

    Registriert seit:
    21. März 2011
    Beiträge:
    155
    Zustimmungen:
    0
    sorry wusste nicht dass das relevant ist :(
    das rel="lightbox" hat natürlich nicht funktioniert (wäre ja auch zu einfach)

    ich benutzt hierfür das Plugin:
    https://de.wordpress.org/plugins/responsive-lightbox/
     
  10. maxe

    maxe Well-Known Member
    Ehrenmitglied

    Registriert seit:
    1. Mai 2008
    Beiträge:
    19.445
    Zustimmungen:
    243
  11. RimFrost

    RimFrost Well-Known Member

    Registriert seit:
    21. März 2011
    Beiträge:
    155
    Zustimmungen:
    0
    ja der ist gleich. hab ich schon überprüft

    nur für den Fall das ich rel falsch gesetzt habe: <a rel="nofollow" rel="lightbox" href="<?php echo... ist richtig oder?
     
  12. SirEctor

    SirEctor Well-Known Member
    Ehrenmitglied

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    12.323
    Zustimmungen:
    412
    2x rel? Das kann nicht funktionieren. Warum setzt du das 2x?
     
  13. RimFrost

    RimFrost Well-Known Member

    Registriert seit:
    21. März 2011
    Beiträge:
    155
    Zustimmungen:
    0
    Keine Ahnung. Vielleicht weil ich nicht wusste das es nicht geht :D
    hab das nofollow jetzt raus genommen und mal die einzelnen Scripte des Plugins getestet aber leider immer das selbe Ergebnis. Das Bild öffnet sich in keiner Lightbox. Der Wähler stimmt auch

    EDIT: Der Fehler lag bei mir! Hatte "Conditional loading" aktiviert und das war wohl des Pudels Kern. Jetzt funktioniert es wie es soll

    Nochmals Danke!!!!!
     
    #13 RimFrost, 22. November 2016
    Zuletzt bearbeitet: 22. November 2016
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden