1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Bilder vom PC hochladen

Dieses Thema im Forum "Allgemeines" wurde erstellt von Martin00, 21. Dezember 2009.

  1. Martin00

    Martin00 Well-Known Member

    Registriert seit:
    21. Dezember 2009
    Beiträge:
    88
    Zustimmungen:
    0
    Hallo,

    Habe ein Problem mit dem hochladen vom PC auf den Server.
    Wenn ich unter Artikel bearbeiten ein Bild hochladen will, kommt die Meldung:

    Das Verzeichnis /wp-content/uploads/2009/12 kann nicht angelegt werden. Ist
    das übergeordnete Verzeichnis durch den Server beschreibbar?

    Ich habe beim Server nachgefragt und die sagen es ist alles richtig eingerichtet.

    Vielleicht kann mir hier jemand weiterhelfen - Danke!

    Lg, Martin
     
  2. Kurt

    Kurt Well-Known Member

    Registriert seit:
    3. Dezember 2006
    Beiträge:
    331
    Zustimmungen:
    0
    du musst schreibrechte vergeben. Log dich mit eine FTP Programm ein und setz den chmod auf 777 dann gehts 1000%ig
    Rechtsklick auf den Upload ordner dann steht da Rechte oder Chmod oder sowas machste auf 777
     
  3. Martin00

    Martin00 Well-Known Member

    Registriert seit:
    21. Dezember 2009
    Beiträge:
    88
    Zustimmungen:
    0
    Danke Kurt!

    Jedoch es muss einen anderen Grund geben, chmod ist auf 777, es geht aber trotzdem nicht!

    Wieder kommt die gleiche Meldung:
    Das Verzeichnis /wp-content/uploads/2009/12 kann nicht angelegt werden.

    Keine Ahnung, was da schuld ist.

    Lg, Martin
     
  4. Bambaataa

    Bambaataa Well-Known Member
    Ehrenmitglied

    Registriert seit:
    17. Mai 2009
    Beiträge:
    2.471
    Zustimmungen:
    8
    Da steht was von "übergeordnete Verzeichnis". Wo liegt den Dein Blog? In einem Unterverzeichniss? Schau mal wie da -> Einstellungen -> Verschiedenes die Pfade lauten und ob die stimmen?
     
  5. Martin00

    Martin00 Well-Known Member

    Registriert seit:
    21. Dezember 2009
    Beiträge:
    88
    Zustimmungen:
    0
    die Pfade passen wp-content/uploads
    Aber es geht trotzdem nicht.
     
  6. ole1210

    ole1210 Well-Known Member

    Registriert seit:
    8. April 2008
    Beiträge:
    49
    Zustimmungen:
    0
    Habe ein ganz ähnliches Problem. Bekomme fast die selbe Meldung:

    Allerdings lautet Sie bei mir
    Das Verzeichnis /wp-content/uploads/2009/03 kann nicht angelegt werden. Ist das übergeordnete Verzeichnis durch den Server beschreibbar?

    WP will die Datei in dem Ordner 03 ablegen, obwohl WP die korrekte Uhrzeit und das korrekte Datum kennt. Schreibrechte sind alle auf 777

    Lösche ich die Ordner und belasse nur uploads auf 777 meckert WP trotzdem.

    Wieso können die Ordner trotz korrektem 777er nicht angelegt werden und wieso versucht WP trotz korrektem Datum die Dateien in 03 abzulegen?
     
  7. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.823
    Zustimmungen:
    1
    Das Verzeichnis zum Upload richtet sich nicht nach dem aktuellen Datum, sondern nach dem Veröffentlichungsdatum des Artikels, zu dem der Upload zugeordnet ist.

    Gruß
    Ingo
     
  8. ole1210

    ole1210 Well-Known Member

    Registriert seit:
    8. April 2008
    Beiträge:
    49
    Zustimmungen:
    0
    Ahh...das passt. Der Artikel ist ausm März. Das erklärt aber trotzdem nicht, wieso der Uplaod trotz garantiert korrekter Einstellungen nicht funktioniert.
     
  9. bgeissler

    bgeissler Well-Known Member

    Registriert seit:
    6. August 2006
    Beiträge:
    4.404
    Zustimmungen:
    0
    Ich hab das mit der Ablage nach Datumsordnern auch noch nie hinbekommen. Gleiche Fehlermeldung.
    Deshalb habe ich die Option deaktiviert, alle Bilder landen ohne Fehler in einem Verzeichnis (/uploads/.
    Das ist auch gut so: ich finde Bilder für eine Wiederrverwendunbg schneller und im Mediapool kann ich sie ja nach Datum sortiert anzeigen.
     
  10. bgeissler

    bgeissler Well-Known Member

    Registriert seit:
    6. August 2006
    Beiträge:
    4.404
    Zustimmungen:
    0
    Der Vorteil einer Ablage in Datumsordnern hat sich mir auch noch nicht erschlossen. Interessanter wäre eine thematische Ablagemöglichkeit.
     
  11. ole1210

    ole1210 Well-Known Member

    Registriert seit:
    8. April 2008
    Beiträge:
    49
    Zustimmungen:
    0
    Ich sortiere gerne nach Monaten, da ich die Bilder so schneller wiederfinde. Hab nachdem ich die Fehlermeldung bekommen habe auch versucht, die Funktion zu deaktivieren. Danach meldet WP mir folgendes:

    Das Verzeichnis /wp-content/uploads kann nicht angelegt werden. Ist das übergeordnete Verzeichnis durch den Server beschreibbar?

    /uploads existiert, hat 777 und es sind schon bilder drin. Was mach WP da???
     
  12. bgeissler

    bgeissler Well-Known Member

    Registriert seit:
    6. August 2006
    Beiträge:
    4.404
    Zustimmungen:
    0
    Gib unter Einstellungen - Verschiedenes noch den
    "Kompletter Pfad zu den Dateien" http://Domain/wp-content/uploads
    ein
     
  13. ole1210

    ole1210 Well-Known Member

    Registriert seit:
    8. April 2008
    Beiträge:
    49
    Zustimmungen:
    0
    Mhh...nicht gut... dann sagt mir WP folgendes:

    Das Verzeichnis /var/www/webxyz/html/pfad/http://www.domain.de/wp-content/uploads/2009/03 kann nicht angelegt werden. Ist das übergeordnete Verzeichnis durch den Server beschreibbar?
     
  14. bgeissler

    bgeissler Well-Known Member

    Registriert seit:
    6. August 2006
    Beiträge:
    4.404
    Zustimmungen:
    0
    nicht gut: ersetze "Domain" durch den Namen deiner Domain
     
  15. ole1210

    ole1210 Well-Known Member

    Registriert seit:
    8. April 2008
    Beiträge:
    49
    Zustimmungen:
    0
    Das habe ich selbstverständlich gemacht.

    - webxyz
    - pfad
    - domain

    Habe ich hier nur unkenntlich gemacht!
     
  16. bgeissler

    bgeissler Well-Known Member

    Registriert seit:
    6. August 2006
    Beiträge:
    4.404
    Zustimmungen:
    0
    Das hast du aber nicht vor die URL gesetzt ?
     
  17. ole1210

    ole1210 Well-Known Member

    Registriert seit:
    8. April 2008
    Beiträge:
    49
    Zustimmungen:
    0
    nein. habe nur meine url angegeben.

    habe neben der wp-installation noch 4 weitere völlig identische installationen auf dem selben server liegen. dort tritt das phänomen nicht auf.
     
  18. Martin00

    Martin00 Well-Known Member

    Registriert seit:
    21. Dezember 2009
    Beiträge:
    88
    Zustimmungen:
    0
    Also ich habe nun unter Einstellungen-Verschiedenes die Datumsfunktion deaktiviert und darauf versucht ein Bild hochzuladen und zum Schreck kommt wieder die gleiche Fehlermeldung.

    Interessant ist, dass es komischer Weise bei einer anderen Domain ohne Fehlermeldung funktioniert.

    Konkret funktioniert es bei der Hauptdomain, also http://domain.com
    Jedoch bei der Subdomain http://test.domain.com funktioniert das Hochladen von Bildern vom PC aus nicht.

    Für beide Domains habe ich eine eigene Datenbank angelegt und die Installation von WP ist bei beiden gleich.
     
  19. ole1210

    ole1210 Well-Known Member

    Registriert seit:
    8. April 2008
    Beiträge:
    49
    Zustimmungen:
    0
    Genau wie bei mir.
     
  20. bgeissler

    bgeissler Well-Known Member

    Registriert seit:
    6. August 2006
    Beiträge:
    4.404
    Zustimmungen:
    0
    Liegt es dann eurer Meinung nach eindeutig an der Subdomain?
    Wenn ja, was habt ihr unter den Einstellungen als Pfad angegeben?

    Gibt es einen Link zu einer HP?
    Und zu einem vorhandenen Bild in /uploads?
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden