1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Burger-Menu in Landscape Mode auf dem iPad

Dieses Thema im Forum "Design" wurde erstellt von j4n_solo, 25. März 2024.

  1. j4n_solo

    j4n_solo New Member

    Registriert seit:
    25. März 2024
    Beiträge:
    2
    Zustimmungen:
    0
    Servus zusammen,

    ich habe schon alles Erdenkliche versucht, aber finde einfach keine Lösung für mein Problem. Daher versuche ich nun hier mein Glück.

    Problem:
    Im Landscape Mode (Querformat) auf dem iPad wird standardmäßig das normale (primäre) Menü angezeigt. Da die Anzeige durch die vielen Menüpunkte in dieser Ansicht jedoch zweizeilig erscheint, wollte ich per CSS im Customizer festlegen, dass das mobile Menü (das mit den 3 Punkten, bzw. in meinem Fall das Burger-Menu) im Landscape Mode immer angezeigt wird, unabhängig von der Bildschirmgröße und der Bildschirmauflösung. Da ich mittlerweile unzählige Versuche und Kombinationen an CSS-Code vergeblich ausprobiert habe, weiß ich einfach keinen Rat mehr. Ich schaffe es im Landscape Mode das primäre Menü (.primary-menu) auszublenden, allerdings nicht anstelle dessen das mobile Menü, bzw. die andere Ansicht des Menüs (.menu-modal), so wie es im normalen Modus (Hochformat) angezeigt wird, anzuzeigen. Im Hochformat wird es immer angezeigt. Was ist zu tun?

    Zur Info: Ich habe es mit verschiedenen Browsern auf dem iPad getestet (Safari, Chrome, Brave); ein anderes Tablet steht mir leider nicht zur Verfügung.

    Ich würde mich wirklich sehr freuen, wenn mir hier jemand helfen könnte.

    Vielen Dank vorab.

    LG Jan

    PS: Im offiziellen WordPress.org-Forum (im Bereich Twenty Twenty) habe ich diesen Beitrag von ein paar Tagen auch schon erstellt, da es mir hier zunächst am sinnvollsten erschien, da ich dieses Theme ja nutze, bislang jedoch leider keinerlei Reaktion.
     
  2. threadi

    threadi Well-Known Member

    Registriert seit:
    9. Oktober 2020
    Beiträge:
    2.007
    Zustimmungen:
    402
    Ein Link zur Seite, wie in den Forenregeln beschrieben, könnte helfen dir zu helfen.
     
  3. j4n_solo

    j4n_solo New Member

    Registriert seit:
    25. März 2024
    Beiträge:
    2
    Zustimmungen:
    0
    Sorry, völlig vergessen. Danke für den Hinweis.

    Hier die Seite: https://www.tsg-himbach.de

    Allerdings muss ich dazu sagen, dass ich den Landscape Mode - eben aus genannten Gründen - per Plugin deaktiviert habe und diesen auch nur ungern wieder aktivieren würde, solange ich hierfür keine Lösung gefunden habe.
     
  4. threadi

    threadi Well-Known Member

    Registriert seit:
    9. Oktober 2020
    Beiträge:
    2.007
    Zustimmungen:
    402
    Eigentlich müsstest Du die Breakpoints für den Viewport neu definieren. Leider erkenne ich wegen der Optimierung durch das Autoptimize-Plugin nicht woher da welcher Code stammt, weshalb es weiterhin schwer ist dir zu helfen.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden