1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Cannot modify header information

Dieses Thema im Forum "Installation" wurde erstellt von 99dingos, 30. Dezember 2017.

  1. 99dingos

    99dingos New Member

    Registriert seit:
    30. Oktober 2014
    Beiträge:
    4
    Zustimmungen:
    0
    Hallo,

    ich wollte auf WP 4.9.1. upgraden und als nächstes konnte ich keine einzige Funktion im Dashboard aufrufen. Das einzige was kam war diese Fehlermeldung. Egal welchen Link ich versucht habe.


    Notice: Die verwendete Konstruktor-Methode für WP_Widget in VMenuWidget ist seit Version 4.3.0 veraltet! Verwende stattdessen __construct(). in /var/www/web1351/html/wordpress/wp-includes/functions.php on line 3901

    Notice: Die verwendete Konstruktor-Methode für WP_Widget in LoginWidget ist seit Version 4.3.0 veraltet! Verwende stattdessen __construct(). in /var/www/web1351/html/wordpress/wp-includes/functions.php on line 3901

    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web1351/html/wordpress/wp-includes/functions.php:3901) in /var/www/web1351/html/wordpress/wp-includes/pluggable.php on line 1216


    Dann habe ich über FTP das neue WP installiert, und zwar Schritt für Schritt nach der Anweisung:
    https://codex.wordpress.org/Upgrading_WordPress_-_Extended_Instructions

    Die Fehlermeldung war immer noch da, und ich konnte übrhaupt nicht mehr einloggen oder auch nur die Seite aufrufen.

    Jetzt habe ich die Foren durchforstet und es wurde immer wieder über diese Fehlermeldung gesagt, dass es ein Whitespace im php code gibt, etc.
    Habe ich überprüft, aber nichts dergleichen gefunden. Ich verstehe aber auch nicht wirklich was von PHP.

    Alle Fehlermeldungen - es waren bei letzten Verlassen vom Dashboard noch einige mehr - haben immer auf diese eine line 3901 in der functions.php verwiesen.
    Im englischen Forum wird gesagt:
    Interpreting the Error Message: If the error message states: Warning: Cannot modify header information - headers already sent by (output started at /path/blog/wp-config.php:34) in /path/blog/wp-login.php on line 42, then the problem is at line #34 of wp-config.php, not line #42 of wp-login.php. In this scenario, line #42 of wp-login.php is the victim. It is being affected by the excess whitespace at line #34 of wp-config.php.


    Also gehe ich jetzt davon aus, dass es sich hier um einen Fehler in der function.php handeln muss. Und eigentlich wird ja - soweit ich den Code verstehe - genau da nur von dieser Fehlermeldung gesprochen.
    Ich stelle jetzt die Umgebung dieser line 3901 der function.php dar - vielleicht kann mir jemand helfen und sagen, was und wie hier korrigiert werden muss:


    if ( WP_DEBUG && apply_filters( 'deprecated_constructor_trigger_error', true ) ) {
    if ( function_exists( '__' ) ) {
    if ( ! empty( $parent_class ) ) {
    /* translators: 1: PHP class name, 2: PHP parent class name, 3: version number, 4: __construct() method */
    trigger_error( sprintf( __( 'The called constructor method for %1$s in %2$s is <strong>deprecated</strong> since version %3$s! Use %4$s instead.' ),
    $class, $parent_class, $version, '<pre>__construct()</pre>' ) );
    } else {
    /* translators: 1: PHP class name, 2: version number, 3: __construct() method */
    trigger_error( sprintf( __( 'The called constructor method for %1$s is <strong>deprecated</strong> since version %2$s! Use %3$s instead.' ),
    $class, $version, '<pre>__construct()</pre>' ) );
    }
    } else {
    if ( ! empty( $parent_class ) ) {
    trigger_error( sprintf( 'The called constructor method for %1$s in %2$s is <strong>deprecated</strong> since version %3$s! Use %4$s instead.',
    $class, $parent_class, $version, '<pre>__construct()</pre>' ) );
    } else {
    trigger_error( sprintf( 'The called constructor method for %1$s is <strong>deprecated</strong> since version %2$s! Use %3$s instead.',
    $class, $version, '<pre>__construct()</pre>' ) );
    }
    }
    }

    }



    Vielen Dank und LG
    Birgit

    PS: ich glaube auch nicht dass es an einem "whitespace" Problem liegt - die Fehlermeldung hatte ich ja schon zuvor - und jetzt ist die alte function.php überschrieben und trotzdem die gleich Fehlermeldung
    Hier sind noch weitere Fehlermeldungen, sie weisen aber, wie gesagt, alle auf die line 3901 hin.

    Notice: Die verwendete Konstruktor-Methode für WP_Widget in VMenuWidget ist seit Version 4.3.0 veraltet! Verwende stattdessen
    __construct()
    . in /var/www/web1351/html/wordpress/wp-includes/functions.php on line 3901

    Notice: Die verwendete Konstruktor-Methode für WP_Widget in LoginWidget ist seit Version 4.3.0 veraltet! Verwende stattdessen
    __construct()
    . in /var/www/web1351/html/wordpress/wp-includes/functions.php on line 3901


    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web1351/html/wordpress/wp-includes/functions.php:3901) in /var/www/web1351/html/wordpress/wp-login.php on line 421

    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web1351/html/wordpress/wp-includes/functions.php:3901) in /var/www/web1351/html/wordpress/wp-login.php on line 434

    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web1351/html/wordpress/wp-includes/functions.php:3901) in /var/www/web1351/html/wordpress/wp-includes/pluggable.php on line 948

    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web1351/html/wordpress/wp-includes/functions.php:3901) in /var/www/web1351/html/wordpress/wp-includes/pluggable.php on line 949

    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web1351/html/wordpress/wp-includes/functions.php:3901) in /var/www/web1351/html/wordpress/wp-includes/pluggable.php on line 950

    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web1351/html/wordpress/wp-includes/functions.php:3901) in /var/www/web1351/html/wordpress/wp-includes/pluggable.php on line 951

    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web1351/html/wordpress/wp-includes/functions.php:3901) in /var/www/web1351/html/wordpress/wp-includes/pluggable.php on line 952

    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web1351/html/wordpress/wp-includes/functions.php:3901) in /var/www/web1351/html/wordpress/wp-includes/pluggable.php on line 953

    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web1351/html/wordpress/wp-includes/functions.php:3901) in /var/www/web1351/html/wordpress/wp-includes/pluggable.php on line 956

    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web1351/html/wordpress/wp-includes/functions.php:3901) in /var/www/web1351/html/wordpress/wp-includes/pluggable.php on line 957

    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web1351/html/wordpress/wp-includes/functions.php:3901) in /var/www/web1351/html/wordpress/wp-includes/pluggable.php on line 960

    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web1351/html/wordpress/wp-includes/functions.php:3901) in /var/www/web1351/html/wordpress/wp-includes/pluggable.php on line 961

    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web1351/html/wordpress/wp-includes/functions.php:3901) in /var/www/web1351/html/wordpress/wp-includes/pluggable.php on line 962

    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web1351/html/wordpress/wp-includes/functions.php:3901) in /var/www/web1351/html/wordpress/wp-includes/pluggable.php on line 963

    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web1351/html/wordpress/wp-includes/functions.php:3901) in /var/www/web1351/html/wordpress/wp-includes/pluggable.php on line 966

    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web1351/html/wordpress/wp-includes/functions.php:3901) in /var/www/web1351/html/wordpress/wp-includes/pluggable.php on line 967

    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web1351/html/wordpress/wp-includes/functions.php:3901) in /var/www/web1351/html/wordpress/wp-includes/pluggable.php on line 968

    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web1351/html/wordpress/wp-includes/functions.php:3901) in /var/www/web1351/html/wordpress/wp-includes/pluggable.php on line 969

    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web1351/html/wordpress/wp-includes/functions.php:3901) in /var/www/web1351/html/wordpress/wp-includes/pluggable.php on line 1216
     
  2. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    9.440
    Zustimmungen:
    1.215
  3. 99dingos

    99dingos New Member

    Registriert seit:
    30. Oktober 2014
    Beiträge:
    4
    Zustimmungen:
    0
    Liebe(r) b3317133!

    VIELEN DANK - Wouw - ich habe Stunden damit verbracht (fast zwei Tage) im Front end im Back end - Neuinstallation über ftp über server ..... Ich weiß nicht was noch alles...
    und dann war es ein fucking Wort.
    Und das mit dem Theme werde ich mir auch noch ansehen. Aber die Seite funktioniert wie am Schnürchen.
    :razz: Liebe Grüße Birgit
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden