1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WP 5.2 Challenge: Bilder werden trotz selben Pfades nicht angezeigt

Dieses Thema im Forum "Installation" wurde erstellt von basty, 11. Oktober 2019.

  1. basty

    basty New Member

    Registriert seit:
    11. Oktober 2019
    Beiträge:
    2
    Zustimmungen:
    0
    Hallo,

    bin kurz vrom Verzweifeln und muss mich jetzt mal an die Experten wenden.

    Ich möchte meine Beträge von einem alten Wordpress (ohne SSL Zertifikat) in ein neues Wordpress mit neuer Domain und SSL Zertifikat übertragen.

    Anstatt der Bilder wird der Bildname als Link angezeigt. Das Bild kann man im Brower öffnen.
    Ich habe in dem importierten beitrag die Linkadresse von http zu https geändert sowie die Domain angepasst.
    Das Bild ist physisch auch im Ordner wp-content/uploads/Jahr/Monat.
    Wenn ich das widget simple SSL ausschalte werden die Bilder angezeigt.
    Im neuen Wordpress angelegt Beiträge zeigen die Bilder ganz normal an.
    Wenn ich die links der Bilder vergleiche sind diese ident bis es zu Jahr/Monat/ kommt.
    Unter Medien werden die Bilder welche importiert wurden nicht angezeigt obwohl sie im ftp in den Ordnern vorhanden sind. Da es eine Responsive Design ist sind in dem Fall immer gleich 20 Größen des Bildes vorhanden.
    Rechte in den Upload Ordnern sind ident.
    htacess oder Umleitung sind nicht aktiviert.

    Hier als Hilfe ein Beispiel:
    Beitrag erstellt im neuen Wordpress. Bild wird normal angezeigt.
    https://www.building-one-world.org/2019/04/bowler-bekaempft-plastik-flut-in-ghana/

    Importierter Beitrag. Bild wird nur als Link angezeigt.
    https://www.building-one-world.org/2018/12/fotos-vom-bosnien-transport/

    Ich hab echt keine Ahnung wobei ich auch echt kein Profi bin.

    Wenn mehr infos benötigt werden Bitte Bescheid sagen. Bin dankbar für jede Hilfe.
     
  2. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    6.375
    Zustimmungen:
    573
    Das eingebundene Bild im importierten Beitrag existiert nicht auf dem Server, es erzeugt einen 404 Fehler.
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Wende Dich am besten an die Person, die den alten Website ursprünglich eingerichtet hat, die sollte alle Eckdaten bzgl. der Bilder und der nötigen und in der alten Installation vorhandenen kleineren Vorschau-Bildgrössen usw. kennen.

    Durch einfaches Kopieren von Bildern via FTP kennt WordPress diese nicht automatisch, sie müssen dafür über das WordPress Backend in die Mediathek eingefügt werden. Erst dann kennt WordPress die Bilder und erzeugt die im aktiven Theme geforderten Bildgrössen. Sind in den Beiträgen andere Bildgrössen eingebunden als im aktiven Theme genutzt werden, musst Du die Beiträge wohl manuell nachbearbeiten.
     
  3. basty

    basty New Member

    Registriert seit:
    11. Oktober 2019
    Beiträge:
    2
    Zustimmungen:
    0
    Hi, danke für die promte Antwort.

    Ja richtig, das thumb ist nicht im Ordner. Frage mich nur warum es angezeigt wurde als SSL aus war. (vielleicht hatte ich da noch nicht die Domain umgeändert)
    In der Mediathek müssen die Bilder nicht unbedinkt ersichtlich sein. Es würde reichen wenn die Bilder direkt auf der Website dargestellt werden bei den alten Beiträgen. Könnte ich sonst einfach die upload Ordner per ftp rüberschieben? Würde das funktionieren? Also erst Ordner im neuen Pfad einfügen und im Anschluss die Beiträge kopieren. Danach dann mit search and Replace die Domain anpassen.

    Die alte Website ist auch von mir :confused: . Backend sagt mir auch nicht viel? Könntest du dass noch mal für Dummies kurz erläuter falls ordner rüber kopieren nicht funktionieren würde?

    Vielen Dank und schon mal schönen Samstag.
     
  4. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    6.375
    Zustimmungen:
    573
    Mehr "für Dummies" als in #2 kann ich es nicht erklären, sorry.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden