1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Contact 7 Form: Emails werden als Spam erkannt (ReCaptcha)

Dieses Thema im Forum "Plugins und Widgets" wurde erstellt von Janawieimmer, 3. Mai 2020.

  1. Janawieimmer

    Janawieimmer Member

    Registriert seit:
    24. Februar 2020
    Beiträge:
    12
    Zustimmungen:
    0
    Hallo,

    ich nutzt die Contact Form 7 für meine Kontaktformulare auf meiner Webseite. Leider gehen dort seit Beginn keine E-Mails raus. Es erscheint immer eine Fehlermeldung mit "orangenem" Rand, dass man es später nochmal versuchen solle.

    Ich nutze ReCaptcha als Spam- und Virusschutz. Heute habe ich diesen kurzfristig ausgeschaltet, um zu überprüfen, ob es daran liegt, da eine "orangene" Fehlermeldung bei Contact Form 7 ja auf den Spamschutz hinweist. Und siehe da: Ohne ReCaptcha funktioniert es. Ich frage mich nun, wie ich es schaffe einen Spamschutz zu haben und gleichzeitig "normalen" Menschen die Nutzung meines Kontaktformulars zu ermöglichen. Aktuell befindet sich meine Seite noch im Maintenance-Modus.

    Liebe Grüße und vielen Dank bereits im Voraus! :)
    Jana
     
  2. pascal88

    pascal88 Well-Known Member

    Registriert seit:
    12. September 2014
    Beiträge:
    83
    Zustimmungen:
    9
    Ist die Config richtig? Sprich die Public und Private Keys? Keine Leerzeichen am Ende o.ä. und die richtige Auswahl der reCaptcha Version (v3)?
     
  3. Janawieimmer

    Janawieimmer Member

    Registriert seit:
    24. Februar 2020
    Beiträge:
    12
    Zustimmungen:
    0
    Hi! Eigentlich hätte ich gerne die v2 genutzt, damit das ReCaptcha-Logo nicht auf jeder Seite unten rechts erscheint. Mit v3 scheint es aber jetzt zu funktionieren. Funktionalität schlägt denke ich Design :) Danke für den Wink mit "v3". Daran lag es wohl!
     
  4. pascal88

    pascal88 Well-Known Member

    Registriert seit:
    12. September 2014
    Beiträge:
    83
    Zustimmungen:
    9
    Du könntest das Logo auf den Seiten ohne Formular ausblenden. Dafür kursieren Anleitungen im Netz.

    Sonst einfach das Cf7 Honeypot Plugin nutzen - wäre eine noch bessere Lösung.
    Damit werden versteckte Felder eingebaut, um die Spambots zu täuschen. Klappt auch zuverlässig.

    Gruß

    Pascal
     
  5. angalo

    angalo Member

    Registriert seit:
    12. April 2013
    Beiträge:
    6
    Zustimmungen:
    0
    Hallo zusammen,

    auch ich kämpfe mit dem Problem, dass mit aktiviertem recaptcha V3 JEDE über CF7 Kontaktformular erstellte Nachricht als Spam gewertet wird (also das Äquivalent für "Die Mitteilung des Absenders konnte nicht gesendet werden." mit orangener Umrandung). Das passiert auch bereits mit dem automatisch von CF7 erstellten Formular. Sowie ich captcha integriere , funktioniert das Absenden der Nachricht nicht mehr.
    Stutzig machen mich zu einen aus dem Beitrag von Pascal88: "die richtige Auswahl der reCaptcha Version (v3)", denn in der von mir genutzten CF7 Vers. 5.1.9 gibt es da keine Auswahlmöglichkeit. V3 ist suzusagen "gesetzt".
    Weiter gehe ich davon aus, dass nach wie vor mit dem Tag [recaptcha] die Prüfung in das Formular eingebunden wird. Tatsächlich ist aber bei Aufruf der Seite nichts zu sehen, was auch recaptcha hinweist.

    Wo kann ich da mit der Fehlersuche ansetzen?

    Gruß
    angalo
     
  6. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    8.605
    Zustimmungen:
    979
    Beispielsweise in der Dokumentation von Contact Form 7. Dort ist auch was zum genannten Tag zu finden:
    Weiterhin in den Forenregeln, ein Link zur Seite fehlt...
     
  7. angalo

    angalo Member

    Registriert seit:
    12. April 2013
    Beiträge:
    6
    Zustimmungen:
    0
    Danke, das hat schon mal die Sache mit dem Tag geklärt.
    Das Weitere habe ich in den FAQs gefunden. Letztendlich stellte sich ein veraltetes NextGENGallery-Plugin als Ursache heraus:
    Kein Recaptcha-Signet auf der Formularseite und das Antwort-Tooken war immer leer.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden