1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

CORS Blocked trotz htaccess Eintrag

Dieses Thema im Forum "Konfiguration" wurde erstellt von mofenx, 11. November 2021.

Schlagworte:
  1. mofenx

    mofenx New Member

    Registriert seit:
    11. November 2021
    Beiträge:
    2
    Zustimmungen:
    0
    Guten Tag,
    auf meiner Website, welche mit WordPress und Woocommerce läuft gibt es ein kleines CORS Problem. Leider können Icons und auch Statistiken im Woocommerce "Statistiken" Tab nicht geladen werden. (Beim Abrufen deiner Statistik ist ein Fehler aufgetreten. Bitte versuche es erneut.)

    Leider fällt mir nicht mehr ein was ich noch testen könnte…

    Die htaccess habe ich bereits mit folgendem Eintrag erweitert:

    <IfModule mod_headers.c>
    <FilesMatch "\.(ttf|ttc|otf|eot|woff|woff2|font.css|css|js)$">
    Header set Access-Control-Allow-Origin "*"
    </FilesMatch>
    </IfModule>


    Passiert ist leider nichts.
    Habe verschiedene Möglichkeiten getestet den Header Eintrag einzubauen.
    Beispielsweise alle diese Varianten: https://de.wordpress.org/support/topic/icons-werden-bei-eingabe-von-www-nicht-angezeigt/
    Auch versucht habe ich den Eintrag per functions.php einzubauen. Auch ohne Erfolg leider.

    Die Fehlermeldung(en):

    Access to font at 'https://domain.de/wp-content/themes/astra/assets/fonts/astra.woff' from origin 'https://www.domain.de' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource.

    Access to fetch at 'https://domain.de/wp-json/wc-analytics/reports/performance-indicators?after=2021-11-01T00%3A00%3A00&before=2021-11-11T23%3A59%3A59&stats=revenue%2Ftotal_sales%2Crevenue%2Fnet_revenue%2Corders%2Forders_count%2Cproducts%2Fitems_sold%2Cvariations%2Fitems_sold&_locale=user' from origin 'https://www.domain.de' has been blocked by CORS policy: Response to preflight request doesn't pass access control check: Redirect is not allowed for a preflight request.

    Hoffentlich kann jemand helfen! Vielen Dank!
     
  2. r23

    r23 Well-Known Member

    Registriert seit:
    9. Dezember 2006
    Beiträge:
    5.637
    Zustimmungen:
    259
    Ich kopiere mal die Anleitung vom h5 Projekt..


    # ----------------------------------------------------------------------
    # | Cross-origin requests |
    # ----------------------------------------------------------------------

    # Allow cross-origin requests.
    #
    # https://developer.mozilla.org/en-US/docs/Web/HTTP/Access_control_CORS
    # https://enable-cors.org/
    # https://www.w3.org/TR/cors/

    # (!) Do not use this without understanding the consequences.
    # This will permit access from any other website.
    # Instead of using this file, consider using a specific rule such as
    # allowing access based on (sub)domain:
    #
    # Header set Access-Control-Allow-Origin "subdomain.example.com"
    #
    # (1) When `Access-Control-Allow-Origin` points to a specific rule rather
    # than `*`, then `Vary: Origin` should be sent along with the response.

    # <IfModule mod_headers.c>
    # Header set Access-Control-Allow-Origin "*"

    # # (1)
    # # Header append Vary Origin
    # </IfModule>

    Da steht zum Beispiel ausdrücklich: Verwenden Sie dies nicht, ohne die Konsequenzen zu kennen.



    Gehört dir die domain.de oder warum verwendest du diese hier?

    Du hast einmal WWW und einmal ohne WWW.

    Entscheide dich für eine Version.

    und verzichte auf Header set Access-Control-Allow-Origin "*"
     
  3. mofenx

    mofenx New Member

    Registriert seit:
    11. November 2021
    Beiträge:
    2
    Zustimmungen:
    0
    Vielen Dank für deine Antwort @r23
    Die "domain.de" ist nur ein Platzhalter den ich hier im Forum eingefügt habe. In der Fehlermeldung wird natürlich die echte verwendet.

    Das mit dem www und nicht www ist mir auch schon aufgefallen. Leider habe ich darauf keinen Einfluss. (Oder doch?) In den Einstellungen ist die Home Seite sowie Website URL mit www eingetragen. Warum das Theme (Astra) sowie Woocommerce die Domain ohne www verwendet weiß ich leider nicht.

    Auf das Header set Access-Control-Allow-Origin "*" würde ich tatsächlich gerne verzichten. Jedoch sollte es aber doch funktionieren sobald ich den Header einfüge?
    Verstehe hier leider nicht mehr an was es liegen kann bzw. wie ich hier weiter vorgehen kann...
     
  4. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    9.433
    Zustimmungen:
    1.213
    Link zur Seite?

    Vermutlich ein Mischmasch aus http/https und/oder mit/ohne www durch unvollständig durchgeführte Umstellungen der WordPress URLs.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden