1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WP 4.7 Customizer kann nicht aufgerufen werden

Dieses Thema im Forum "Konfiguration" wurde erstellt von Mosel2591, 17. Januar 2017.

  1. Mosel2591

    Mosel2591 Member

    Registriert seit:
    10. Januar 2017
    Beiträge:
    19
    Zustimmungen:
    0
    Hallo,
    ich habe folgendes Problem seit einem manuellen Update auf Wordpress 4.7.1 kann ich meine Seite nicht mehr anpassen, egal welches Theme ich wähle
    Nach langer suche im Netz habe ich nichts gefunden außer den Tipp beim Hoster die Error Logfile Datei anzuschauen. Wenn ich die Seite vom Customizer aufrufe kommt der Fehler 500. In der Logfile Datei steht folgendes:
    17.01.2017 22:52:31 Domain.de [client 91.67.29.0] #5 /mnt/web109/e1/73/57877973/htdocs/WordPress_01/wp-includes/class-wp-customize-manager.php(734): do_action('customize_regis...', Object(WP_Customize_Ma in /mnt/web109/e1/73/57877973/htdocs/WordPress_01/wp-includes/customize/class-wp-customize-nav-menu-item-setting.php on line 182

    kann mir irgend jemand sagen was der Fehler bedeutet ?
    Das Update rückgängig machen ist eigentlich keine Lösung da ich es ja dann wieder manuell machen müsste, da selbst nach dem update immer wenn ich ein update instalieren möchte der Fehler kommt Aktuelle wir eine andere Anwendung aktualisiert.


    bitte um dringende Hilfe
    Danke
     
  2. Edi

    Edi Well-Known Member

    Registriert seit:
    26. Juli 2006
    Beiträge:
    3.728
    Zustimmungen:
    1
    Vielleicht ist beim Update etwas schiefgelaufen... Ich würde zuerst das Update noch einmal "manuell" mit einem FTP-Client machen.
     
  3. Mosel2591

    Mosel2591 Member

    Registriert seit:
    10. Januar 2017
    Beiträge:
    19
    Zustimmungen:
    0
    also ich habe mit filezilla die kompletten ordner neu hochgeladen. leider ohne Verbesserung. es geht immer noch nicht.
     
  4. Edi

    Edi Well-Known Member

    Registriert seit:
    26. Juli 2006
    Beiträge:
    3.728
    Zustimmungen:
    1
    Hast Du einmal geschaut, was passiert, wenn Du alle Plugin deaktivierst?
     
  5. Mosel2591

    Mosel2591 Member

    Registriert seit:
    10. Januar 2017
    Beiträge:
    19
    Zustimmungen:
    0
    ja habe ich auch schon gemacht leider keine Veränderung und langsam verzweifle ich hier. Wenn meine Seite nicht so viel Arbeit wäre, würde ich einfach von vorne anfangen.
     
  6. Edi

    Edi Well-Known Member

    Registriert seit:
    26. Juli 2006
    Beiträge:
    3.728
    Zustimmungen:
    1
    Ich würde ein Backup einspielen. Und dann das Update zuerst bei einer Testinstallation versuchen.

    Frage: Gibt es einen Grund, warum Du das erste Update "manuell" gemacht hast? Mit welchen Einstellungen überträgst Du die Files ("Übertragungstyp")?
     
  7. Mosel2591

    Mosel2591 Member

    Registriert seit:
    10. Januar 2017
    Beiträge:
    19
    Zustimmungen:
    0
    Ja es gibt eine Grund wie ich oben geschrieben habe schreib mein wp immer das bereits eine Aktualisierung bereits läuft dies schreib es aber schon seit 1 Monat. Übertragungstyp steht bei Filezilla auf automatisch. ich habe jetzt mal den debug eingeschaltet und folgende Antwort bekommen wenn ich auf den Customizer klicke:

    Notice: wp_register_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or login_enqueue_scripts hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.0.) in /mnt/web109/e1/73/57877973/htdocs/WordPress_01/wp-includes/functions.php on line 4091 Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /mnt/web109/e1/73/57877973/htdocs/WordPress_01/wp-config.php:1) in /mnt/web109/e1/73/57877973/htdocs/WordPress_01/wp-content/plugins/wpforo/wpf-includes/class-notices.php on line 16 Notice: register_sidebar_widget is deprecated since version 2.8.0! Use wp_register_sidebar_widget() instead. in /mnt/web109/e1/73/57877973/htdocs/WordPress_01/wp-includes/functions.php on line 3783 Notice: register_widget_control is deprecated since version 2.8.0! Use wp_register_widget_control() instead. in /mnt/web109/e1/73/57877973/htdocs/WordPress_01/wp-includes/functions.php on line 3783 Warning: Cannot modify header information - headers already sent by (output started at /mnt/web109/e1/73/57877973/htdocs/WordPress_01/wp-config.php:1) in /mnt/web109/e1/73/57877973/htdocs/WordPress_01/wp-content/themes/minamaze/admin/main/core/newsflash.php on line 71 Strict Standards: call_user_func_array() expects parameter 1 to be a valid callback, non-static method widget_categorys::init() should not be called statically in /mnt/web109/e1/73/57877973/htdocs/WordPress_01/wp-includes/class-wp-hook.php on line 298 Notice: Die verwendete Konstruktor-Methode für WP_Widget in widget_categorys ist seit Version 4.3.0 veraltet! Verwende stattdessen __construct(). in /mnt/web109/e1/73/57877973/htdocs/WordPress_01/wp-includes/functions.php on line 3846 Notice: Die verwendete Konstruktor-Methode für WP_Widget in jwl_PHP_Code_Widget ist seit Version 4.3.0 veraltet! Verwende stattdessen __construct(). in /mnt/web109/e1/73/57877973/htdocs/WordPress_01/wp-includes/functions.php on line 3846 Notice: Trying to get property of non-object in /mnt/web109/e1/73/57877973/htdocs/WordPress_01/wp-includes/class-wp-customize-nav-menus.php on line 650 Fatal error: Uncaught exception 'Exception' with message 'Illegal widget setting ID: nav_menu_item[]' in /mnt/web109/e1/73/57877973/htdocs/WordPress_01/wp-includes/customize/class-wp-customize-nav-menu-item-setting.php:182 Stack trace: #0 /mnt/web109/e1/73/57877973/htdocs/WordPress_01/wp-includes/class-wp-customize-nav-menus.php(661): WP_Customize_Nav_Menu_Item_Setting->__construct(Object(WP_Customize_Manager), 'nav_menu_item[]', Array) #1 [internal function]: WP_Customize_Nav_Menus->customize_register(Object(WP_Customize_Manager)) #2 /mnt/web109/e1/73/57877973/htdocs/WordPress_01/wp-includes/class-wp-hook.php(298): call_user_func_array(Array, Array) #3 /mnt/web109/e1/73/57877973/htdocs/WordPress_01/wp-includes/class-wp-hook.php(323): WP_Hook->apply_filters('', Array) #4 /mnt/web109/e1/73/57877973/htdocs/WordPress_01/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #5 /mnt/web109/e1/73/57877973/htdocs/WordPress_01/wp-includes/class-wp-customize-manager.php(734): do_action('customize_regis...', Object(WP_Customize_Ma in /mnt/web109/e1/73/57877973/htdocs/WordPress_01/wp-includes/customize/class-wp-customize-nav-menu-item-setting.php on line 182
     
  8. Mosel2591

    Mosel2591 Member

    Registriert seit:
    10. Januar 2017
    Beiträge:
    19
    Zustimmungen:
    0
    Hallo ich habe noch was ausprobiert. Ich habe wordpress neu Installiert. Nun hat alles funktioniert. dann bin ich die die config Datei gegangen und habe die Datenbank geändert. Ab dem Zeitpunkt funktioniert es nicht mehr. hat jemand eine Idee was in der Datenbank z.b. fehlen könnte?
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden