1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

DB-Fehler

Dieses Thema im Forum "Allgemeines" wurde erstellt von Wu_kung, 8. Dezember 2007.

  1. Wu_kung

    Wu_kung Well-Known Member

    Registriert seit:
    17. Juni 2006
    Beiträge:
    225
    Zustimmungen:
    0
    Hallo!

    Bekomme plötzlich diesen Fehler:

    Bei den FAQ/Suchen finden sich zwar Hinweise über Attacken. Zu dem konkreten fall hab ich nichts gesehen. SCHNELLER Hinweis wäre SUPER.

    Als ob jemand etwas in meine DB geschleust hat...

    DANKE.
    Gruß
     
  2. jottlieb

    jottlieb Well-Known Member
    Ehrenmitglied

    Registriert seit:
    20. August 2005
    Beiträge:
    17.381
    Zustimmungen:
    0
    Schau ob du dich mit deinen Userdaten mittels phpMyAdmin einloggen kannst.
     
  3. Wu_kung

    Wu_kung Well-Known Member

    Registriert seit:
    17. Juni 2006
    Beiträge:
    225
    Zustimmungen:
    0
    #3 Wu_kung, 8. Dezember 2007
    Zuletzt bearbeitet: 8. Dezember 2007
  4. Syntronica

    Syntronica Well-Known Member

    Registriert seit:
    11. März 2006
    Beiträge:
    1.051
    Zustimmungen:
    0
    Wie viele waren denn vorher drin?

    Unter der Lehrerumfrage und über der Fehlermeldung steht doch "Wordpress".
    Läuft da normalerweise ein Plugin/Widget?
    Nimm das Widget raus, oder das Codefragment!
    Schau dann, ob die Fehlermeldung immer noch kommt.
     
    #4 Syntronica, 8. Dezember 2007
    Zuletzt bearbeitet: 8. Dezember 2007
  5. Wu_kung

    Wu_kung Well-Known Member

    Registriert seit:
    17. Juni 2006
    Beiträge:
    225
    Zustimmungen:
    0
    Es fing damit an, dass die Log-Abfragen wasup, useronline und referraltracker diese Meldung brachten. Dann habe ich die Plugins abgeschaltet....

    Im Quellcode findet sich ganz hinten ein container. Der ist offenbar das Übel. Werde ich wohl suchen müssen, wie der dahin kommt, oder?
     
  6. jottlieb

    jottlieb Well-Known Member
    Ehrenmitglied

    Registriert seit:
    20. August 2005
    Beiträge:
    17.381
    Zustimmungen:
    0
    Achja: WP Version 2.2.3 ist leider unsicher. Hat Sicherheitslücken. Generell kann man fast immer sagen: Nur die jeweils aktuellste Version ist derzeit sicher.
     
  7. Wu_kung

    Wu_kung Well-Known Member

    Registriert seit:
    17. Juni 2006
    Beiträge:
    225
    Zustimmungen:
    0
    Das ist ja der knackpunkt. Das Plugin IST FAUL. Mal sehen, ob jetzt die anderen wieder gehen...
     
  8. Wu_kung

    Wu_kung Well-Known Member

    Registriert seit:
    17. Juni 2006
    Beiträge:
    225
    Zustimmungen:
    0
    Was bedeutet denn diese Anzeige:

    Access denied for user: 'dbo126340658@%' to database 'db126340658' on line: 294

    Hinweise wäre nett! Erscheint bei dem Versuch, das Plugin useronlien wieder zu aktivieren.

    Irgendwas ist mit der DB...:(
     
  9. jottlieb

    jottlieb Well-Known Member
    Ehrenmitglied

    Registriert seit:
    20. August 2005
    Beiträge:
    17.381
    Zustimmungen:
    0
    Muss nicht unbedingt was mit der DB sein. Es kann ja auch einfach das SQL Statement im Plugin fehlerhaft sein.
    Ist denn nämlich z.B. dbo126340658@% wirklich der Benutzername für die Datenbank? Vermutlich nicht, sieht nämlich etwas seltsm aus.
     
  10. Wu_kung

    Wu_kung Well-Known Member

    Registriert seit:
    17. Juni 2006
    Beiträge:
    225
    Zustimmungen:
    0
    Der name ist so:

    db126340658

    Aber vielleicht ist das das Problem, dass hinten die zeichen angehängt werden. Was soll denn die line 294? Auf was bezieht sich das?
     
  11. jottlieb

    jottlieb Well-Known Member
    Ehrenmitglied

    Registriert seit:
    20. August 2005
    Beiträge:
    17.381
    Zustimmungen:
    0
    Eigentlich sollte hinter line immer die Datei stehen, die den Fehler verursacht. In der Regel ist es die Datei mit dem Aufruf, also z.B. das Plugin. Wo eben in Programmzeile xxx der Fehler auftritt.
     
  12. Wu_kung

    Wu_kung Well-Known Member

    Registriert seit:
    17. Juni 2006
    Beiträge:
    225
    Zustimmungen:
    0
    Keine Plugin-Aktivierung möglich. Auf dieser line 294 muss etas Faules stehen. Aber welches Skript?

    Bsp. wassup: Da ist line 294 leer.

    Kann also NICHT am Plugin liegen. Sondern generell am WP - nehme ich an...


    Also ob mit jeder Transaktion noch der "user" mit "@%" als Schatten folgt. Während die Aktion des Users durchgeführt wird, gibt es bei dem "Schatten" den Zugriffsstop.

    Also ich bin am Ende meines Lateins...

    Was meint Ihr...
     
    #12 Wu_kung, 8. Dezember 2007
    Zuletzt bearbeitet: 8. Dezember 2007
  13. Wu_kung

    Wu_kung Well-Known Member

    Registriert seit:
    17. Juni 2006
    Beiträge:
    225
    Zustimmungen:
    0
    Zugriff WP -> Datenbank: WO?

    Habe wohl im falschen Eck gepostet...

    Im Admin erscheint: [Access denied for user: 'dbo126340658@%' to database 'db126340658']

    Kann jemand helfen, in welchem Skript der Zugriff auf die DB erfolgt? Beim Versuch, Plugins zu aktivieren (egal welche), wird angezeigt, dass der Fehler seine Ursache auf line 294 hat.

    Ich vermute eine Hackerangriff. Aber das Abschalten der Plugins führt auch nicht weiter.

    DANKE.
     
  14. jottlieb

    jottlieb Well-Known Member
    Ehrenmitglied

    Registriert seit:
    20. August 2005
    Beiträge:
    17.381
    Zustimmungen:
    0
    Steht denn nicht noch mehr da aus der Zeile? Da muss eigentlich auch stehen, welche Datei den Fehler wirft.
     
  15. Wu_kung

    Wu_kung Well-Known Member

    Registriert seit:
    17. Juni 2006
    Beiträge:
    225
    Zustimmungen:
    0
    Sobald ich ein Plugins laufen hab, das mit Wp-Statistikdaten zu tun hat, gibt es die zitierte Fehlermeldung... Selbt im Front-end

    Schalte ich die alle ab, ist scheinbar alles ok. Plugins DEAKTIVIEREN ist auch ok. Will ich aber eines AKTIVIEREN kommt das:

    In der Kommandozeile:

    www.onlzoberurff.info/wp-admin/plugins.php?activate=true

    und Anzeige:

    Access denied for user: 'dbo126340658@%' to database 'db126340658' on line: 294

    Danach ist das Plugin aktiv. Wie gesagt, als ob es da einen zweiten Parallel-User gibt, der versucht auf die DB zuzugreifen, was die aber verweigert und korrekt als Fehler meldet.

    Habe schon mal alle Files in /admin erneuert - ohne Wirkung.

    Danke für Deine Mühe!


    P.S. Habe gerade USERONLINE aktiviert - damit Du das Elend selbst sehen kannst...

    Ich tauche noch mal als GAST auf.

    Vermutlich hat ein Hacker versucht, an den Admin einen Gast anzukleben, der dann alles mitmacht die Zugangsdaten damit preisgibt...

    Hrrrr
     
    #15 Wu_kung, 9. Dezember 2007
    Zuletzt bearbeitet: 9. Dezember 2007
  16. Wu_kung

    Wu_kung Well-Known Member

    Registriert seit:
    17. Juni 2006
    Beiträge:
    225
    Zustimmungen:
    0
    Hallo!

    Angeblich ist die Datenbank voll. Kann das sein?
     
  17. jottlieb

    jottlieb Well-Known Member
    Ehrenmitglied

    Registriert seit:
    20. August 2005
    Beiträge:
    17.381
    Zustimmungen:
    0
    Wer sagt das?
     
  18. Wu_kung

    Wu_kung Well-Known Member

    Registriert seit:
    17. Juni 2006
    Beiträge:
    225
    Zustimmungen:
    0
    Erst mal der Provider. Hatte DARAN gar nicht gedacht. Und tatsächlich - von 100 MB waren noch 0,4 MB frei. Das Anhängsel "@%" an den User ist der Local host. Da kein Zugriff mehr auf die db geht, versucht wp auf den local host zuzugreifen, was die abweisende Meldung erzeugt.

    Habe dann die db bereinigt. Und reorganisiert - und der Fehler ist weg. Und es ist auch wieder mehr Platz da.

    So weit so theoretisch... und falls jemand anderes auch mal damit zu kämpfen hat.
     
  19. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.823
    Zustimmungen:
    1
    Naja, 100MB ist auch wirklich nicht besonders viel. Aber bei den Datenbanken war 1und1 schon immer etwas knauserig.

    Gruß
    Ingo
     
  20. jottlieb

    jottlieb Well-Known Member
    Ehrenmitglied

    Registriert seit:
    20. August 2005
    Beiträge:
    17.381
    Zustimmungen:
    0
    Wie kann denn ein stinknormaler Blog eine DB-Größe von 100 MB erreichen? Außer man sammelt Akismet-Spam in Größenordnungen von 10.000 bis 100.000?
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden