1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Deutsche Rechtschreibung

Dieses Thema im Forum "Sprachdatei" wurde erstellt von errator, 22. Februar 2007.

  1. errator

    errator Member

    Registriert seit:
    7. Oktober 2006
    Beiträge:
    6
    Zustimmungen:
    0
    Hallo,

    seit der 2.1 Version ist ja nun eine Rechtschreibprüfung eingebaut. Obwohl ich das deutsche WP verwende prüft der nur für die englische Sprache.

    Wie kann ich eine deutsche Rechtschreibprüfung einbauen? Habe hier im Forum schon gesucht doch es geht immer nur um die deutsche Sprachdatei.

    Danke Mario
     
  2. SuMu

    SuMu Well-Known Member

    Registriert seit:
    5. Januar 2006
    Beiträge:
    6.146
    Zustimmungen:
    41
    ich mache das mit firefox, da gibt es eine schöne erweiterung.
     
  3. Olaf

    Olaf WPDE-Team
    Mitarbeiter

    Registriert seit:
    3. September 2004
    Beiträge:
    2.739
    Zustimmungen:
    30
    Ich habe versucht in der 2.1 DE-Edition eine deutsche Rechtschreibung einzubauen, habe es in der Kürze der Zeit aber nicht hinbekommen... soweit ich weiß, hat es bisher noch niemand hinbekommen ;)

    Angepeilt habe ich das für WP 2.2 DE, aber vielleicht hat ja jemand Lust sich des Problems anzunehmen... es geht um den TinyMCE Spellchecker.
     
    #3 Olaf, 22. Februar 2007
    Zuletzt bearbeitet: 23. Februar 2007
  4. maxb

    maxb Member

    Registriert seit:
    25. Februar 2007
    Beiträge:
    16
    Zustimmungen:
    0
    Morgen,

    wenn man Teile des WP-eigenen TinyMCE löscht und durch die neuere Version ersetz, kann man die Google-Rechtschreibung einbauen. Sicher geht auch der Weg über aspell (ein Unix-Programm, das extern aufgerufen wird) oder pspell (ein php-Modul als Schnittstelle dazu). Ging aber bei mir nicht, weil ich in PHP keine externen Programme aufrufe und wegen des php-Moduls nicht mein PHP neu kompilieren will. Ich hab also diese Google-Rechtschreibung eingebaut. Folgender Text per Copy+Paste aus meiner Seite entstanden, Bilder gibts auch dort.

    Dieses Google-api scheint aber Anfang des Jahres auf https umgestellt worden zu sein, darum geht das wordpress 2.1, das ich mir runtergeladen habe auch nicht. Der spellchecker muss also nachinstalliert werden.
    Und das geht so:
    • Backup machen
    • wp-includes/js/tinymce/plugins/spellchecker löschen
    • Neuen spellchecker aus dem TinyMCE-Paket bei SourceForge holen (gebraucht wird nur der Teil “TinyMCE Spellchecker PHP”)
    • Auspacken und damit wp-includes/js/tinymce/plugins/spellchecker ersetzen
    • In diesem Verzeichnis in config.php “$spellCheckerConfig[’enabled’] = true;” setzen und drunter die default.language auf “de”.
    • in editor_plugin.js und editor_plugin.src.js nach “English” suchen und dort statt “+English=en” “+English=en,+Deutsch=de” einsetzen (das steuert die Sprachauswahl im Editor).
    • Ich hab in og. Datei noch überall, wo “lang=en,fi,sv” eingetragen war noch “de” dazugeschrieben, glaube aber nicht, dass das wichtig ist.
    Zwischendurch hab ich auch noch php-curl installiert. Wie sich später herausstellte, funktioniert damit die Überprüfung besser. Ohne curl kam öfters (aber nicht immer…) eine Meldung “could not execute AJAX call, server didn’t return valid a XML”, die seit dem Einsatz von curl weg ist. So wie es auf den ersten Blick in den Code aussieht, wird im spellcheck erst eine Verbindung mit “fsockopen” versucht und falls diese fehlschlägt alternativ eine Verbindung mit curl geöffnet. Vielleicht braucht man einfach in 50% der Fälle 2 Versuche bei Google. Also musste ich noch
    • php4-curl installieren und “extension=curl.so” in die php.ini eintragen
    • Apache neu starten
    Grüße, Max

    Nachtrag 26.2.: Für mal-eben-schnell-Ausprobierer hab ich eine zip-Datei gebastelt. Die enhält alle Dateien aus dem tinyMCE-Spellchecker mit einer lauffähigen Anbindung der deutschen Google-Korrektur. Einfach wp-includes/js/tinymce/plugins/spellchecker löschen und damit ersetzen. Aber Backup nicht vergessen...
    Download: spellcheck-DE-1031.zip (basierend auf tinyMCE Spellcheck 1.0.3.1 vom 10.1.07)

    Ich glaube übrigens, dass eine funktionierende pspell-Korrektur vorzuziehen wäre, wenn das die php-Installation zulässt. Der Umschalter dafür befindet sich in den Zeilen 5-7 von wp-includes/js/tinymce/plugins/spellchecker/config.php. Sollte sich lohnen, da mal die auskommentierten Zeilen umzustellen.
    Wenn man Glück hat, funktioniert ja "pspell Internal PHP version"
    Die dritte Variante "Command line pspell" erfordert einen Aufruf per "shell_exec", das geht im safe_mode von php nicht, wird also bei vielen Providern nicht hinhauen.
     
    #4 maxb, 25. Februar 2007
    Zuletzt bearbeitet: 26. Februar 2007
  5. dominik1

    dominik1 Member

    Registriert seit:
    1. September 2006
    Beiträge:
    12
    Zustimmungen:
    0
    Danke dir, Max. Hat prima funktioniert!
     
  6. Lejla

    Lejla Well-Known Member

    Registriert seit:
    8. Juni 2007
    Beiträge:
    101
    Zustimmungen:
    1
    @maxb

    Du bist ein Schatz, danke dir vielmals für die Mühe und Zeit dies zu bewerkstelligen, bis jetzt funktionierts prima.
    btw. von dem was du geschrieben hast habe ich kein Wort verstanden! ;)
    DAs liegt an meinen Prorammierkenntnisse! Aber professionell klingt es allemal!! ;) Ahnung haste! ;)
     
  7. cbschmidt

    cbschmidt Member

    Registriert seit:
    1. Juli 2006
    Beiträge:
    6
    Zustimmungen:
    0
    Leider funktioniert die Änderung bei mir nicht. Ich habe das Verzeichnis wie oben beschrieben ersetzt, bekomme aber weiterhin nur die englische Korrektur angeboten. In der "spellcheck-DE-1031.zip" ist unter "langs" auch nur eine "en.js" enthalten. Was fehlt mir noch bzw. wo liegt mein Fehler?
     
  8. maxb

    maxb Member

    Registriert seit:
    25. Februar 2007
    Beiträge:
    16
    Zustimmungen:
    0
    hmmm... diese "spellchecker/langs/en.js" ist anscheinend nur für die Sprache der Benutzerführung da (ob da "Suggestions" oder "Vorschläge" beim Korrekturvorschlag steht). Nicht für die Prüfung selbst...

    Die Version 1031 ist schon ein wenig älter und war für WP2.1, ich hab zwar keinen Grund gesehen, warum das neueren Wordpress-Versionen nicht gehen sollte, aber vielleicht liegts daran. Testen kann ich selbst immer nur mit ein oder zwei Versionen.

    Also schau mal bitte, obs mit der neuesten Version auch nicht geht, zumindest die Auswahl der Sprache ist ja noch recht unabhängig von Provider/PHP-Einstellungen, das sollte eigentlich auf jeden Fall klappen.

    Wenns nicht geht, melde Dich, ich komm aber vermutlich erst in ein paar Tagen wieder zum basteln ...

    Grüße, Max
     
  9. cbschmidt

    cbschmidt Member

    Registriert seit:
    1. Juli 2006
    Beiträge:
    6
    Zustimmungen:
    0
    Danke erst mal, Max, für die schnelle Reaktion. Ich habe die neue Version auf einer WordPress 2.3 Installation getestet, leider wieder ohne Erfolg. Die prüfung funktioniert weiterhin nur in englisch. :(

    PS: Das Rechschreibhilfe-Menü hingegen ist nun auch in deutsch, sprich statt "Suggestions" werden mir englsche "Vorschläge" gemacht...
     
    #9 cbschmidt, 13. Oktober 2007
    Zuletzt bearbeitet: 13. Oktober 2007
  10. raceface

    raceface Well-Known Member

    Registriert seit:
    6. Januar 2008
    Beiträge:
    89
    Zustimmungen:
    0
    Danke für die Arbeit!
    hat super funktioniert bei mir!
     
  11. pauLee

    pauLee Well-Known Member

    Registriert seit:
    15. September 2006
    Beiträge:
    71
    Zustimmungen:
    0
    Hallo Max,

    in der aktuellen Version 3.xxx von TinyMCE sieht die config.php ein wenig anders aus ...

    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Es gibt hier keinen Abschnitt namens "Default settings". Kannst du mir sagen wo ich da die Einstellungen $spellCheckerConfig[’enabled’] = true;” und default.language auf “de” setzen muß/kann?
     
  12. tobiii

    tobiii Active Member

    Registriert seit:
    16. Januar 2008
    Beiträge:
    35
    Zustimmungen:
    0
    Hi,

    hab gerade mich gerade mal drangesetzt und es auch probiert:

    Bekomme jetzt auch die Meldung:
    could not execute AJAX call, server didn’t return valid a XML

    Was ist: php-curl?

    Danke
    Tobi
     
  13. Syntronica

    Syntronica Well-Known Member

    Registriert seit:
    11. März 2006
    Beiträge:
    1.051
    Zustimmungen:
    0
    CURl ist eine php-Bibliothek!

    Die Fehlermeldung ist also länger, als die, die du hier gepostest hast.

    Wenn dein Hoster curl nicht anbietet, hast du leider Pech gehabt. Möglicherweise kannst du ihn ja überreden, dass du curl brauchst.
     
  14. tobiii

    tobiii Active Member

    Registriert seit:
    16. Januar 2008
    Beiträge:
    35
    Zustimmungen:
    0
    ..ich Hoste selber ;)

    Nur die frage wo ich die Datei herbekomme....
     
  15. Syntronica

    Syntronica Well-Known Member

    Registriert seit:
    11. März 2006
    Beiträge:
    1.051
    Zustimmungen:
    0
  16. maxb

    maxb Member

    Registriert seit:
    25. Februar 2007
    Beiträge:
    16
    Zustimmungen:
    0
    Hi Paul,

    sorry, den Spellchecker 2.0.rc1 (passend zu TinyMCE 3.0.rc1) bringe ich auch nicht zum laufen. Die TinyMCE-Leute haben wohl die ganzen Konfigurationsdateien ausgelagert. Den neuen Spellchecker bekommt man nicht einzeln ins alte Tiny von Wordpress (da ist eine TinyMCE 2.x verbaut). Den ganzen Editor will ich nicht auswechseln, weil mir nicht klar ist, wie viel Anpassungsarbeit die Wordpress-Entwickler da reingesteckt haben, erste Versuche, das einfach zu überschreiben endeten mit kaputtem Editor.

    Falls das nächste Wordpress TinyMCE 3 verwendet, versuche ich das weiterzuführen und anzupassen. Ansonsten bleibe ich bei der letzten funktionierenden Version stehen. Den kompletten Editor will ich nicht anpassen (und die Welt mit meinen Programmierfehlern dabei belasten ;) ).


    @tobiii

    Ich hab einen Debian-Server, da hab ich einfach das Paket "php5-curl" installiert (php4-curl gäbe es auch). Für andere Betriebsysteme / Distributionen gibts sicher auch Pakete...

    Grüße, Max
     
  17. maxb

    maxb Member

    Registriert seit:
    25. Februar 2007
    Beiträge:
    16
    Zustimmungen:
    0
    Wegen curl nochmal...

    Die letzte Version vom Spellcheck (1.0.5a, ich führe die neuen Versionen in einem Blogeintrag fort, wenn ich dazu komm), braucht kein curl mehr.

    Ich hatte einen Tipp bekommen, dass der Spellchecker statt diesem Hinweis doch einfach nochmal versuchen soll, Google zu erreichen. Ist zwar ein bisschen schräg, Fehler so zu umgehen, aber es funktioniert...
     
  18. pauLee

    pauLee Well-Known Member

    Registriert seit:
    15. September 2006
    Beiträge:
    71
    Zustimmungen:
    0
    Kein Problem Max, die Rechtschreibung wird dadurch nicht besser. Hängt schließlich an der Google API.
     
  19. fb130868

    fb130868 New Member

    Registriert seit:
    17. Januar 2008
    Beiträge:
    3
    Zustimmungen:
    0
    Super Danke es geht auch paralell ;) eng und DE

    Danke sagt fb130868
     
  20. RvS

    RvS Active Member

    Registriert seit:
    27. März 2008
    Beiträge:
    29
    Zustimmungen:
    0
    hat sich erledigt
     
    #20 RvS, 27. März 2008
    Zuletzt bearbeitet: 27. März 2008
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden