1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Deutsche Version von WP-Polls

Dieses Thema im Forum "Plugins und Widgets" wurde erstellt von michael.oeser, 19. Mai 2007.

  1. michael.oeser

    michael.oeser Well-Known Member

    Registriert seit:
    24. März 2007
    Beiträge:
    347
    Zustimmungen:
    0
    Hallo,

    ich habe WP-Polls installiert und mir auch die deutschen Sprachdateien heruntergeladen (also die *.mo und die *.po Datei).

    Dann dachte ich, es ei damit getan, dass ich die beiden Dateien einfach in das Pluginverzeichnis von WP-Polls kopiere und fertig ist die deutsche Version. Aber nix da. Ist immer noch alles auf Englisch.

    Wie funzt das noch mal mit den Sprachdateien???
     
  2. milko

    milko Well-Known Member

    Registriert seit:
    29. Dezember 2006
    Beiträge:
    107
    Zustimmungen:
    0
    Vielleicht bringt Dir das Tutorial eine Lösung?
     
  3. Ben-Inside

    Ben-Inside Well-Known Member

    Registriert seit:
    30. April 2006
    Beiträge:
    377
    Zustimmungen:
    0
    Wäre selber an einer deutschen Version des Plugins interessiert. Bin nämlich selber daran dies zu bewerkstelligen.

    Bei mir tritt folgendes Problem auf:

    Beim Aktualisieren der Seite existiert zwischen Umfragetitel und Auswahlmöglichkeiten existiert die Leerzeile.

    Beim Klick auf Ergebnis anzeigen und anschließend auf Zurück zur Abstimmung ist diese aber wieder weg.

    Wie das?
     
  4. michael.oeser

    michael.oeser Well-Known Member

    Registriert seit:
    24. März 2007
    Beiträge:
    347
    Zustimmungen:
    0
    Sprachdateien

    Bedingt. Nun weiß ich, dass die Sprachdatei im selben Verzeichnis liegen muss, wie das Plugin selbst. Davon war ich auch ausgegangen. Leider funktioniert das aber nicht (auch bei anderen Plugins des gleichen Autors, obwohl die Plugins sehr gut sind).

    Nur noch mal damit ich es richtig verstehe. Die eigentliche Sprahcdatei ist die *.mo Datei. Die muss im gleichen Verzeichnis liegen wie das Plugin, also im grunde etwa so:

    /wp-conten/plugins/plugin-xyz/xyz.php
    /wp-conten/plugins/plugin-xyz/xyz_de.mo

    Die *.pot oder *.po Datein (was ist eigentlich der Unterschied?) muss man nicht notwendigerweise haben (auch wenn ich sie habe...nur so interessehalber). Die braucht man nur zum Bearbeiten mot "po-edit".

    Wenn das alles richtig ist, dann frage ich mich, warum der Mist nicht funzt.

    Ne Idee???

    (ich glaube langsam, der Thread passt nicht mehr ganz hier her :?)
     
  5. milko

    milko Well-Known Member

    Registriert seit:
    29. Dezember 2006
    Beiträge:
    107
    Zustimmungen:
    0
    @Ben: Ich arbeite gerade an einer Übersetzung von WP-Polls 2.20. Die Final kommt Ende des Monats. Siehe dazu auch meinen Beitrag.

    @Michael: Im Tutorial steht eigentlich alles, was Du wissen willst. Die .po/ .pot-Datei ist eine Gettext-Katalogdatei, die bearbeitet werden kann. Beim Speichern der Katalogdatei wird eine .mo-Datei produziert, die dann vom jeweiligen Plugin verwendet wird.

    Bei der Namesgebung musst Du auf die richtige Endung achten. Deutsche Sprachdateien haben die Endung: pluginname-de_DE.mo . Das ist eigentlich der meistgemachte Fehler. Als nächste Fehlerquelle könnte ich mir vorstellen, dass der Dateiname vor der -de_DE Erweiterung falsch ist.
    Bei WP Polls heißt die Sprachdatei wp-polls-de_DE.mo und es klappt eigentlich.
     
  6. michael.oeser

    michael.oeser Well-Known Member

    Registriert seit:
    24. März 2007
    Beiträge:
    347
    Zustimmungen:
    0
    Hurraaaaaa...

    Das war WIRKLICH der Fehler. Ich habe die POT Datei jetzt noch mal so bearbeitet, wie Du es beschrieben hast und es klappt.

    1000 DANK!
     
  7. milko

    milko Well-Known Member

    Registriert seit:
    29. Dezember 2006
    Beiträge:
    107
    Zustimmungen:
    0
    Gern geschehen
     
  8. catao

    catao New Member

    Registriert seit:
    9. März 2008
    Beiträge:
    2
    Zustimmungen:
    0
    Hallo Zusammen,

    seit Stunden suche ich eine Beschreibung, die mir hilft, die deutsche Übersetzung zu aktivieren. Auch konnte ich das von Milko beschriebene Tutorial nicht finden. Mit Poedit bin ich auch nicht so klar gekommen bzw. weiß nicht was ich dort genau machen muss :oops:

    WP-Polls habe ich auf meiner Seite drauf, nur eben nicht in deutsch :(

    Kann mir jemand von euch helfen?

    Danke & Gruß

    Sascha
     
  9. Monika

    Monika Well-Known Member
    Ehrenmitglied

    Registriert seit:
    4. Juni 2005
    Beiträge:
    14.126
    Zustimmungen:
    2
    Hi Sascha und das umbenennen der Dateien wie weiter oben beschrieben half auch nicht?

    lg
     
  10. catao

    catao New Member

    Registriert seit:
    9. März 2008
    Beiträge:
    2
    Zustimmungen:
    0
    Hallo Monika,

    ich habe folgende Dateien unter /wp-pools
    wp-polls-de_DE.mo
    wp-polls-de_DE.po
    wp-polls.mo

    Habe auch schon versucht die wp-polls-de_DE.mo in wp-polls.mo umzubennen, aber auch das half nicht. Nach den vielen Stunden, des lesens und ausporbierens, bin ich gefrustet und kurz davor es wieder in die Tonne zu hauen. *sorry*

    Hast du noch irgendeine Idee, was ich tun kann??

    Danke & Gruß
    Sascha
     
  11. gregma

    gregma Active Member

    Registriert seit:
    22. Juli 2008
    Beiträge:
    29
    Zustimmungen:
    0
    Verwendet jemand Wordpress 2.8, WP-Polls 2.50 und kann die deutsche Sprachdatei nutzen?

    Sobald ich diese hochlade, bleibt alles weiss - Zeitlimit für PHP-Ausführung wird überschritten... :-?
     
  12. infected

    infected Well-Known Member

    Registriert seit:
    9. Juli 2006
    Beiträge:
    9.816
    Zustimmungen:
    1
    Ja, bei mir läufts problemlos.

    EDIT: Ich sehe gerade, dass ich die Sprachdatei der Vorgängerversion benutze... :oops:
     
    #12 infected, 15. Juni 2009
    Zuletzt bearbeitet: 15. Juni 2009
  13. infected

    infected Well-Known Member

    Registriert seit:
    9. Juli 2006
    Beiträge:
    9.816
    Zustimmungen:
    1
    Ich habe die Sprachdatei gerade auf die Version 2.50 aktualisiert. Läuft bei mir ohne Probleme. Probiers mal aus.
     
  14. Flame

    Flame Well-Known Member

    Registriert seit:
    17. Februar 2009
    Beiträge:
    84
    Zustimmungen:
    0
    Hallo,

    ich habe es mal ausprobiert, nur leider gehts nicht :/

    hab die datein umbenannt und hochgeladen. nur alles ist nach wie vor auf englisch :/

    die .po datei war garnicht drinnen, nur eine mo datei.

    gruß
     
  15. Bambaataa

    Bambaataa Well-Known Member
    Ehrenmitglied

    Registriert seit:
    17. Mai 2009
    Beiträge:
    2.483
    Zustimmungen:
    12
    was den umbenannt?
     
  16. melina

    melina Active Member

    Registriert seit:
    6. Mai 2005
    Beiträge:
    37
    Zustimmungen:
    0
    Ich habe ebenfalls die Sprachdateien in das Plugin-Verzeichnis kopiert und sehe trotzdem nur die englische Version (meine Website ist sonst erfolgreich auf de_DE eingestellt). Versuchsweise habe ich die .po mal mit Poedit geöffnet und abgespeichert. Sie hat mir mehrere Fehlermeldungen ausgegeben, die sich auf Pluralformen bezogen. Kann es sein, dass die .mo auch vorher schon defekt war und deshalb nicht gelesen werden kann?

    Vielen Dank für jeden Tipp

    Susanna
     
  17. infected

    infected Well-Known Member

    Registriert seit:
    9. Juli 2006
    Beiträge:
    9.816
    Zustimmungen:
    1
    Hm. Sorry, kann ich absolut nicht nachvollziehen. Habe die von mir angebotenen Dateien gerade nochmal heruntergeladen und auf einem Testblog überprüft. Die Übersetzungen funktionieren einwandfrei. Recht gebe ich Dir in Bezug auf die Fehlermeldung in PoEdit. Ich weiß nicht wo der Fehler herkommt und wie er zu beseitigen ist, aber der Fehler ist schon in der Sprachdatei des Pluginautors vorhanden.

    Du hast die beiden Dateien (wp-polls-de_DE.po, wp-polls-de_DE.mo) wirklich ins Verzeichnis /wp-content/plugins/wp-polls/ hochgeladen? Leere bitte mal Deinen Browsercache, schließe den Browser komplett und rufe Deine Seite dann nochmal auf.
     
  18. bluehouseman

    bluehouseman Member

    Registriert seit:
    20. November 2009
    Beiträge:
    6
    Zustimmungen:
    0
    hallo,

    sorry wollte keinen neuen thread dafür aufmachen! Folgendes Problem tritt bei mir immer auf...Umfragen kann ich erstellen, das widget einfügen, wird auch angezeigt aber sobald ich eine Antwort oder auf ergebniss zeigen klicke, fängt es zu laden an und es kommt nix! Link zur seite www.hammerschmiedler.de

    mfg&thx
    hoff jemand kann mir helfen brauche diese plugin wirklich dringend!
     
  19. infected

    infected Well-Known Member

    Registriert seit:
    9. Juli 2006
    Beiträge:
    9.816
    Zustimmungen:
    1
    #19 infected, 20. November 2009
    Zuletzt bearbeitet: 20. November 2009
  20. bluehouseman

    bluehouseman Member

    Registriert seit:
    20. November 2009
    Beiträge:
    6
    Zustimmungen:
    0
    also der aufruf ist in der footer.php vorhanden und die rechte stimmen auch, oh mann was kanns denn sonst no sein?
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden