1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Domaintausch und NGG

Dieses Thema im Forum "Konfiguration" wurde erstellt von dummy, 6. Februar 2011.

  1. dummy

    dummy Well-Known Member

    Registriert seit:
    25. Dezember 2007
    Beiträge:
    286
    Zustimmungen:
    0
    Wo befinden sich die lokalen Einstellung der Next Gen Gallery. Nachdem ich den Domainnamen gewechselt habe sind meine Einstellungen leer. Habe überall nach einem NGG Cache Ordner gesucht, finde aber leider nichts.
     
  2. Ammaletu

    Ammaletu Well-Known Member
    Ehrenmitglied

    Registriert seit:
    14. Juli 2007
    Beiträge:
    4.694
    Zustimmungen:
    0
    Ich hab mit der NGG noch nicht gearbeitet, aber normalerweise sollten Einstellungen in der wp_options-Tabelle gespeichert sein. Ich wüsste da aber nicht, wieso sie nach einem Domainwechsel weg sein sollten. Frage: Hast Du nur die Domain getauscht oder bist Du auch von einem Server zum anderen umgezogen?
     
  3. dummy

    dummy Well-Known Member

    Registriert seit:
    25. Dezember 2007
    Beiträge:
    286
    Zustimmungen:
    0
    Ich habe nur die Domain gewechselt. Natürlich habe ich in allen Tabellen die alte Domain durch die neue ersetzt. Es kann eigentlich nicht sein, dass es an der Datenbank liegt. NGG muss wohl die Einstellungen irgendwo auf dem Webspace ablegen, anders kann ich es mir nicht erklären.
     
  4. Ammaletu

    Ammaletu Well-Known Member
    Ehrenmitglied

    Registriert seit:
    14. Juli 2007
    Beiträge:
    4.694
    Zustimmungen:
    0
    Ich habe mir NGG gerade mal testweise installiert. Was genau ist denn weg? Galerien und/oder Bilder? Oder wirklich nur Einstellungen? Die Bilder landen offenbar unter wp-content/gallery, die Einstellungen in der wp_options-Tabelle (Keys startend mit "ngg_").

    Die NGG-Optionen landen offenbar in einem serialisierten String. genau wüsste ich nicht wie, aber möglich wäre es, dass Du in diesem String Deine Domain ersetzt hast und hast ihn damit zerstört. Vergleiche also mal die Werte von "ngg_options" in der alten und der neuen wp_options-Tabelle. Ansonsten wüsset ich jetzt erstmal nicht, wie da etwas wegkommen sollte.
     
  5. dummy

    dummy Well-Known Member

    Registriert seit:
    25. Dezember 2007
    Beiträge:
    286
    Zustimmungen:
    0
    Ja genau, bei den Einstellungen sind einfach alle Felder leer. Die Bilder werden noch gefunden, nur der Style passt nicht mehr, da in den Optionen nichts konfiguriert ist. Da könnte was an dem Serialisierten String dran sein, daran habe ich garnicht gedacht.

    Habe das mit den Tabellen so gemacht.
    1. Als sql exportiert
    2. im Editor geöffnet und webseite-alt.de durch webseite-neu.de ersetzen lassen.
    3. sql in eine neue Datenbank importiert und auf die neue Datenbank umgeschaltet.

    Ich werde einfach alles nochmal manuell einstellen, bevor ich es mit der Datenbank noch schlimmer mache.

    Vielen Dank :)
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden