1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

"Du hast nicht die erforderlichen Rechte, um auf diese Seite zuzugreifen."

Dieses Thema im Forum "Konfiguration" wurde erstellt von starsofthelid, 28. Juli 2013.

  1. starsofthelid

    starsofthelid Member

    Registriert seit:
    8. Juli 2013
    Beiträge:
    17
    Zustimmungen:
    0
    Ich habe vor Kurzem in meinem Blog das PLugin "Better WP Security" installiert. Aus aktuellem Anlass habe ich dort eingestellt, dass jeder User, der 2 mal ein falsches Passwort eingibt, für eine Woche gesperrt wird. Heißt, man kann rein garnichts mehr sehen, wenn man die URL zu meinem Blog eingibt.
    In einem Moment der Unachtsamkeit bin ich dann schließlich Oper meiner selbst geworden, und gab das Passwort ein zweites mal falsch ein. Sehr ärgerlich. Ich wusste, dass ich zum Wochenende an einem Rechner an einem komplett anderen Standort sein würde, mich also von dort aus einloggen könnte, da es sich dann um eine andere IP handelt, die nicht gesperrt ist.
    Gesagt, getan. Blog war sichtbar, alles ganz normal. ALs ich dann versuchte mich in das WP-Backend einzuloggen, erhielt ich nur noch die Meldung: "Du hast nicht die erforderlichen Rechte, um auf diese Seite zuzugreifen."

    Das Problem hatte ich noch nie, habe also diverse SChritte aus diesem Forum hier probiert, unter anderem die Umbenennung des Ordners "plugins" über Filezilla, was zur Folge haben sollte, dass man sich wieder anmelden kann. Aber sattdessen hat diese Aktion nur das LAyout meines Blogs zerschossen, und es werden keine Bilder mehr angezeigt. ICh kann das ja nun leider nicht ändern, da ich mich nicht einloggen kann...

    Ich habe mich bei MySQL eingeloggt und die "user lockouts" alle gelöscht, sodass keine IP mehr gesperrt ist. Trotzdem ist es mir nach wie vor nicht möglich, mich in das WP-Backend über ...url/wp-admin einzuloggen. Ich erhalte stets nur diese eine Fehlermeldung.

    Es geht mir unbeschreiblich gegen den Strich, dass ich nun hilflos mit Ansehen muss, wie meine Webseite mit einem zerschossenen Layout online ist, und ich es einfach nicht ändern kann.

    Ein Neuupload des kompletten Blogs hat ebenfalls nichts gebracht. Auch das Ändern meines Passwortes habe ich mit einem Notfallscript hinbekommen, und ich kann 100%ig sagen, dass Passwort und Username korrekt sind. Ich bekomme jedoch immer wieder die Meldung die hier Thema meines Threads ist.

    Liegt das Problem in meiner Datenbank? Muss ich meine Seite offline nehmen, das Security-Plugin löschen, die Datenbank löschen, eine komplett neue Datenbank anlegen, und dann den bisherigen Content wieder hochladen?
     
  2. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    Kannst du nicht im Backend des Plugins die gesperrten IP's löschen?
     
  3. bgeissler

    bgeissler Well-Known Member

    Registriert seit:
    6. August 2006
    Beiträge:
    4.404
    Zustimmungen:
    0
    Ist eben "Better WP Security". So soll es doch sein?
     
  4. r23

    r23 Well-Known Member

    Registriert seit:
    9. Dezember 2006
    Beiträge:
    5.968
    Zustimmungen:
    333
    Warum sollte die Sperre ausgerechnet IP abhängig sein? Wenn das System Zugriff auf die Benutzerdatenbank hat und vermutlich noch Cookie gesendet hat.

    Wildes Konzept für eine Entspreeung... Ich würde mir einfach mal ansehen, wie das Plugin das macht und diese Sperre löschen.
     
  5. starsofthelid

    starsofthelid Member

    Registriert seit:
    8. Juli 2013
    Beiträge:
    17
    Zustimmungen:
    0
    Vielen Dank für eure Antworten. Das besagte Plugin speichert die "verdächtigen" IP-Adresse in einer Liste die in der Datenbank hinterlegt ist. Lösche ich diese Liste, habe ich wieder Loginversucht und der Blog wird überhaupt erstmal wieder angezeigt.
    Ins Bankend des Plugins komme ich ja nicht ran, weil das bedeuten würde, dass ich mich bei WP anmelden kann. Was ja nicht gelingt. Also kann ich nur über Filezilla auf alles zugreifen.

    Naja deswegen gehe ich schon stark davon aus, dass die Sperre IP-basiert ist. Aber wie auch immer, selbst von fremden Anschlüssen aus, ist es mir nicht möglich, mich einzuloggen.
    Ich versuche jetzt das PLugin über Filezilla zu löschen und zu sehen ob das vielleicht etwas bringt. Ansonsten muss ich wohl oder übel die Seite komplett neu aufsetzen, da ich denke, dass es evtl. in der Datenbank ein Problem gibt, dass den Fehler verursacht. Sonderlich viele andere Möglichkeiten scheint es ja nicht zu geben:(
     
  6. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    Versuche dich doch mal über einen freien Proxy einzuloggen, dann weißt du, ob es an deiner IP liegt.
     
  7. starsofthelid

    starsofthelid Member

    Registriert seit:
    8. Juli 2013
    Beiträge:
    17
    Zustimmungen:
    0
    Hallo Hille, ich kenne mich leider nicht so gut aus, dass ich ohne deine genauere Beschreibung weiß, wie genau ich das mache. KAnnst du noch etwas mehr dazu sagen?

    Ich habe eben das Sicherheits-Plugin gelöscht, und sehe jetzt nach dem Einloggen zumindest wieder die graue WP-Menuleiste oben, und auch das "Willkommen admin"-Feld usw. Es sieht jetzt alles aus, als wäre ich wieder normal ins WP-Backend eingeloggt. SObald ich aber auf genau dieses Feld klicke, finde ich als mögliche Optionen nur:

    - Profil bearbeiten

    - Abmelden

    Klicke ich dann auf "Profil bearbeiten" erhalte ich wieder nur die Meldung "du hast keine Rechte um auf diese Seite zuzuzgreifen..." auf einer neuen Seite, ohne jegliche Optionen.

    ICh habe nur einen einzigen User angelegt und kann dies auch nach einem Blick in die Datenbank bestätigen, dass ich der Admin bin, und es sonst keine weitern Profile gibt. Ich meine, ich bin nun offensichtlich eingeloggt, aber kann trotzdem auf keinerlei Optionen zur Bearbeitung meiner Seite zugreifen.

    Sollte statt "Profil bearbeiten" nicht auch "Blog/Seite bearbeiten" dort angeboten werden? Ich meine...irgendwie fehlt doch dort was.

    Vielleicht kannst du/könnt ihr mir mit diesem kleinen "Fortschritt", dass ich nun zumindest wieder ins WP-Backend eingeloggt zu sein scheine, weiterhelfen.

    Viele Grüße
     
    #7 starsofthelid, 28. Juli 2013
    Zuletzt bearbeitet: 28. Juli 2013
  8. starsofthelid

    starsofthelid Member

    Registriert seit:
    8. Juli 2013
    Beiträge:
    17
    Zustimmungen:
    0
    Ich habe nun auch mal dieses chk.php-Script angewendet, mit dem Ergebnis:
    Die Option 'wp_mattaustfotografieundfilmuser_roles' ist scheinbar in Ordnung.

    Damit wäre wieder eine Möglichkeit augeschlossen, und euch vielleicht geholfen noch andere Ideen zu haben, was ich überprüfen kann.
     
  9. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    Wo haste denn das Script her?

    Hier ein Proxy, versuche dich mal darüber einzuloggen.

    http://www.freshproxy.eu/
     
  10. starsofthelid

    starsofthelid Member

    Registriert seit:
    8. Juli 2013
    Beiträge:
    17
    Zustimmungen:
    0
    Das Script habe ich auf einer WP-Hilfeseite gefunden, es waren diverse Lösungen für mein Problem aufgeführt, unter anderem eben einen Test mit diesem Script durchzuführen.

    Ich habe versucht mich über den Proxy einzuloggen, mit folgender Fehlermeldung als Ergebnis:

    "The requested resource could not be loaded because the server returned an error:
    500 Internal Server Error (?). "

    Also habe ich ein Serverproblem?
     
  11. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    Irgend etwas stimmt mit deiner Wordpress bzw. mit einem Plugin / Theme Installation nicht.
     
  12. starsofthelid

    starsofthelid Member

    Registriert seit:
    8. Juli 2013
    Beiträge:
    17
    Zustimmungen:
    0
    Ich habe dir geantwortet, bin mir aber grad nicht sicher ob du das bekommen hast, da mein Postausgang immernoch leer ist...
     
  13. h-u-g-o

    h-u-g-o Well-Known Member

    Registriert seit:
    23. November 2008
    Beiträge:
    704
    Zustimmungen:
    0
    Durch das Umbenennen des Plug-in-Ordners sollten alle Plug-ins deaktiviert worden sein. Hast du versucht, einfach mal den Plug-in-Ordner wieder in seinen ursprünglichen Namen umzubenennen? Versuche doch mal, nur den Ordner des Plug-ins Better WP Security umzubenennen.
     
  14. starsofthelid

    starsofthelid Member

    Registriert seit:
    8. Juli 2013
    Beiträge:
    17
    Zustimmungen:
    0
    Ja natürlich hab ich dem Ordner dann wieder seinen ursprünglichen Namen gegeben. Das hatte ja dann zur FOlge, das mein WP-Seite zwar wieder erreichbar war, jedoch fehlerhaft dargestellt wurde. Ich hab wirklich ALLES versucht, und mich heute entschieden WP komplett neu zu installieren. Nach 4 Stunden Arbeit sieht meine Seite nun auch wieder so aus wie sie soll.
    Das Better-WP-Securtiy-Plugin werde ich allerdings nicht nochmal installieren^^
     
  15. h-u-g-o

    h-u-g-o Well-Known Member

    Registriert seit:
    23. November 2008
    Beiträge:
    704
    Zustimmungen:
    0
    [offtopic]Ich empfehle dir, noch die Permalinkstruktur dahingehend zu ändern, dass die Links sprechend sind. Beispiel: matt-fotografie.de/impressum statt matt-fotografie.de/?page_id=48[/offtopic]
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden