1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Editor zeigt bei [code] falsche ergebnisse

Dieses Thema im Forum "Plugins und Widgets" wurde erstellt von spyuser, 22. September 2021.

  1. spyuser

    spyuser Well-Known Member

    Registriert seit:
    6. Juli 2016
    Beiträge:
    61
    Zustimmungen:
    2
    Hallo,

    ich habe bei meiner Seite das Plugin SythaxHightlighter, das wunderbar funktioniert.

    Ich verwende auch ein Theme mit dem Visual Composer, wo ja so ein Codefregment über den Editor eingebunden wird.

    Das Problem jetzt aber: Wenn ich den Code einbinde, diesen nochmals bearbeiten will, verändert der Editor meinen Code. Hier ein Beispiel.

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!

    Nach ändern und nochmaligen speichern ändert mir der Editor das """ ind ein Anführungszeichen ".
    Das sollte aber nicht passieren.

    Beispiel:
    So soll es sein: Include=" "SpaProxyServer": {" />
    So ist es nach nochmaligem Bearbeiten und speichern des Codes: Include=" ";SpaProxyServer&": {" />

    Habt ihr eine Lösung, damit mein Editor das nicht ändert?
    Ich habe schon vieles versucht, aber es funktionierte nichts. Der Editor ändert mir das immerwieder und ich weiß nicht mehr weiter.

    Vielen Dank für eure hilfe!
     
  2. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    9.234
    Zustimmungen:
    1.140
    Welches SyntaxHighlighter Plugin, Version/Link, welches Theme & Version, welche Visual Composer Version, welche WordPress Version? Siehe auch Forenregeln, Punkt II
     
  3. spyuser

    spyuser Well-Known Member

    Registriert seit:
    6. Juli 2016
    Beiträge:
    61
    Zustimmungen:
    2
  4. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    9.234
    Zustimmungen:
    1.140
    Das hilft insofern weiter, als dass man die Aktualität und die Kompatibilität der Teile zueinander mal betrachten kann:
    1. Plugin SyntaxHighlighter Evolved 3.6 ist nur getestet bis WordPress 5.7.3, verwendet wird WordPress 5.8
    2. Theme LevelUp scheint ein Kauf Theme zu sein, was sagt der Theme Support zum Problem?
    3. Also doch nicht Visual Composer sondern WPBakery Page Builder 6.4.1, ein Jahr alt, aktuell hier wäre 6.7.0, was sagt der Plugin Support?
    4. Aktuell wäre WordPress 5.8.1, wobei der kleine Unterschied hier eher keine Rolle spielen dürfte
    Vermutlich eine Wechselwirkung zwischen Theme und dem veralteten WPBakery, wobei noch die Angabe fehlt, wie es sich mit einem anderen Theme und ohne alle sonstigen Plugins verhält.

    Ergänzung: Möglich hier wäre auch eine Problem bei der SyntaxHighlighter Einbindung, z.B. in ein unpassendes Element in WPBakery.
     
    #4 b3317133, 22. September 2021
    Zuletzt bearbeitet: 22. September 2021
  5. spyuser

    spyuser Well-Known Member

    Registriert seit:
    6. Juli 2016
    Beiträge:
    61
    Zustimmungen:
    2
    Der Theme Support kann hier kein Problem feststellen.
    Der WpBackery , bei dem ist das htmlspecialchars aktiv, der all diese Sonderzeichen richtig stellt.

    Beim gutenberg zB funktioniert es normal, ist jetzt aber ungut, immer von WpBackery auf Gutenberg und wieder retour umzustellen ;)

    Die einbindung von Syntax in WpBackery geht nur über den integrierten Editor, der Viual und Text zulässt. Beim ersten abspeichern eines Codes in dessen Editor funktioniert es und es sieht auch im Frontend gut aus.
    Aber möchte man was ändern, öffnet den Editor werden alle Sonderzeichen in richtige Zeichen umgewandelt, was nicht sinn der sache ist ;)

    Nicht einfach, wenn man sowas einfaches machen möchte :D
     
  6. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    9.234
    Zustimmungen:
    1.140
    WPBakery hat RAW HTML oder RAW JavaScript Elemente für sowas.

    Deine ein Jahr alte WPBakery Version 6.4.1 ist zu Zeiten von WordPress 5.4 bzw. WordPress 5.5 entwickelt worden, Du verwendest aber WordPress 5.8, da gibt es teilweise Riesenunterschiede.

    Stelle erstmal die Kompatibilität aller Teile zueinander sicher und beschäftige Dich dann ggf. noch etwas mit der WPBakery Dokumentation, evtl. wird ein unpassendes Element verwendet.
     
  7. spyuser

    spyuser Well-Known Member

    Registriert seit:
    6. Juli 2016
    Beiträge:
    61
    Zustimmungen:
    2
    Ich werde mich mal schlau machen und sage mal Danke für diese Infos ... hat mir mal weitergeholfen. Jetzt weiß ich, wo ich mal weitersuchen muss ;)

    Danke dir
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden