1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WP 5.4 Ein CSS Datei verlangsamt alles und soll weg...

Dieses Thema im Forum "Design" wurde erstellt von madraxx, 30. Mai 2020.

  1. madraxx

    madraxx Well-Known Member

    Registriert seit:
    2. Februar 2008
    Beiträge:
    114
    Zustimmungen:
    1
    Hallo,
    ich bin grad hier dabei meine Ladezeiten zu minimieren und stoße auf ein CSS, dass ich programmieren ließ und das bis zu 25Sekunden Ladezeit braucht, obwohl es winzig ist.

    Hier zu finden: https://xn--schne-aussicht-xpb.de/leutaschklamm/ wenn man bei Google Pagespeed schaut.
    Das macht es möglich, dass ich beim Eventkalender rechts eine Sidebar habe: https://xn--schne-aussicht-xpb.de/event/lauf-der-verrueckten-spendenlauf-bis-100km/

    Ich weiss nicht, warum das in eine extra CSS Datei gepackt ist, aber diese enorme Ladezeitverzögerung muss weg. Am liebsten die paar Zeilen in die normale CSS Datei, oder irgendeine smarte Lösung ohne das die Ladezeit explodiert.

    Jemand eine Lösung oder Idee?

    DANKE, Mad.
     
  2. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    7.759
    Zustimmungen:
    820
    Welches CSS? Welche extra Datei? Was sagt der Programmierer des CSS dazu? Screenshot der entspr. Meldung?

    Die Ladezeit der leutaschklamm Seite wird nach kurzem Einblick vor allem durch eine Vielzahl von externen Einbindungen (fonts.googleapis.com, fonts.gstatic.com, m.media-amazon.com, www.komoot.de, maps.google.com, api.mapbox.com, account.komoot.com, tiles-api.maps.komoot.net, events.mapbox.com, maps.googleapis.com, zig subdomains von tiles-api.maps.komoot.net und viele, viele weitere externe Dateien von verschiedenen Trackern) beeinflusst.

    Für Hilfe bei der Suche nach Ladeproblemen deaktiviere alle Optimierungs-, Minify- und Cache-Plugins, derzeit mind. aktiv: Autoptimize, weiterhin alle Tracking-, Statistik- und Werbung-Plugins (Google Analytics, Adsense o.ä., WP-Statistics, VG Wort, Amazon, ...), dann kann man ggf. zuordnen, was wo wie woher kommt bzw. für die genannte "enorme Ladezeitverzögerung" verantwortlich sein könnte.
     
    #2 b3317133, 30. Mai 2020
    Zuletzt bearbeitet: 30. Mai 2020
    madraxx gefällt das.
  3. madraxx

    madraxx Well-Known Member

    Registriert seit:
    2. Februar 2008
    Beiträge:
    114
    Zustimmungen:
    1
    Danke dir, aber ich will nichts zuordnen, sondern die CSS entfernen. Am liebsten irgendwie in das normale CSS...
    Den Rest muss ich noch schauen, wo eine gute Balance ist.
     
  4. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    7.759
    Zustimmungen:
    820
    Nach wie vor ist völlig unklar, welches CSS Du meinen könntest... keine Antworten = keine Hilfe möglich. :rolleyes:
     
  5. r23

    r23 Well-Known Member

    Registriert seit:
    9. Dezember 2006
    Beiträge:
    5.036
    Zustimmungen:
    137
    auf deiner Seite gibt es kein JavaScript mit einer derartig schlechten ladezeit. Aber dein WebSapce benötigt für die erste Anwort sagenhafte 5 Sekunden.

    cool... Wer ist dein Provider?

    Vg Wort beaucht auch "nur" etwas über 2 Sekunden .. da braucht man keine Feinde mehr ...
     
  6. madraxx

    madraxx Well-Known Member

    Registriert seit:
    2. Februar 2008
    Beiträge:
    114
    Zustimmungen:
    1
    Sorry, das treibt mich grad in den Wahnsinn...

    Ich habe ein Bild dran gehängt mit dem CSS und der Ladezeit. ich wollte es nicht schreiben, da er seinen Firmennamen als Dateinamen genommen hat.

    Provider All-Inkl.com

    -------------------------

    Ich habe nach einigen Versuchen die CSS Datei gelöscht und die alte php Datei eingefügt, die es vor der Programmierung gab. Es geht noch alles, aber Pagespeed sieht die CSS immer noch. Wie das? Habe auch Autoptimize deaktiviert, Cache gelöscht, anderer Browser...
     

    Anhänge:

    • css.jpg
      css.jpg
      Dateigröße:
      25,2 KB
      Aufrufe:
      2
  7. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    7.759
    Zustimmungen:
    820
    Diese Datei existiert nicht auf Deinem Server und irgendein völlig unsinniger Mechanismus leitet bei Dir "404 nicht gefunden" Links auf die Startseite weiter, was dann eine neue Instanz von WordPress startet und das Ergebnis runterlädt und was der Browser dann natürlich nicht als CSS interpretieren kann und dann geht es erst weiter... Was sagt der Programmierer des CSS dazu?

    Ergänzend: Für Hilfe bei der Suche nach Ladeproblemen deaktiviere alle Optimierungs-, Minify- und Cache-Plugins, aber das weisst Du ja bereits schon.
     
    #7 b3317133, 30. Mai 2020
    Zuletzt bearbeitet: 30. Mai 2020
  8. madraxx

    madraxx Well-Known Member

    Registriert seit:
    2. Februar 2008
    Beiträge:
    114
    Zustimmungen:
    1
    Der Mechanismus kommt von Rank Math. Aber genau das ist es ja, die Datei gibt es gar nicht mehr und dennoch wird sie von Pagespeed gewertet und verursacht ewige Ladezeiten.... ich hatte die vor 2h entfernt und caches gecleart. Warum die immer noch gewertet wird.., ich weiss es nicht ;/
     
  9. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    7.759
    Zustimmungen:
    820
    Deaktiviere diesen Mechanismus in Rank Math, eine Weiterleitung statt 404 ist nur für einzelne ganz gezielte Links gedacht die irgendwo extern falsch zu Dir verlinkt sind o.ä., alternativ wende Dich an die Person, die dieses Plugin eingerichtet hat, die sollte das wissen und entspr. einstellen können.

    Und schau Dir einfach den HTML-Quelltext Deiner Seite in Deinem Browser an, dann siehst Du den Link zur CSS-Datei, dafür brauchst Du kein Pagespeed... Was sagt der Programmierer des CSS dazu?

    Im HTML-Quelltext sieht man auch, dass weiterhin offenbar Optimierungs-, Minify- oder Cache-Plugins laufen, warum auch immer, offenbar gibt es kein echtes Interesse an Hilfe, bin raus, ist mir zu mühsam. Viel Erfolg.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden