1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

eine php Seite ohne iframe anzeigen

Dieses Thema im Forum "Design" wurde erstellt von heischi, 6. März 2015.

Schlagworte:
  1. heischi

    heischi Active Member

    Registriert seit:
    5. August 2013
    Beiträge:
    33
    Zustimmungen:
    0
    Hallo liebes Forum,
    Habe in einem Unterverzeichnis auf der selben Domain wo das WP liegt eine /../index.php.
    Auf einer neue erstellten WP Seite habe ich <? include ("/../index.php"); ?> eingefügt um die Seite dort innerhalb von Texten anzuzeigen.
    Das funktioniert aber nicht, die indexseite wird nicht angezeigt.
    Mit einem iframe geht es natürlich, das möchte ich aber vermeiden.
    Das Unterverzeichnis ist nicht Bestandteil von WP, es liegt nur auf der gleichen Domain.
    Wie könne es funktionieren?
    Vielen Dank für Eure Hilfe.
     
  2. mensmaximus

    mensmaximus Well-Known Member

    Registriert seit:
    24. Juli 2014
    Beiträge:
    8.728
    Zustimmungen:
    403
    Der include Befehl müsste entweder in das Template oder man schreibt einen shortcode der die Datei includet. Von Plugins die es erlauben PHP Code im Content auszuführen rate ich ab.
     
  3. heischi

    heischi Active Member

    Registriert seit:
    5. August 2013
    Beiträge:
    33
    Zustimmungen:
    0
    Vielen Dank für die Info, also mit einem Shortcode wäre das ideal. Vermute den muß ich in die functions.php von WP einfügen.
    Ein Beispiel würde mir sehr helfen, bin da noch nicht so gut in dem Bereich. Vielen Dank!:p
     
  4. mensmaximus

    mensmaximus Well-Known Member

    Registriert seit:
    24. Juli 2014
    Beiträge:
    8.728
    Zustimmungen:
    403
  5. SirEctor

    SirEctor Well-Known Member
    Ehrenmitglied

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    12.341
    Zustimmungen:
    418
    Du könntest es so versuchen:

    In die functions.php
    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Und dann als Shortcode folgendes verwenden
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Die Datei müsste bei dem Code im Template-Verzeichnis liegen. So kannst du mit einem Shortcode verschiedene Dateien einbinden.
     
  6. heischi

    heischi Active Member

    Registriert seit:
    5. August 2013
    Beiträge:
    33
    Zustimmungen:
    0
    Vielen Dank, leider bekomme ich diese Fehlermeldung:
    Kann man auf der Seite sehen: http://www.mobile-extra.eu/?page_id=1366&preview=true

    das komplette Script liegt ja auf einer anderen Datebank als WP, habe nur die index-auto.php in das Template-Verzeichnis verlegt.
     
    #6 heischi, 6. März 2015
    Zuletzt bearbeitet: 6. März 2015
  7. SirEctor

    SirEctor Well-Known Member
    Ehrenmitglied

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    12.341
    Zustimmungen:
    418
    Lädt die index-auto.php noch andere Dateien per require nach? Dann müsstest du ggf. die Pfade anpassen.
     
  8. mensmaximus

    mensmaximus Well-Known Member

    Registriert seit:
    24. Juli 2014
    Beiträge:
    8.728
    Zustimmungen:
    403
  9. heischi

    heischi Active Member

    Registriert seit:
    5. August 2013
    Beiträge:
    33
    Zustimmungen:
    0
  10. mensmaximus

    mensmaximus Well-Known Member

    Registriert seit:
    24. Juli 2014
    Beiträge:
    8.728
    Zustimmungen:
    403
    Sirector hatte Die schon gepostet, dass die Pfade angepasst werden müssen, da diese relativ erfolgen. Auf den Links die ich Dir gepostet hatte, wird dad teilweise ebenfalls erklärt

    Heißt es nun /xaut/ oder /xauto/ ?
     
  11. heischi

    heischi Active Member

    Registriert seit:
    5. August 2013
    Beiträge:
    33
    Zustimmungen:
    0
    Die Datei liegt im Template-Verzeichnis dort habe ich einen Ordner xaut indem ist die index.php

    Mit [include filepath='/xaut/index.php'] rufe ich die auf.

    In der Datei index.php wird nachgeladen dort steht

    <?php

    require '/xauto/listings.php';


    ?>


    das ist eben:
    www.mobile-extra.eu/xauto/listings.php alle Datein der /xauto haben aber einen andere Datenbank als die von WP als Hintergrund.
    Vermutlich stimmt diese Eingabe zum Nachladen nicht: require '/xauto/listings.php'; kann ich da auch eine http:// eingeben? wenn ja wie genau, oder gibt es einen anderen Weg.

    Vielen Dank!
     
  12. heischi

    heischi Active Member

    Registriert seit:
    5. August 2013
    Beiträge:
    33
    Zustimmungen:
    0
    Das habe ich auch gefunden, in die functions.php am Ende vor ?> eingetragen:


    function show_file_func( $atts ) {
    extract( shortcode_atts( array(
    'file' => ''
    ), $atts ) );

    if ($file!='')
    return @file_get_contents($file);
    }

    add_shortcode( 'show_file', 'show_file_func' );


    Der Shortcode wäre dann:

    [show_file file="http://www.mobile-extra.eu/xauto/index.php"]


    Funktioniert aber auch nicht!!
     
  13. heischi

    heischi Active Member

    Registriert seit:
    5. August 2013
    Beiträge:
    33
    Zustimmungen:
    0
    Jetzt habe ich es auch mit dem Plugin versucht, das besteht nur aus einer Datei da steht:

    function tsIncludeFile($atts,$content=null,$code="") {
    $content = file_get_contents($atts['url']);
    if ($content == true) {
    return $content;
    } else {
    return "An error occured retreiving " . $atts['url'];
    }
    return $atts['url'];
    }


    add_shortcode('include_file','tsIncludeFile');
    ?>

    Das wäre der Shortcode:
    [include_file url="http://www.mobile-extra.eu/xauto/index.php"]

    Und das leider ist die Fehlermeldung:
    Warning: file_get_contents() [function.file-get-contents]: URL file-access is disabled in the server configuration in /onlbnvhn/www.mobile-extra.eu/wp-content/plugins/include-file/include-file.php on line 12

    Warning: file_get_contents(http://www.mobile-extra.eu/xauto/index.php) [function.file-get-contents]: failed to open stream: no suitable wrapper could be found in /onlbnvhn/www.mobile-extra.eu/wp-content/plugins/include-file/include-file.php on line 12
    An error occured retreiving http://www.mobile-extra.eu/xauto/index.php





     
  14. aturo

    aturo Well-Known Member

    Registriert seit:
    26. Dezember 2012
    Beiträge:
    84
    Zustimmungen:
    0
    Funktioniert den deine Datei wenn du sie direkt aufrufst? Du kannst sie auch mit get_template_part('datei') ins template einbinden.
     
  15. heischi

    heischi Active Member

    Registriert seit:
    5. August 2013
    Beiträge:
    33
    Zustimmungen:
    0
    Vielen Dank für eine Rückmeldung!
    Habe nun eingebunden
    <?php get_template_part('index-auto.php')
    ?>

    Also die Datei ist nun index-auto.php
    Das Problem ist aber nach wie vor das in der index-auto.php steht:

    <?php


    require '/xauto/listings.php';


    ?>


    Das sollte eigentlich von dort aufgerufen werden: www.mobile-extra.eu/xauto/listings.php
    Diese Datei und alles was weiter folgt liegt aber auf einer anderen Datenbank als auf der WP wo ich die index-auto.php jetzt eingebunden habe.

    Spreche ich nun direkt die http://www.mobile-extra.eu/wp-content/themes/index-auto.php an, kommt auch hier der gleiche Fehler:
    Warning: require(/xauto/listings.php) [function.require]: failed to open stream: No such file or directory in /onlbnvhn/www.mobile-extra.eu/wp-content/themes/index-auto.php on line 3

    Fatal error: require() [function.require]: Failed opening required '/xauto/listings.php' (include_path='.:/usr/local/php5/lib/php') in /onlbnvhn/www.mobile-extra.eu/wp-content/themes/index-auto.php on line 3


    Es wird mir zwar wiederholt erklärt den Pfad anzupassen, aber wie?dorthin soll es gehen: www.mobile-extra.eu/xauto/listings.php was ich auch in die php require '/xauto/listings.php'; dazu reinschreibe funktioniert nicht!
    Im Prinzip geht es darum ein iframe zu vermeiden und die Seite in WP direkt auf einer Seite aufzurufen, das sollte ja mit einem shortcode funktionieren, doch das Hauptproblem scheint require in der index-auto.php zu sein.





     
  16. heischi

    heischi Active Member

    Registriert seit:
    5. August 2013
    Beiträge:
    33
    Zustimmungen:
    0
    Habe nun das Verzeichnis /xauto in das Template-Verzeichnis verlegt. Jetzt kann man auch die index.php direkt fehlerfrei aufrufen, die ganze Seite kommt fehlerfrei. Wenn ich aber den Shortcode in eine Seite einbaue bekomme ich als Fehlermeldung: Failed opening required '/inc-confdata.php' (include_path='.:/usr/local/php5/lib/php') er zeigt mir die Zeile2 wo der Zugriff auf die Datenbank steht an.
    Diese Datenbank ist nicht die gleiche in der das WP liegt? Kann das der Grund sein? Wie kann ich das Problem beheben?
     
    #16 heischi, 13. März 2015
    Zuletzt bearbeitet: 13. März 2015
  17. heischi

    heischi Active Member

    Registriert seit:
    5. August 2013
    Beiträge:
    33
    Zustimmungen:
    0

    Bitte um weitere Hilfe, da komme ich jetzt nicht weiter !!!

    Habe es nun neu wie unten beschrieben angelegt, alle Versuche auch mit Plugins ergeben immer wieder den selben Fehler:
    es endet beim Datenbankzugriff, es wird als Fehler die Zeile $dbhost = ..... angezeigt:
    <?php
    $dbhost = .....
    $dbuser = .....
    $dbpass = .....
    $session_path = '';

    Hier nochmals wie alles angeordnet ist:

    Habe unter wp-content/theme/<themename>/meinetemplate.php ein Seiten-Template mit einer php include angelegt .
    Das Template kann ich beim erstellen einer Seite unter Template auswählen.

    Es wird die index.php des Scripts aufgerufen, doch es kommt eine Fehlermeldung die anzeigt, daß bei der Abfrage der confdata.php des Scrips der Datenbankzugriffe nicht möglich ist.
    Die Datenbank des Scripts ist nicht die gleiche wie von WP.

    Versuche ich einen anderen Weg über einen [Shortcode] dazu gibt es in der functions.php den passenden Eintrag, erhalte ich die selbe Fehlermeldung.
    Das komplette Script liegt in einem Ordner der unter wp-content/theme/<themename>/ angeleg ist.
    Wenn ich den kompletten Pfad im Browser eingebe funktioniert das Script einwandfrei.
    Wie kann ich das Script über die WP Seite richtig ansprechen, oder welche Einstellungen sind noch erforderlich?
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden