1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Einlogen als User funktioniert nicht

Dieses Thema im Forum "Konfiguration" wurde erstellt von vivien, 25. September 2021.

  1. vivien

    vivien Well-Known Member

    Registriert seit:
    3. April 2018
    Beiträge:
    110
    Zustimmungen:
    1
    Hallo,

    ich versuche mit einem User (und nicht mit dem Admin) auf ein Kommentar im Blog zu antworten. Dafür muss ich mich mit dem User anmelden (wp-login.php statt wp-admin). Doch die Anmeldung funktioniert nicht.

    Ich habe ein Admin- und ein Autor-Konto. Eben dieses Autor-Konto kann ich zwar für die Erstellung der Blogeinträge wählen, aber nicht um auf ein Kommentar einzugehen.

    Es läuft WP 5.8.1 und NinjaFirewall, jedoch verstehe ich nicht, welche Einstellung das Einlogen eines Users blocken sollte.


    Hat jemand eine Idee, woran das liegen kann?
    Danke!
    vivien
     
  2. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    9.291
    Zustimmungen:
    1.154
    Der Login-Link bei WordPress für die Rollen Administrator und Autor ist normalerweise identisch.

    Was funktioniert bei der Anmeldung nicht? Link zur Seite?

    Deaktiviere das Plugin NinjaFirewall, ändert das etwas bzgl. des nicht funktionierenden Login-Links?

    Und was genau ist mit "auf Kommentare eingehen" gemeint? Einen Antwortkommentar schreiben? Das kann ein Autor und jeder sonstige, der Kommentare abgeben kann. Oder die Kommentare moderieren/freischalten/löschen? Das kann eine Autor Rolle standardmässig nicht.

    Mehr zu den Rollen z.B. hier in der WordPress Dokumentation.
     
  3. vivien

    vivien Well-Known Member

    Registriert seit:
    3. April 2018
    Beiträge:
    110
    Zustimmungen:
    1
    ah, ok... also melde ich mich mit einem User auch bei /wp-admin an und nicht bei /wp-login.php?
    Funktioniert allerdings ebenfalls nicht.

    Mit NinjaFW bekomme ich beim wp-admin als User: ERROR: Invalid username, email address or password.
    Und: NinjaFirewall brute-force protection is enabled and you are temporarily whitelisted.

    Wenn ich das Plugin deaktiviere: Fehler: Das Passwort, das du für den Benutzernamen ljsdf8379f eingegeben hast, ist nicht korrekt.

    Jetzt habe ich das Mysterium gelöst... warum auch immer, hatte ich ein anderes Passwort drin.
    Es lag also an der Banalität eines falschen Passworts. Sorry :D

    Jetzt funktionierts auch problemlos mit der Firewall.

    Dennoch danke!
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden